Jump to content

Sumar números que están como texto


Recommended Posts

Buena noche

Favor su ayuda con la siguiente novedad, ya que no puedo sumar los datos que están en la columna D, he intentado con la formula en mención pero nada, alguna sugerencia que me pueda servir...

image.thumb.png.f7c5af493cb975d07a1ff5132276d040.png

Mil gracias 

Libro1.xlsx

 

Link to comment
Share on other sites

¡Saludos @kai7as!

Hay varias técnicas para realizar lo que pides:  desde el uso de las viejas macrofunciones v 4.0 hasta una fórmula matricial.

Te dejo una opción de introducción no matricial:

=SUMAPRODUCTO(XMLFILTRO("<a><b>"&SUSTITUIR(SUSTITUIR(D2;".";",");" + ";"</b><b>")&"</b></a>";"//b"))

Nota: La sustitución del "." por la "," es asumiendo que el separador decimal es la ","

¡Bendiciones!

Link to comment
Share on other sites

hola @kai7as! y (John😍)

 

y en caso de esto:

Hace 59 minutos , John Jairo V dijo:

Nota: La sustitución del "." por la "," es asumiendo que el separador decimal es la ","

la fórmula de John 😍quedaría así:

=SUMAPRODUCTO(XMLFILTRO("<a><b>"&SUSTITUIR(D2," + ","</b><b>")&"</b></a>","//b"))

saludos,

Silvia

Link to comment
Share on other sites

Hace 9 horas, John Jairo V dijo:

¡Saludos @kai7as!

Hay varias técnicas para realizar lo que pides:  desde el uso de las viejas macrofunciones v 4.0 hasta una fórmula matricial.

Te dejo una opción de introducción no matricial:

=SUMAPRODUCTO(XMLFILTRO("<a><b>"&SUSTITUIR(SUSTITUIR(D2;".";",");" + ";"</b><b>")&"</b></a>";"//b"))

Nota: La sustitución del "." por la "," es asumiendo que el separador decimal es la ","

¡Bendiciones!

Hola John  && Silvia mil gracias por sus respuestas me  han ayudado resto, sobre la función XMLFILTER no la conocía la voy a estudiar, mil gracias de nuevo... Dios los siga bendiciendo.

Link to comment
Share on other sites

Hola j

Hace 10 horas, John Jairo V dijo:

¡Saludos @kai7as!

Hay varias técnicas para realizar lo que pides:  desde el uso de las viejas macrofunciones v 4.0 hasta una fórmula matricial.

Te dejo una opción de introducción no matricial:

=SUMAPRODUCTO(XMLFILTRO("<a><b>"&SUSTITUIR(SUSTITUIR(D2;".";",");" + ";"</b><b>")&"</b></a>";"//b"))

Nota: La sustitución del "." por la "," es asumiendo que el separador decimal es la ","

¡Bendiciones!

Hola Jhon te quería molestar y preguntar, si esta misma lógica se podría ejecutar en google sheets... ??  o que formula reemplazaría XMLFILTRO en google sheets. Mil gracias

Link to comment
Share on other sites

Hola a todos,

Tal vez puedan servir también los métodos ancianos...

Sitúate en C1 (primera celda a evaluar).

Teclea Ctrl+F3 (te aparecerá el 'Administrador de nombres'), haz clic en Nuevo, en 'Nombre' introduce abc, y en 'Se refiere a:' introduce =EVALUAR(D2), y haz clic en 'Aceptar'.

Ahora, remarca el rango C2:C20 (o hasta la última fila donde tengas datos), pulsa F3 y manteniendo pulsada la tecla 'Ctrl' haz doble clic en abc y pulsa INTRO.

Si todo ha ido bien, ya deberías haber obtenido las sumas.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Nota 1: Mi separador decimal es la coma, así que la primera operación que he tenido que hacer ha sido sustituir los puntos de tus cantidades por comas para lograr el resultado. Por tu archivo, interpreto que tu separador decimal es el punto, así que, en principio no deberías hacer ninguna sustitución.

Nota 2: No sé si este procedimiento sirve para Google Sheets; en Excel no debería haber problemas, incluso en versiones antiguas.

Saludos,

Link to comment
Share on other sites

¡Saludos a todos!

Hace 11 horas, kai7as dijo:

esta misma lógica se podría ejecutar en google sheets... ??

No.  En Google Sheets no existe la función XMLFILTRO.   Ten en cuenta que este no es un foro de Google Sheets, sino de Excel.  Sin embargo, te doy una opción con esa hoja de cálculo:

=SUMA(SPLIT(C1," + "))

Nota: El tema de los nombres de funciones que te comenta @Victor7 tampoco está disponible para Google Sheets.

Nota2: Si tu separador decimal es la "," tendrás que hacer la sustitución del punto por la "," de igual forma.  ¡Bendiciones!

Link to comment
Share on other sites

Hace 4 minutos , John Jairo V dijo:

¡Saludos a todos!

No.  En Google Sheets no existe la función XMLFILTRO.   Ten en cuenta que este no es un foro de Google Sheets, sino de Excel.  Sin embargo, te doy una opción con esa hoja de cálculo:

=SUMA(SPLIT(C1," + "))

Nota: El tema de los nombres de funciones que te comenta @Victor7 tampoco está disponible para Google Sheets.

Nota2: Si tu separador decimal es la "," tendrás que hacer la sustitución del punto por la "," de igual forma.  ¡Bendiciones!

Gracias Jhon Jairo por compartir la formula, si se que no es un foro de google sheets, es que estaba trabajando con ambos, de todas maneras Mil gracias por sus aportes me han servido demasiado, Dios los siga bendiciendo.

Link to comment
Share on other sites

Hola de nuevo a todos,

Hace 4 horas, Gerson Pineda dijo:
=SUMA(--DIVIDIRTEXTO(D2," + "))

😲😲😲😲

¿¿¿ DIVIDIRTEXTO ????

Gerson, creo que voy a elevar una enérgica queja a MS... me acaba de llegar la factura de renovación para M365 y no veo por ningún sitio tal función. ¿Tal vez tienes algún privilegio especial para disfrutar de más prerrogativas que el común de los mortales? 🤣

🤣🤣 Saludos cordiales,

Link to comment
Share on other sites

Hace 6 horas, Victor7 dijo:

Gerson, creo que voy a elevar una enérgica queja a MS... me acaba de llegar la factura de renovación para M365 y no veo por ningún sitio tal función.

Para que esa queja sea un tanto fructífera, llama a @Abraham Valencia para que te acompañe a la corte jaja

Estoy en el canal actual, aunque aparecieron antes para los que están en el programa insider

Hace 6 horas, Victor7 dijo:

¿Tal vez tienes algún privilegio especial para disfrutar de más prerrogativas que el común de los mortales? 🤣

¡Ya quisiera! aquí los únicos privilegiados, son los que crearon Excel, como el mismo @Abraham Valencia ... que ya lo sabe😅

Link to comment
Share on other sites

Hola de nuevo, @Gerson Pineda

¡¡¡ INCREÍBLE !!!  Gracias por compartir el vídeo de Sergio; me he quedado sorprendido² (al cuadrado) 😲 con esas novedades de Excel. Ya suponía que sólo las podían disfrutar los Insider, pero la verdad es que van a simplificar muchas cosas corrientes que ahora necesitan varios pasos y a menudo con complejidades al formular.

Lo malo es que se nos va a olvidar que existen funciones como =DESREF (que, dicho sea de paso, a veces hace auténtica magia)... y es una de las que más utilizamos para conseguir lo que en un futuro cercano (esperemos) podremos hacer de forma más fácil e intuitiva.

A ver si Microsoft las libera pronto; creo que será un verdadero boom.

Saludos cordiales,

Link to comment
Share on other sites

Hola amigos, ojo a algo que justo le comenté a Sergio estas últimas semanas y lo he dicho también en un par de foros, Office Insider tienes dos canales, el Canal Preview y el Canal Beta, siendo los miembros de ese último canal los que reciben inicialmente todas las nuevas funciones de Excel así como las nuevas características.  Es decir, no basta tener suscripción a Microsoft 365, sino que necesariamente hay que inscribirse al programa Insider y agregarse a algún canal,  recomiendo el Beta.  Saludos.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Privacy Policy