Jump to content

Silvia

Moderators
  • Posts

    3,156
  • Joined

  • Last visited

  • Days Won

    127

Everything posted by Silvia

  1. Hola Oscar si, tienes razón, sin embargo, no aseguro, pero me parece que los datos siempre estarán ordenados de acuerdo al cambio de conductor, el que sale y entrega la posta al que inicia.. bueno, me parece.. pero..... de todas formas tu solución es excelente.. saludos.. Silvia
  2. pruébala bien, cambia fechas y me confirmas.. porque yo no estoy tan segura, no lo he probado mucho.. saludos..
  3. hola adjunto una opción Ejemplo consumos combustible sq.xlsx
  4. hola Pirtrafilla como haces para coincidir los conductores? , por ejemplo entiendo que hay que buscar la fecha de consumo, en la hoja conductores...¿..? no veo ninguna coincidencia, con que columna de la hoja Conductores, comparas la fecha de Consumo¿? saludos, Silvia
  5. hola José Mira este enlace de Youtube saludos, Silvia
  6. Adjunta un ejemplo... Así como has mostrado el problema, no sé que solución se te puede dar....
  7. hola inunagu 🙄 Pues resta a las 8 el tiempo que va a demorar en conducir, pausas, descanso obligatorio, carga , descarga.. etc... a esa hora se tiene que levantar saludos, Silvia
  8. hola xjujuxjuxju Te adjunto un ejemplo... si te inscribes, tienes mas posibilidades de ayuda, podrás incluir tu libro excel en la consulta, con lo que será mas fácil entender tu necesidad.. espero te sea de utilidad.. libro xjux.xlsx
  9. hola @kai7as! y (John😍) y en caso de esto: la fórmula de John 😍quedaría así: =SUMAPRODUCTO(XMLFILTRO("<a><b>"&SUSTITUIR(D2," + ","</b><b>")&"</b></a>","//b")) saludos, Silvia
  10. hola Luisma Quizás no me dejé entender con esto No me refería a una imagen, sino a tu archivo en excel, con una muestra de lo que tienes y otra de lo que quieres, a mi modo de ver (sin archivo), la solución que te di, es lo que necesitas.. (Incluso si tus datos están en diferentes libros... , caso en el cual, quizá sería mejor tu consulta por el foro de Macros) saludos, Silvia
  11. hola LUISMA tal vez con una fórmula, puedas buscar un listado en el otro.., algo así (si.error( buscarv( ),"") Si no te sirve la idea, te sugiero adjuntar una muestra de tu archivo, . saludos Silvia
  12. hola CSI1981 esto que solicitas... solo con macros revisa el siguiente link https://www.excel-avanzado.com/24539/beforeclose-en-vba.html saludos Silvia
  13. hola olivia_rogers (y torquemada 😉 a los tiempos....) otra opción, para los días de la semana =TEXTO(E8,"dddd") Mi separador de argumentos es la coma, si el tuyo es otro, corriges E8 es la celda con la fecha y claro, esperando que la fecha esté ingresado como fecha y no como texto. saludos Silvia
  14. Es lo más probable.. 😀 gracias! 😃
  15. hola a todos yo dejo otra opción, solo que hay una que no me cuadra. Es por esto Si alguno de los MC no están Realizado, la columna ""finalizado"" será ""No"" 🙄 saludos, Silvia procesos Sq.xlsx
  16. y @Albertcm23 no vino a ver su respuesta... 🙄
  17. Sería bueno que termines de explicar todos los pormenores. En tu ejemplo tu base de datos termina en la fila 36, en F solo tienes 31 datos, V9 sería el último resultado con 25 filas que contienen números; de ahí en adelante, cual es el resultado que debe salir? Silvia
  18. Hola Viciana Dices que en V3 deseas el promedio de los últimos 25 datos de F eso quiere decir que deseas promediar >> {1;2;15;20;36;54;568;455;158;54956;4;6;5;56;7;8;8;10;2;0;8;8;88;8;8} , es decir desde F9 Hasta F36? y en V4, sería lo mismo porque los últimos 25, siempre serán los últimos 25... ....(?) y se toma en cuenta los datos en blanco?, en realidad los últimos 25 seria desde F12 hasta F36. Creo que no estoy entendiendo.. Saludos, Silvia
  19. hola Albertcm23 si Adjunta tu excel, recibirás mas y mejor ayuda saludos Silvia
  20. hola Javierc Elimina los Rangos Nombrados, que ya de por sí, todos están con error. Saludos Silvia fuente: revisar
  21. hola javierc y njnsp yo lo que haría sería ir al final de mi área de trabajo y seleccionar desde ahí hacia el final y eliminar celdas, tanto a la derecha, como hacia abajo.. ¿..? saludos Silvia
  22. hola, Obviamente que si tiene fecha, entonces, no está vacía.. Entonces solo necesitas considerar si hay celdas con fechas menores a las de la fila 17 me parece que esto es suficiente... =--(CONTAR.SI($B3:$B13,"<"&F17)>0) y si no fuera eso, insisto, debes explicar mejor, lo que deseas hacer.. saludos Silvia
  23. hola Javierc (y njnsp) De acuerdo 100% con todo lo que njnsp menciona. Te refieras a que si en el rango B3:B13, existieran celdas con fechas y además, existieran celdas con Fechas menores a digamos F17... (31/01/2023) Desde el momento en que cualquier celda del rango B3:B13 , tenga fecha menor a 31/01/2023, ya no necesitas la primera condición.. así mismo esto: primero dices >0, luego dices = a 0 ¿...? Creo que debes releer todo lo que posteaste y explicar claramente, que es lo que necesitas. Por cierto, tal vez un contar.si te ayude.. Cuentas si hubieran celdas en la columna B que sean menores a F17, si fuera verdadero, entonces1, caso contrario 0. saludos Silvia
×
×
  • Create New...

Important Information

Privacy Policy