Jump to content

John Jairo V

Moderators
  • Posts

    3,725
  • Joined

  • Last visited

  • Days Won

    221

Everything posted by John Jairo V

  1. Hola @Janlui... con todo respeto, te diría no apliques Nompropio. Observa este link: https://www.rae.es/espanol-al-dia/mayuscula-o-minuscula-en-los-meses-los-dias-de-la-semana-y-las-estaciones-del-ano#:~:text=Salvo que la mayúscula venga,pasado martes%2C 22 de noviembre.
  2. ¡Hola a todos! Una solución sencilla podría ser: =TEXTO(B14*30;"mmmm") ¡Bendiciones!
  3. ¡Hola a todos! En primer lugar, parece que este tema lleva 7 meses de preguntado, por lo que no se si el consultante verá las respuestas que cada uno de ustedes ha posteado. En segundo lugar, el consultante comenta explícitamente que las macros no son permitidas para la solución que se plantee... así que, a pesar que puede servir a modo de ejercicio @Janlui, no creo que sea adoptada tu respuesta. Y, en tercer lugar, pues ya que estamos, demos otra opción con fórmulas matriciales del asunto. ¡Bendiciones! Nota: Mi separador decimal es la ",", por lo que añadí a la fórmula el sustituir la "," por nada para que no se tomara en cuenta como decimal. Si es el caso del consultante en que el separador decimal es el ".", se puede omitir ese sustituir adicional. SumaLetras.xlsx
  4. ¡Saludos a todos! Otra opción, en Google Sheets (la cual es muy similar en Excel), puede ser: =REDOND.MULT(A5%,0.5) El separador de argumentos, decimal e idiomas en las funciones depende de la configuración regional y de idioma de tu equipo y/o la configuración en el mismo Google Sheets. La misma opción, en inglés: =MROUND(A5%,0.5) ¡Bendiciones!
  5. ¡Hola a ambos! Una forma, según lo que se entiende de tu solicitud, puede ser: =DIAS.LAB(D6;SI(E6;E6;HOY()))-1 ¡Bendiciones!
  6. ¡Hola, @gogua! El tema de los rangos expandibles en tabla tienen un comportamiento "peculiar" cuando llegan al final de la misma. Entonces, una opción para trabajar con ellos es "jugar" con las referencias estructuradas. Tu fórmula, al tener un solo criterio, puede usarse con la función SUMAR.SI de la siguiente forma: =SUMAR.SI(C$7:[@CODIGO];[@CODIGO];J$7:[@[Ent./Sal.]]) ¡Pruébala y comentas! ¡Bendiciones!
  7. ¡Hola @Pirtrafilla! Los comodines en la función SUMAR.SI solamente trabajan con textos, no con números. Dicho esto, puedes usar como alternativa la función SUMAPRODUCTO, de la siguiente forma: =SUMAPRODUCTO(--(IZQUIERDA(F$2:F$8;4)=A2&"");G$2:G$8) ¡Bendiciones!
  8. ¡Hola a todos! Para "redondear" el tema, algunos comentarios: 1. El atajo Ctrl + E Funciona en "todas" las versiones de Excel, excepto en Excel 2013. Esto es porque cuando introdujeron la herramienta "relleno rápido" en Excel, ésta adoptó este atajo de teclado, desplazando la selección a Ctrl + Shift + E. Luego, en 2016, se acomodaron las cosas y se invirtieron los atajos: Ctrl + E para la selección y Ctrl + Shift + E para el relleno rápido. 2. El atajo Ctrl + * también funciona tanto en teclado numérico (directo) como en teclado alfanumérico (con shift). Lo que sucede es que en teclado alfanumérico el * (en configuración de teclado latino o español) se encuentra "arriba" en la tecla, lo que hace que se deba usar el Shift para "alcanzarla". 3. Otro atajo para lo mismo: Ctrl + Shift + Barra Espaciadora, dentro de los datos. 4. Otro más, aunque no "tan directo": Ctrl + Shift + Flecha Derecha + Flecha Abajo (o viceversa en las flechas), estando parado en la celda superior izquierda del rango seleccionado. De igual forma se juega con este atajo dependiendo de la posición de la celda activa dentro del "rango alrededor", y también de la "completitud" de la columna o fila desde donde esté la celda activa (se puede "cortar la inspiración" con celdas en blanco). ¡Bendiciones!
  9. ¡Hola a ambos! Adjunto otra propuesta. ¡Bendiciones! Busqueda Aproximada - dos condiciones.xlsx
  10. ¡Hola @fisper! Revisa el adjunto, con una propuesta. ¡Bendiciones!ejemplo repeticion.xlsx
  11. ¡Hola de nuevo! @GabrielRaigosa, la razón del SI.ERROR(... 1+ CONTARA) es por si el usuario coloca la última fecha (en el ejemplo de la tabla, es el 12/04/2021), donde al ser 100% no habrían fechas por debajo de ésta. Tu opción 2 genera error por este motivo. ¡Bendiciones!
  12. ¡Hola a todos! Si te he entendido bien, puedes probar con lo que te muestro en el adjunto. ¡Bendiciones! EJEMPLO 1.xlsx
  13. ¡Hola a ambos! @YOUSAFJAMALD, para la próxima, sube un archivo Excel en vez de una imagen. Nos ayuda mucho más a ayudarte. Ahora, en cuanto a tu problema y como bien te comenta @DiegoPC, efectivamente, con la función BUSCAR "solita", el problema no es posible realizarlo, pero con "ayuda" si que es posible. =BUSCAR(2;1/FRECUENCIA(0;1/(1+(K$37:K$43<=N37)*K$37:K$43));L$37:L$43) otra alternativa un poco más "digerible": =INDICE(L$37:L$43;COINCIDIR(MAX(INDICE(K$37:K$43*(K$37:K$43<=N37);));K$37:K$43;)) o también usar la función BUSCARX (solo disponible en Microsoft 365 / Excel 2021 / Excel Online 😞 =BUSCARX(N37:N63;K37:K43;L37:L43;"No Existe";-1) Analiza detenidamente las propuestas. ¡Bendiciones!
  14. ¡Hola, @zelarra821! y... ¿por qué no, simplemente, alguna de las siguientes? =MULTIPLO.SUPERIOR(A2;0,05) =MULTIPLO.SUPERIOR(A2;5%) ¡Bendiciones!
  15. ¡Hola de nuevo @Patrick Marabote! Si he entendido bien, esto puede servirte: =SI(B2 < A2 ; B2 ; 0) Dando formato de "hora" al resultado. ¡Bendiciones!
  16. Dejo dos opciones: =RESIDUO(B2 - A2; 1) =B2 - A2 + (B2 < A2) Siendo A2 y B2 las celdas donde están los horarios. ¡Bendiciones!
  17. ¡Hola a ambos! Dejo una opción en el adjunto, "parecida" a una de las opciones del gran Héctor (un saludo). Coloco unas "correcciones de 1 segundo" en las comparaciones por el tema de errores por coma flotante en Excel. ¡Bendiciones! Horas por intervalo.xlsx
  18. ¡Hola @Patrick Marabote! De acuerdo con lo que se entiende, pudieses usar lo que te propongo en el adjunto. ¡Bendiciones! Horas por intervalo 1.xlsx
  19. ¡Hola a ambos! Ya teniendo la fecha anterior, puedes usar esta fórmula: =INDICE(E14:E23;COINCIDIR(1;INDICE((F14:F23>8)/(E14:E23>J17););)) ¡Bendiciones!
  20. Hola a ambos! Una de varias opciones: =INDICE(E14:E21;COINCIDIR(1;INDICE(--(F14:F21<5););)) Bendiciones!
  21. ¡Hola, @Hbarreto.py! Una forma de hacerlo: =B4:INDICE(B4:M4;COINCIDIR(B1;B3:M3;)) ¡Bendiciones!
  22. ¡Hola de nuevo, @CarlosKurt! Este nuevo problema fue más interesante. Se tuvo que resolver con ayuda de cálculos intermedios por lo "complejo" del mismo. Estos cálculos intermedios corresponden a nombres formulados. Revisa con detalle el adjunto. ¡Bendiciones! PRUEBA Excel.xlsx
  23. ¡Hola, @edilbertosb! ( y @njnsp ) Revisa el adjunto, con una propuesta. ¡Bendiciones! dias-por-mes.xlsx
  24. Hola de nuevo, @CarlosKurt: Revisa las siguientes funciones, como opción: TTL Cantidad [N5] : =MAX(SI((B3:B20=H4)*(C3:C20=I4)*(MAX((B3:B20=H4)*(C3:C20=I4)*D3:D20)=D3:D20);F3:F20)) PROMEDIO [M5] : =MIN(SI((B3:B20=H4)*(C3:C20=I4)*(MAX((B3:B20=H4)*(C3:C20=I4)*D3:D20)=D3:D20)*(F3:F20=N5);E3:E20)) ¡Bendiciones!
  25. ¡Hola, Carlos! No termino de entenderte del todo. Escribe por favor de nuevo lo que necesitas con 3 ejemplos representativos... porque, según veo, solo necesitas el mínimo valor de las cantidades máximas iguales más recientes de un producto y un estado específico. Los ejemplos, por favor en el archivo Excel, no en imágenes. ¡Bendiciones! ¡Bendiciones!
×
×
  • Create New...

Important Information

Privacy Policy