Jump to content

John Jairo V

Moderators
  • Posts

    3,758
  • Joined

  • Last visited

  • Days Won

    231

Everything posted by John Jairo V

  1. ¡Un regalito para todos! Espero les sea de utilidad. ¡Bendiciones!
  2. ¡Saludos @Hbarreto! Una opción para resolver, sería: =LET(c;A2:A40;UNICOS(FILTRAR(c;MMULT(--(CONTAR.SI.CONJUNTO(c;c;C2:C40;{"ROTO"\"CUMPLIDO"})>0);{1;1})=2))) ¡Bendiciones!
  3. ¡Saludos @Jose Martinez! Dejo dos opciones en el adjunto. Una compatible con tu Excel 2010, y otra con Microsoft 365. ¡Bendiciones! Como averiguar si trabaje entre dos horas.xlsx
  4. Saludos compatriota @GabrielRaigosa. Revisa el adjunto, donde te dejo una propuesta. ¡Bendiciones! Ordenar matriz ✖.xlsx
  5. ¡Saludos @Compumakro! Para resolver tu caso, una herramienta fundamental es SUBTOTALES, la cual hace exactamente lo que pides. Verifica el siguiente link, donde puedes averiguar cómo funciona: https://support.microsoft.com/es-es/office/insertar-subtotales-en-una-lista-de-datos-en-una-hoja-de-cálculo-7881d256-b4fa-4f81-b71e-b0a3d4a52b3a ¡Bendiciones!
  6. ¡ Saludos @GabrielRaigosa ! Si se requiere con números... basta hacer un "pequeño" ajuste: =SI.ERROR(--DIVIDIRTEXTO(UNIRCADENAS(REPETIR(" ";1+E2);;SECUENCIA(C2));;" ");"") Tal cual como has comentado, depende de las necesidades del consultante. De igual forma, por diversión, dejo otra más: =LET(e;1+E2;n;SECUENCIA(C2*e-E2)-1;SI(RESIDUO(n;e);"";1+ENTERO(n/e))) Y... reduciendo un poco la ya propuesta: =LET(e;1+E2;n;SECUENCIA(C2*e-E2;;;1/e);SI(ENTERO(n)=n;n;"")) ¡Bendiciones!
  7. ¡Saludos @Hbarreto! (y a todos los participantes del tema). Otra forma (teniendo en cuenta el archivo de @Oscar_MRF) : =DIVIDIRTEXTO(UNIRCADENAS(REPETIR(" ";1+E2);;SECUENCIA(C2));;" ") ¡Bendiciones!
  8. Saludos @jesuspg Esto es porque estás usando la función MES dentro de la función TEXTO. si la quitas, tendrás el nombre del mes correcto: =SI(ESBLANCO([@[FECHA DE LA COMUNICACION]]);"";MAYUSC(TEXTO([@[FECHA DE LA COMUNICACION]];"MMMM"))) ¡Bendiciones!
  9. ¡Saludos a todos! Una opción, según lo que se te entiende de este mensaje: Podrías usar, simplemente: =(A1>0)*SUMAR.SI(A2:A3;"<0") ¡Bendiciones!
  10. ¡Hola a todos! Dejo otra opción... dejando las celdas combinadas tal cual y como están. ¡Bendiciones! CeldasCombinadas.xlsx
  11. Nota: Por orden de "la jefa" (ella Sabe quIén es, literaLmente 😂🤣)... y claramente, para el consultante y todos los interesados, informo que la fórmula de fondo gris es de introducción matricial. Es decir, no se debe introducir con un simple Enter, sino con Control + Shift + Enter (CSE). ¡Bendiciones!
  12. Saludos @Ruben_sk8. No soy el maestro @Antoni, pero quizá te puede servir lo que te muestro en el adjunto. ¡Bendiciones! RepetirDatosSegúnFrecuencia.xlsx
  13. ¡Saludos @kai7as! Recomiendo que en preguntas de Google Sheets lo hagas en un foro de Google Sheets. Sin embargo, por acá te va una ayuda: =ArrayFormula(UNIQUE(FLATTEN(SPLIT(A1," + "))) & " = " & COUNTIF(SPLIT(A1," + "),UNIQUE(FLATTEN(SPLIT(A1," + "))))) ¡Bendiciones!
  14. ¡Saludos a todos! No. En Google Sheets no existe la función XMLFILTRO. Ten en cuenta que este no es un foro de Google Sheets, sino de Excel. Sin embargo, te doy una opción con esa hoja de cálculo: =SUMA(SPLIT(C1," + ")) Nota: El tema de los nombres de funciones que te comenta @Victor7 tampoco está disponible para Google Sheets. Nota2: Si tu separador decimal es la "," tendrás que hacer la sustitución del punto por la "," de igual forma. ¡Bendiciones!
  15. ¡Saludos @kai7as! Hay varias técnicas para realizar lo que pides: desde el uso de las viejas macrofunciones v 4.0 hasta una fórmula matricial. Te dejo una opción de introducción no matricial: =SUMAPRODUCTO(XMLFILTRO("<a><b>"&SUSTITUIR(SUSTITUIR(D2;".";",");" + ";"</b><b>")&"</b></a>";"//b")) Nota: La sustitución del "." por la "," es asumiendo que el separador decimal es la "," ¡Bendiciones!
  16. ¡Saludos a ambos! Otra opción: =SUMA(CONTAR.SI(G457:AK457;{"*F*";"F"})*{1;-1}) ¡Bendiciones!
  17. ¡Saludos a ambos! Según lo veo, la fórmula "larga" se puede simplificar así: =(CONTAR(D7:E7)=2)*MEDIANA(;(1+$T$3-D7)/(1+E7-D7);1) En la cual fijo completamente T3 para que pueda copiarse a la derecha en las otras diferencias que tienes. ¡Verifícalo! ¡Bendiciones!
  18. ¡Saludos a todos! @HbarretoUna forma es "rearmar" los criterios creando las combinaciones. Revisa el adjunto. ¡Bendiciones! CONTAR.O.CONJUNTO.xlsx
  19. ¡Saludos a todos! Dejo una opción con formulación 365 en el adjunto. ¡Bendiciones! sustituciones.xlsx
  20. ¡Saludos @JUL AYALA! Algunas opciones: =SI.ND(INDICE(Historial!A$2:A$53591;COINCIDIR(A2;Historial!B$2:B$53591;));"") =BUSCARX(A2;Historial!B$2:B$53591;Historial!A$2:A$53591;"") ¡Bendiciones!
  21. ¡Saludos a ambos! Otra forma de solucionar, puede ser: =SUMAPRODUCTO(E3:E$31;--(ENTERO(C3:C$31)=C2)) ¡Bendiciones!
  22. ¡Saludos a todos! Solo para aportar que no necesitamos de una función "extra" para el tema de los "errores de división". Aplicando el "padding" a la función DIVIDIRTEXTO obtenemos el mismo resultado. Quedamos entonces, así: =DIVIDIRTEXTO(UNIRCADENAS("|";;B2:B6);",";"|";;;"") ¡Bendiciones a todos!
  23. Hola a todos! Lo de la franja horaria: =COINCIDIR(A1;{0;6;14;18}/24) Siendo A1 la hora. Bendiciones!
  24. ¡Hola a todos! Otra opción, podría ser la que te muestro en el adjunto. ¡Bendiciones! AYUDA CON FORMULA.xlsx
  25. ¡Hola @raizor! Efectivamente es posible lo que pides. Según muestras en la lista, los datos los tienes en el rango A1:A9. Entones, puedes probar con la siguiente fórmula: =SUMAR.SI(A2:A9;"";A1:A8) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
×
×
  • Create New...

Important Information

Privacy Policy