Saltar al contenido

Gerson Pineda

Administradores
  • Contador de contenido

    10692
  • Unido

  • Última visita

  • Days Won

    249

Sobre Gerson Pineda

  • Rango
    Miembro

Formas de contacto

  • Web http://gerson-pineda-el-catracho.blogspot.com/

Información de perfil

  • Sexo Hombre
  • Localización: Honduras - Excel 2016

Configuraciones

  • Campo que utilizas como separador de argumentos ,

Visitantes recientes del perfil

2889 visitas de perfil
  1. Hola avp Como notaras sin libro es difícil entender exactamente tu problema, en las normas del foro, puedes leer al respecto Y para adelantar algo [espero no sea tan en vano], prueba esta formula, pegarla en A1 y desde A2 estarán tus números =INDICE(A$2:A$11,COINCIDIR(MIN(INDICE(CONTAR.SI(A$2:A$11,A$2:A$11),)),INDICE(CONTAR.SI(A$2:A$11,A$2:A$11),),-1),) Saludos a los 3
  2. Hola Jamel Revisa el adjunto Saludos Repeticiones de rangos_GP.rar
  3. Contar.Si Libros cerrados

    Que bien, enhorabuena! También se puede hacer con Power Query, ¿haz escuchado de esta herramienta poderosa?... sirve para transformar y manipular nuestros archivos de Excel, orientada a BD para convertirlas a Tabla Este complemento esta disponible, para versiones 2010/2013 y en 2016 ya viene incorporada en la ficha Datos Tomando de ejemplo tus archivos en la carpeta y la necesidad de contar, te adjunto un ejemplo, el archivo de Recuento en libros cerrados Power Query_GP debe estar fuera de la carpeta de los archivos a procesar Al abrirlo veras una tabla, y a lado derecho, un panel donde se puede ver la consulta creada a estos archivos... busca la que lee Formato Formato Countif VBA y das click derecho [o doble click], luego en "Editar", se abrirá Power Query, al lado derecho, están todos los pasos [similar a VBA] realizados para crear esa tabla/consulta, al principio de esa lista, esta "Origen", ahí das click y en la barra superior podrás ver la ruta de la carpeta, ahí debes cambiarla por la tuya, das "Cerrar y Cargar" y listo [esa ruta se crea automáticamente, desde los pasos pero dado que tu ruta va cambiar, debes hacerlo manualmente] Todo esto te parecera extraño y una perdida de tiempo [a mi me paso , pero ahora no me arrepiento] Míralo y ya nos comentaras Saludos Formato Countif VBA.rar
  4. Contar.Si Libros cerrados

    Disculpa te di el resultado de la formula y no el codigo Le hice unos leves cambios, prueba asi Sub Prueba() Dim FSO As Object: Dim Archivo As Object: Dim strArchivo As String Dim strHoja As String: Dim strRuta As String Application.ScreenUpdating = False Application.Calculation = xlCalculationManual Set FSO = CreateObject("Scripting.FileSystemObject") strHoja = "Worstation Design" 'Worstation Design With Sheets.Add.Range("a1:b1") .Value = Array("Nombre", "Registros") .Font.Bold = True For Each Archivo In FSO.GetFolder(ThisWorkbook.Path).Files strArchivo = Archivo.Name If strArchivo Like "*.xlsx" Then If strArchivo <> ThisWorkbook.Name Then strRuta = ThisWorkbook.Path & "\[" & strArchivo & "]" With Range("a" & Rows.Count).End(xlUp)(2) .Value = Archivo.Name With .Offset(, 1) .Value = "=SUMPRODUCT(--('" & strRuta & strHoja & "'!K1:K1000=""Ok""))" .Value = .Value 'Usar esta línea si se quiere sólo el valor y no la fórmula End With End With End If End If Next Archivo .EntireColumn.AutoFit End With Set FSO = Nothing Application.Calculation = xlCalculationAutomatic Application.ScreenUpdating = True End Sub Saludos
  5. Ahí mi versión, con macro de evento Private Sub Worksheet_Change(ByVal Target As Range) Application.EnableEvents = False With Target If Not Intersect(Target, Range("C3:I3")) Is Nothing Then .Offset(1) = .Offset(1) + Application.Sum(.Value) .Value = Empty End If End With Application.EnableEvents = True End Sub Saludos
  6. Ayuda (Listbox y Tablas)

    Te vas a "quemar" por experiencia te lo aviso!
  7. Contar.Si Libros cerrados

    Utiliza para este caso SUMAPRODUCTO .Formula = "=SUMPRODUCT(--('C:\Users\gerson.pineda\Desktop\Formato Countif VBA\[Countif Format - Copy.xlsx]Worstation Design'!K:K=""Ok""))" Saludos
  8. completar formula

    Hola Prueba así =SI(SI.ERROR(BUSCARV(D247;'BALANCE 3D'!A:E;5;0);SI.ERROR(BUSCARV(D247;'BALANCE 4 D'!A:J;10;0);0))<0;0;"") Saludos
  9. Extraer y ordenar

    Hola Luis Revisa el adjunto Saludos a ambos Extraer numeros sin repetir_GP.rar
  10. Ayuda (Listbox y Tablas)

    Solo aclararte que no debes hacer varias preguntas en un tema, porque entonces se pierde el sentido del foro Por favor crea un tema por una duda especifica, pues bastante se te ha ayudado con lo expuesto Saludos
  11. Programación de alertas en función de resultados

    Hola @Cristian RC El propósito del foro es colaborar u orientar en algo especifico [pero corto], no esta dedicado a realizar grandes tareas o que se necesite mucho esfuerzo, para poder ayudar al consultante Sigue la sugerencia de @avalencia y seguro obtendras ayuda nuestra Saludos a todos
  12. Sumar apariciones en rango de fechas

    Hola! Hice modificaciones a tu archivo, para poder mostrarte ambas soluciones [no esta igual que el tuyo y por eso a mi si me funciona y a ti a medias] ¿Porque? Pues en la fila 3, agrego fechas automáticamente comenzando por un mes especifico En la fila 4, uso una función para obtener el numero-dia de la fecha en la fila 3 Con sumaproducto solo necesito la fila 3 y 5 Con Contarsiconjunto necesito fila 4 y 5 Espero te haya quedado mas claro Saludos
  13. Ayuda (Listbox y Tablas)

    En mi aporte ya esta agregado ese mecanismo Desde luego que se permite, pero te sugiero en la medida de lo posible subas tus propios aportes, pues imagínate llenar el foro de puros vídeos...! Saludos
  14. Ayuda (Listbox y Tablas)

    Hola tito Lo sospeche, pero siendo que si no existe lo agregue, pues se hace una modificación Observa los cambios Saludos Registrar Vba_GP.rar
  15. Sumar apariciones en rango de fechas

    @njnsp te adjunto dos formas de hacerlo Saludos Contar segun dia de semana_GP.rar
×