Saltar al contenido

Gerson Pineda

Administradores
  • Contador de contenido

    11533
  • Unido

  • Última visita

  • Days Won

    307

Todo se publica por Gerson Pineda

  1. Hola! Puedes usar la siguiente formula =SUMAR.SI($A$2:$A$116,E2&"*",$C$2:$C$116) Mi separador de argumentos es la coma, cambia al tuyo si es necesario Saludos
  2. Hola isidro Solo así, se puede ir aprendiendo, con la práctica... Pero en este caso no es necesario, el With end With [solo si utilizaras más de una vez un rango u objeto] , ni obtener la última fila con datos, ya que Replace es optimizada para tal proceso Saludos
  3. Range("A:A").Replace "velo", "VELO", , , 0 Hola Sin necesidad de un bucle, usa ésta línea de codigo Pd: lee la yuda de la herramienta o comando REPLACE Saludos
  4. La función INDIRECTO es otra alternativa, lo malo de esta función que es volátil e INDICE, no Saludos
  5. Hola Te adjunto 2 opciones, con formula y vba Saludos Transponer Datos_GP.zip
  6. Hola Utiliza esta formula en el rango para el FC =Y(C5<>"",D5="") Saludos
  7. Hola! Una opción mas con el poder de las formulas =SI($D2<>"",BUSCARV($D2,$G$4:$I$10,3,1),"") Saludos
  8. Hola Solo agrega esa comparación, a la formula que te envié (ColumnaSolicitud=CeldaSolicitud) Saludos
  9. Hola! Revisa el adjunto, va incluido que en el caso que no hubiese semana 1 para Diciembre, solo copiara el primer rango Saludos Copiar rangos a hojas_GP.zip
  10. Hola @hugovegac Interesante tu proyecto, pero por favor toma nota, que nuestro foro es para poder colaborar en pequeñas dudas, ademas debe ser acompañado de un libro de Excel, adicional a eso, ser lo mas explicito posible Saludos
  11. Bruno Intentare explicarte como funciona, la parte de Agregar, pero antes de todo, lee la ayuda de esta función AGREGAR(14,6,FILA(SOLP[Estado])-FILA(SOLP[#Encabezados])/(SOLP[Material]=[@MATERIAL]),1) 14 = equivale a kesimomayor 6 = Ignorar errores FILA(SOLP[Estado]) = contador de filas de la tabla FILA(SOLP[#Encabezados]) = obtener la primera fila de la matriz / = dividir (SOLP[Material]=[@MATERIAL]) = comparamos la matriz material con la variable de material 1 = para obtener la mayor fila En acción: FILA(SOLP[Estado])-FILA(SOLP[#Encabezados]) = resto el total filas con la primera fila, el objetivo es re dimensionar la matriz, en tu caso la tabla comienza en la fila 8, entonces al restarle 7 [que es la fila donde esta el encabezado], queda 1, de esta forma la matriz, toma un nuevo rango comenzado desde 1 y no de 8 (SOLP[Material]=[@MATERIAL]) = obtengo las variables booleanas [falso y verdadero] FILA(SOLP[Estado])-FILA(SOLP[#Encabezados])/(SOLP[Material]=[@MATERIAL]) = al dividir el total filas con la matriz de falso/verdadero, obtengo las coincidencias [numero de filas] y las que no son, quedan como errores de valor, que es dividir por cero Entonces 14 y 6 que son los primeros argumentos de agregación y finalmente el 1, después de comparar todo, obtendré el el primer valor mayor de la cadena de números Tal que AGREGAR(14,6,{#¡DIV/0!;...;27;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;#¡DIV/0!;45;...;#¡DIV/0!;#¡DIV/0!;207;#¡DIV/0!;;#¡DIV/0!},1) [los 3 puntos suspensivos, es para recortar el ejemplo, significa que hay mas errores de división] Por lo que 207 es el primer mayor, siendo la fila del ultimo estado Saludos!
  12. Bienvenido Bruno Saludos
  13. Hola Bruno Revisa el adjunto Saludos Obtener ultimo estado_GP.zip
  14. Hola! Un código mas simple y corto Private Sub Worksheet_Change(ByVal Target As Range) With Target If .Column = 5 Then .Offset(, 1).Value = .Value End With End Sub Saludos a ambos!
  15. ¿Y como piensas que podemos ver, a que se debe el fallo? Saludos
  16. Espera entonces, quien puede desarrollarlo para ti Saludos
  17. Hola Ricardo Adjunto una solución, para la creación de la tabla Solo debes cambiar los valores de numero de cajas y nivel de altura Saludos Crear tabla tridimensional VBA_GP.zip
  18. Hola! Adjunto mi versión con VBA, ademas otro método utilizando Power Query [mi preferido] Saludos a todos Transformar datos VBA y Power Query_GP.zip
  19. Lo que Haplox te proporciono es producto de usar la grabadora de macros ¿Por otro lado en que momento o donde asumes que me molesta tu presencia? ¿O en realidad te molesta que te mande a usar la grabadora de macros de Excel? Y por si las dudas respondes y preguntas ¿Que es la grabadora de macros? Mira: https://support.office.com/es-es/article/automatizar-tareas-con-la-grabadora-de-macros-974ef220-f716-4e01-b015-3ea70e64937b Vamos inicia ya! Saludos
  20. Hola Alfonso Para guardarlos en la hoja, debes usar las funciones de conversión, lee el siguiente enlace https://docs.microsoft.com/es-es/dotnet/visual-basic/language-reference/functions/type-conversion-functions Saludos
  21. Definitivamente es la mejor practica, luego solo lo carga al modelo de datos y listo Saludos
  22. @A.Maurizio ya es hora que vayas utilizando la grabadora de macro A veces preguntas cosas muy básicas, date el tiempo, pues VBA te esta siendo de mucha utilidad no? Saludos
  23. ... y es que en realidad, cuando las matrices son mal utilizadas, se dan estos casos Respecto a tu libro, no se pide un "original", se solicita una recreación del mismo, de parte del consultante, pues se debe tener demasiada imaginación, magia negra y varita, para determinar como se puede resolver de la mejor forma Saludos!
×
×
  • Crear nuevo...

Información importante

Echa un vistazo a nuestra política de cookies para ayudarte a tener una mejor experiencia de navegación. Puedes ajustar aquí la configuración. Pulsa el botón Aceptar, si estás de acuerdo.