Jump to content

Gerson Pineda

Administrators
  • Posts

    12,528
  • Joined

  • Last visited

  • Days Won

    449

Everything posted by Gerson Pineda

  1. La parte de intercalar no la había captado Adjunto de nuevo mi método Espero ahora si, quede listo Saludos! Mover filas filtradas otra hoja_GP.xlsm
  2. @Maria_80 Si entiendo bien y en resumen deseas pasar lo que esta filtrado en Salida y Entrada a Destino, te adjunto una alternativa como solución, presiona "Actualizar destino" y listo Saludos Mover filas filtradas otra hoja_GP.xlsm
  3. Sube una muestra en Excel, explicas un poco mas y asi poder darte colaboración Saludos
  4. Hola ¿Lo estas haciendo desde un formulario o desde la hoja? En el primer caso, solo es cosa de poner un textbox para indicar el numero de hoja Si no, intenta con INPUBOX Saludos
  5. Esa misma lógica es la que tienes que aplicar en Power Query o Query Editor de PBI, agregando una columna personalizada Hay una leve diferencia respecto a la sintaxis, tal que: = if [campo] < 300 then 0 else if [campo] < 401 then 100 etc.... Saludos!
  6. Hola No entiendo que deseas hacer exactamente Formato condicional se puede hacer con y sin DAX , pero no me queda claro, que buscas Se mas explicito o si es posible adjunta imagen Saludos!
  7. De forma "automática", se puede con una macro de evento, como Change, tal que: Private Sub Worksheet_Change(ByVal Target As Range) With Target If .Column = 1 And .Row < 3 Then result = Range("A1") & " " & Range("A2") Range("A3") = result End If End With End Sub Cada que edites la celda A1 o A2, en la celda A3, se mostrara el resultado concatenado Saludos a ambos!
  8. Como te lo comente en el otro lado, es posible que esa sea una tabla independiente de una consulta de power query, es decir si te colocas sobre ella, debe aparecerte en la cinta de opciones, la frase "Consulta", de lo contrario es evidente lo que indicas, que no va actualizar Saludos
  9. Una alternativa mas, puede ser: =BUSCARV($M6,$B$5:$E$16,COINCIDIR(N$4,$B4:$E4,),0) Saludos!
  10. Si es posible hacerlo dinámicamente y automáticamente Pero creo que estas iniciando con lo ultimo, es decir, no puedes estar suponiendo tu idea, debes tener algo armado y poco a poco, darle sentido a tu necesidad, si no es algo en concreto, es difícil aterrizar Para lo que buscas hay distintos métodos y formas, pero si lo tuyo va encaminado o enfocado a gráficos dinámicos, te recomiendo que vayas pensando en leer sobre Power Query, Modelo de datos y Tablas dinámicas, estas te darán mucha flexibilidad, al momento de crear tus gráficos, mismos que dependerán de tabla dinámica Te lo sugiero, porque yo lo he trabajado y es fascinante Saludos!
  11. También puedes solamente ordenar esa tabla por nombre y listo, seria una buena opción Te dejo una formula mas, como solución =INDICE( D$1:D$14, AGREGAR( 15, 6, FILA( D$1:D$14 ) / ( $F5 = C$1:C$14 ), CONTAR.SI( F$5:$F5, $F5 ) ) ) Saludos a los 3
  12. Tu formulario esta raro, es posible que este corrupto, pues haciendo pruebas, tengo problemas Te adjunto un ejemplo para que lo pruebes y veas que si funciona Saludos Foco entre formularios.xlsm
  13. Mi método If mes <> Empty Then With Worksheets("Hoja1") .Range("A:A").SpecialCells(4) = mes End With End If o If mes <> Empty Then Worksheets("Hoja1").Range("A:A").SpecialCells(4) = mes Saludos
  14. Benito Para dar foco a un objeto desde un formulario a otro, solo debes escribir sus nombres de formulario y objeto MiForm.Referencia.Setfocus Inclúyelo en el botón "Ir" Saludos
  15. Hola! Puedes solucionarlo así: try Date.Month( [Fechas] ) otherwise null [Fechas] es el campo de fechas Saludos
  16. Hola! Dejo mi versión @tono812 Sustituí tus procedimientos y agregue uno mas, de tal manera que solo deje el botón de borrar Saludos Filtrar columnas dinamicamente_GP.xlsm
  17. Hola Con una tabla dinámica, seria mas eficiente Lo que hice fue pasar a formato tabla la hoja pedido y luego arme la TD Te lo dejo como solución Saludos PRUEBA_CONSOLOCIDACION.xlsm
  18. Tu dificultad es de adaptación porque debes manejar mejor las referencias Te sugiero leer el articulo de @Sergio Mientras lo haces, en el argumento de columna de INDICE, escribe, 1, 2 y 3 y listo Saludos!
  19. En cuanto al funcionamiento, las he probado y ambas funcionan con texto y números Si aun no lo notas, mis 2 métodos, son dinámicos, es decir no importa la cantidad de filas y columnas a procesar, para unir las celdas, además que ignora automáticamente cualquier celda vacía Respecto a la aplicación que utilizo para mostrar una demo, se llama Licecap La función UNIRCADENAS la pude ver disponible en 2016, pero creo que MS por alguna razón la eliminó, solo esta en 365 y 2019 como posterior Saludos!
  20. A mi me funcionan las 2 La función unircadenas esta en las versiones mas recientes de Excel, seguro por eso te da error Yo tengo la version365 Saludos
  21. Hola a ambos Adjunto 2 alternativas con VBA Saludos Concatenar celdas VBA_GP.xlsm
  22. Insisto, si es problema de lógica y de implementación DAX ni Power Query, podrán encontrar lo que se busca, si no le damos cierta lógica de donde buscar y asociar... hago este comentario para que quede aclarado que las herramientas necesitan estructuras para relacionar y transformar Suerte!
  23. Claro, solo es cosa de copiar la formula hacia la derecha y listo Saludos
  24. En efecto, también es buena opción con FC, siempre que no sean muchos datos en la hoja Saludos
×
×
  • Create New...

Important Information

Privacy Policy