Jump to content

Gerson Pineda

Administrators
  • Posts

    12,796
  • Joined

  • Last visited

  • Days Won

    487
  • Country

    Honduras

Everything posted by Gerson Pineda

  1. Hola a todos @Jose Angel Castro Como veo que dispones de Excel 365, te dejo más soluciones, empleando funciones nuevas, de 2 formas La primera funciona fila a fila, mientras que la otra tomo la tabla completa y el resultado queda en una sola formula, expandiéndose con los resultados en una matriz Separar textos de celdas APILARV-H TEXTOANTES REDUCE 365_GP.xlsx
  2. Pero no indicas sobre que lógica, se deben obtener esos códigos, solo dejaste el resultado manualmente
  3. Yo prefiero la función BUSCAR, o en defecto INDICE/COINCIDIR
  4. Nos puedes explicar cuál es la lógica que implica este orden
  5. Te sugiero utilizar formato de tabla, para que tus rangos sean dinámicos
  6. Hola Sube un ejemplo en Excel y deja el resultado manual, de lo que buscas según tu lógica aplicada
  7. Tu debes adjuntar un archivo, para que podamos colaborarte
  8. Hola Hay varias formas de solucionarlo, pero adjunta un archivo con la tabla y deja el resultado manualmente de lo que esperas
  9. Mientras este aquí, no lo vas a lograr jajajaja, cambiare tu puntaje 😈 ¡Saludos a ambos!
  10. Ahora la versatilidad de Excel, es de otras dimensiones😎 Vamos, anímate con las funciones, no les tengas miedo 😁
  11. Hola Si dispones de Excel 365 Te dejo una solución =FILTRAR(A8:D87,(C8:C87<>0)+(D8:D87<>0)) Te recomiendo, además, utilizar formato tabla para que sean dinámicos los rangos Si no tienes 365, nos avisas
  12. Ahora con power query Extraer ultima cadena power query_GP.xlsx
  13. No estaria mal, que probaras con esta Adaptándola a TS, es decir supongo que reconocería las nuevas funciones
  14. Lo que debes formatear es el resultado de la formula, al formato que tienes en la columna F
  15. Hola a todos Suponiendo que tus datos inician en A1 Dejo otra posible solución =LET(m_,ENCOL(DIVIDIRTEXTO(A1,"\")),INDICE(m_,COINCIDIR("pdf",m_))) Saludos
  16. Hola a ambos @Giancarloch Para que veas que Excel es versátil, dejo una solución sin utilizar un bucle Utilizando mi preferido SpecialCells vce = Range("P:Q").SpecialCells(xlCellTypeFormulas, 16).Count If vce Then VBA.MsgBox "Se encontraron " & vce & _ " errores, favor revisar", vbExclamation, "AyudaExcel" Excel te mostrar una alerta, si hay errores
  17. Por si no tienes MIN.SI.CONJUNTO que aparece desde Excel 2019 o posterior Te dejo otra opción con Agregar disponible a partir 2010 =AGREGAR(15,6,C$2:C$26/((C$2:C$26>0)*(A$2:A$26=$K5)),1)
  18. Hola a ambos Una solución mas =(CONTAR.SI(A$1:A1,$A1)=CONTAR.SI(A$1:A$19,$A1))*SUMAR.SI(A$1:A1,$A1,B$1:B1)
  19. Hola Con una macro de evento y validación de datos, es posible Te dejo un pequeño ejemplo Restringir entrada de datos VBA_GP.xlsm
  20. Hola Federico Para no mezclar los temas, crea un nuevo tema en Fórmulas y funciones (ayudaexcel.com) Saludos
  21. Si te refieres a validación de datos, aun no es posible, en versiones perpetuas Pero si es posible en versión insider beta de Excel 365
  22. Te adjunto una solución Prefijo dobleclick VBA_GP.xlsm
×
×
  • Create New...

Important Information

Privacy Policy