Jump to content

Mostrar coincidencias si la celda contiene texto de la lista


Recommended Posts

Llevo todo dos días intentando (con mis conocimientos de Excel 2019) que me funcione la fórmula que aparece en este post

https://www.get-digital-help.com/es/si-la-celda-contiene-texto-de-la-lista/#array

Necesito hacer lo que se muestra en la imagen para unas encuestas de texto.

If-cell-contains-value-from-list-show-al

He probado la fórmula:

=IFERROR(INDEX($G$3:$G$7, SMALL(IF(COUNTIF($B3, "*"&$G$3:$G$7&"*"), MATCH(ROW($G$3:$G$7), ROW($G$3:$G$7)), ""), COLUMNS($A$1:A1))), "")
 
y la he traducido en español:
 
=SI.ERROR(INDICE($O$2:$O$35; K.ESIMO.MENOR(SI(CONTAR.SI($B3; "*"&$G$3:$G$7&"*"); COINCIDIR(FILA($G$3:$G$7); FILA($G$3:$G$7)); ""); COLUMNAS($A$1:A1))); "")
 
Pero no logro que funcione. Ya no se que hacer y es una labor que necesito.
 
Espero puedan ayudarme. Muchas gracias.
Link to post
Share on other sites
Hace 2 horas, Sergio dijo:

@pixelatumente, te recomiendo que rellenes los campos de tu perfil referentes al separador de argumentos y versión de Excel que usas.

Con Excel 365 hay una respuesta fácil a tu consulta.

Gracias. Así lo he hecho.

Me comentas que la fórmula está orientada para Excel 365 y no Excel 2019?

Link to post
Share on other sites

@pixelatumente, en las fórmulas del archivo que adjuntas hay muchos errores de introducción de datos. He corregido las fórmulas. 

=SI.ERROR(INDICE($G$3:$G$7; K.ESIMO.MENOR(SI(CONTAR.SI($B3; "*"&$G$3:$G$7&"*"); COINCIDIR(FILA($G$3:$G$7);FILA($G$3:$G$7)); ""); COLUMNAS($A$1:A1))); "")

Está preparada para que la introduzcas en la celda C3.

 

Link to post
Share on other sites
En 16/7/2020 at 22:53 , Sergio dijo:

@pixelatumente, en las fórmulas del archivo que adjuntas hay muchos errores de introducción de datos. He corregido las fórmulas. 


=SI.ERROR(INDICE($G$3:$G$7; K.ESIMO.MENOR(SI(CONTAR.SI($B3; "*"&$G$3:$G$7&"*"); COINCIDIR(FILA($G$3:$G$7);FILA($G$3:$G$7)); ""); COLUMNAS($A$1:A1))); "")

Está preparada para que la introduzcas en la celda C3.

 

Muchas gracias Sergio por tu colaboración, pero no me funciona. He copiado la fórmula a la celda C3.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Privacy Policy