Jump to content

Sergio

Administrators
  • Posts

    9,972
  • Joined

  • Last visited

  • Days Won

    32
  • Country

    Spain

Everything posted by Sergio

  1. @njnsp, en la segunda versión se mantiene la fecha en caso de que cambie el número de cliente?
  2. Si tu deseo es evitar introducir la fecha manualmente me temo que sin una macro no es posible. Una forma rápida de introducir la fecha del día en una celda es presionar las teclas Ctrl + ; (punto y coma) . Quizá te sirva. De esa forma quedará fijada. Un saludo,
  3. @JSDJSD, por esa razón le solicité si podía grabar el vídeo... Realmente es muy extraño.
  4. Puedes usar la siguiente fórmula: =SI.ERROR(BUSCARV($B3&"1"&C$2;'Hoja Calulcos Data'!$B$3:$F$169;5;0);"")&SI.ERROR(BUSCARV($B3&"2"&C$2;'Hoja Calulcos Data'!$B$3:$F$169;5;0);"") Echa un vistazo a la fórmula de la hoja Calulcos: =C3&CONTAR.SI.CONJUNTO($C$3:C3;C3;$D$3:D3;D3)&D3 He cambiado CONTAR.SI por CONTAR.SI.CONJUNTO para que admita más condiciones. Pruebalo y me dices.
  5. Hola @Patrick Marabote, cómo estás? Adjunto una posible solución. Para comenzar, la cuenta que haces en la columna B de la hoja de los cálculos no es necesaria, pues un trabajador solo tiene una jornada al día. Solo tienes que concatenar el nombre y la fecha: =C3&D3 El resto de la solución es igual a la que proponías en el ejemplo. Solo he agregado SI.ERROR para eliminar los molestos mensajes de datos no encontrados. =SI.ERROR(BUSCARV($B3&C$2;'Hoja Calulcos Data'!$B$3:$F$169;5;0);"") Pruébalo y nos dices. Proyecto Validacion Ayuda EXCEL.xlsx
  6. Jajajajaja. SAP en cuanto a informes es menos flexible que un palo.
  7. Gonzalo, no se ven las fichas en el vídeo. ¿Puedes grabar la parte de arriba de la ventana?
  8. Hola Gonzalo, ¿Podrías mostrar de forma visual cómo lo haces? No sé si tienes la posibilidad de grabar un breve vídeo de tu pantalla o adjuntar algunas capturas. De esa forma podremos identificar más rápido por qué sucede eso.
  9. Por favor, deja tu respuesta
  10. Te paso la información por correo electrónico.
  11. Galactico, si estás aprendiendo a programar para hacer scraping VBA te puede ayudar mucho pero Python es el lenguaje más potente para hacerlo. ¿Quieres recomendaciones de cursos?
  12. Cuando presionas la tecla tabulador, ¿qué comportamiento tiene? ¿Qué celda se activa? Como bien dices el comportamiento debería ser el mismo.
  13. Simplemente debes indicar el nombre de la hoja delante de la referencia de la matriz de búsqueda. De esta forma: =UNIRCADENAS(", ";0;BUSCARV(A2;Hoja2!A2:E25;{2;3;4;5};0)) Si te sirve no olvides dar tu opinión usando el corazón del mensaje y dar el tema por solucionado. Un saludo,
  14. Hola Vicente, Espero que esta fórmula te sirva: =UNIRCADENAS(", ";0;BUSCARV(G7;A2:E2;{2;3;4;5};0)) Un saludo,
  15. Hola @Janlui, ¿con atendidos/cerrados te refieres a los que la persona que pregunta ha obtenido una respuesta satisfactoria pero no ha sido cerrado?. Me gustaría charlar contigo un día. Te envié un correo pero no sé si lo habrás visto... Un saludo,
  16. Hola @Patrick Marabote¿qué versión de Excel utilizas? (te recomiendo rellenar los datos de tu perfil). En caso de usar Excel 365 puedes hacer uso de la función FILTRAR. FILTRAR devuelve un conjunto de datos que coinciden con uno o varios criterios dentro de un rango. Introduce la siguiente fórmula en las celdas G5, G7 y G12. =FILTRAR($D$5:$D$14;$C$5:$C$14=F5) En caso de tener una versión anterior de Excel te recomiendo que eches un vistazo a esta publicación de Moisés Ortiz: https://exceltotal.com/buscar-un-valor-y-regresar-multiples-resultados-en-excel/ En ella se explica perfectamente cómo proceder para encontrar varios resultados de una sola búsqueda. Espero haberte podido ayudar.
  17. Hola @Janlui, Se ve muy interesante. ¿Podemos hacer una sesión de Zoom para hablar de ello? Un saludo.
  18. Janlui, gracias por tu interés. Te respondo en el mismo orden en el que aparecen tus puntos: - Las personas que tienen la palabra 'Exceler' en amarillo debajo de su foto de perfil (también en otros lugares) son los que tienen membresía. - Los 'aportadores' suelen ser los que más mensajes escriben. La forma de detectarlo es mirando su perfil, donde aparece un 'contador de contenido'. - En este momento la única calificación de temas es en la que se indica si una consulta se solucionó o no. ¿Cuál sería la razón por la que deberíamos conocer la calificación del tema?¿En qué nos puede ayudar?¿Cómo actuaríamos? Si me das más detalle quizá podamos implementarlo en el futuro. - Con respecto a las aportaciones, mi experiencia me dice que vivimos en un mundo en el que no valoramos la ayuda recibida. Hace unos meses hice una prueba: Cierta plantilla que tengo en la web tenía un promedio de 2.000 descargas al mes. Durante un mes le puse un precio de 1 euro (porque quería comprobar la buena fe del ser humano) y tuvo únicamente dos ventas. De 2.000 descargas a únicamente 2 ventas (fíjate en el precio). Así somos. Aprovecho para agradecerte la ayuda que prestas en el foro y por estas sugerencias. Me gustaría mejorar el foro tanto en servicio como en la clasificación de los temas y las sugerencias de las personas que usan el foro a diario me ayudan mucho. Un saludo,
  19. Hola Eugenio, ¿Qué pasos has seguido hasta ahora para intentar conseguirlo? Un saludo,
  20. Sergio, indícame las referencias en las que tienes los datos de la tabla que da error.
  21. @hiram debes fijar las columnas introduciendo el símbolo $ delante de la letra de la columna. Echa un vistazo a la siguiente publicación donde se explica cómo funcionan las referencias absolutas, relativas y mixtas. https://ayudaexcel.com/el-uso-de-referencias-en-las-fórmulas/ Un saludo,
  22. El inconveniente está solucionado desde hace unos días. Disculpa la molestia.
  23. Prueba con =HOY(). Eso devuelve únicamente el día, no la hora. así te coincidirá.
  24. Prueba a introducir la siguiente fórmula en la celda AM12: =FILTRAR($C$6:$C$36;DESREF(C5;1;COINCIDIR($AM$5;$F$5:$AJ$5;0)+2;31)="o") Esa fórmula mostrará los empleados que están por la mañana según la fecha introducida en la celda AM5. Para mostrar los demás turnos solo tienes que sustituir la O por la letra correspondiente. Comenta si te ha servido.
×
×
  • Create New...

Important Information

Privacy Policy