Jump to content

Leaderboard

Popular Content

Showing content with the highest reputation on 03/24/2021 in all areas

  1. =SUMAPRODUCTO((ENTERO(C$2:C$6)=HOY())*B$2:B$6) Hola, puede salir así
    2 points
  2. Hola Veo que realizas 8 importaciones del mismo .txt, eso en realidad se puede evitar Cuando importas la primera vez, realiza las transformaciones hasta un punto donde puedas hacer una copia, es decir la primera consulta será tu base, para después solo copiar y realizar las transformaciones siguientes según sea el caso, en resumen debes tener 9 consultas, la original mas las 8 transformaciones Si vas haciendo carpetas mes a mes, por lo pronto se me ocurre, que a cada .txt le asignes un sufijo de mes, pe: Origen_Ene, Origen_Feb, de modo que todos estén en una sola carpeta y luego creas las tablas según el sufijo, aquí debes usar el conector de carpeta Es mas dentro del editor se pueden crear carpetas para diferenciarlas Saludos
    1 point
  3. Después de tantas consultas, todavía insistes en no subir el archivo. ¿Cómo quieres que comprobemos porqué te ocurre lo que cuentas. Haz el favor de seguir las normas del foro.
    1 point
  4. Uy, vaya gazapo. Lcopia es un libro y como tal no admite invocar directamente .Rows.Count, por lo que cambia el código a: With Lcopia lFilaCopia = .Sheets(1).Range("A" & .Sheets(1).Rows.Count).End(xlUp).Row .Sheets("SoloMexico").Range("A3:L" & lFilaCopia).Copy End With De todas maneras, al no tener los archivos interprete lo que quieres hacer con el código que leí pero es posible que no se adapte fielmente a lo que necesitas. Si quieres postea un ejemplo en un libro y adjúntalo. Saludos.
    1 point
×
×
  • Create New...

Important Information

Privacy Policy