Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 07/15/2019 in all areas

  1. 3 points
    Hola @lphant Hay distintas formas, te adjunto 2 con Vba y 1 con Power Query Saludos Contar Distintos VBA - Power Query_GP.zip
  2. 2 points
    Hola Jose Vba esta siendo claro, con el error "El objeto olMailItm no admite esa propiedad o método [AddAttachment]", entonces cuando veas este tipo de errores, lee sobre cada propiedad o método que utilizas del objeto y verificar como se escribe correctamente Pues lo correcto es: .Attachments.Add Saludos
  3. 2 points
    Hola ikanni, agradezco la llamada de atención, pero sucede que no se nada de programación, solo se entrar al VBA e insertar módulos.
  4. 2 points
    Hola: En A4: =SUMA(SI(MES($J$5:$J$34)=A$3,$I$5:$I$34)) Es matricial (CTRL+SHIFT+ENTER) y copias hacia la derecha
  5. 2 points
    >Hola Pues sí te hubieses esforzado un poco lo podrías haber arreglado tu, salvo que hagas un copia pega sin mirar lo que hace y sí es así pues .... con cambiar un numero funciona como tu quieres. Y te voy a dar una ayudita. Hay que cambiarlo en esta linea If Len(celda.Offset(, 5)) <> 0 Then Ala curratelo un poco
  6. 2 points
    Holas! Creo que @Jormoar olvido adjuntar el archivo, pero como es simple de armar la tabla, lo hice Adjunto el archivo [@Silvia se te acerca el feriado ] Saludos! Encontrar numero mas proximo_GP.zip
  7. 2 points
    Hola Iphant (e Isidro 😊 ) Yo entendí que quiere el conteo por Cliente.. En ese caso, por ejemplo si en el rango E3 : E7 tienes los códigos Entonces en F3 : =CONTAR(1/FRECUENCIA(SI($A$2:$A$27=E2,COINCIDIR($B$2:$B$27,$B$2:$B$27,0)),FILA($B$2:$B$27))) mi separador de argumentos es la coma, si el tuyo es otro, corriges. saludos, Silvia
  8. 2 points
    buen día @Iphant te dejo un ejemplo a ver si es lo que quieres ejemplo.xlsx
  9. 2 points
    Antoni

    Color de varias formas

    Pues ya estoy aquí. Seleccionar un temario de la lista y pulsar Comenzar. Aparecerá una pregunta en la celda J14. Responder en la celda J16 y pulsar Responder o pulsar Pasa Palabra. Si quereis jugar con tiempo, llenar la celda L23. de lo contrario informar cero. El rango de celdas L6:L11 controla los colores del Rosco. La columna L puede ocultarse. Pasa palabra full.xlsm
  10. 2 points
    Antoni

    Calendario minimalista

    Version 1.0.0

    14 downloads

    Es un calendario al uso, sin misterios. Ya sabeis de mi debilidad por los calendarios, en este caso la gracia está en el código VBA. Os recomiendo que lo reviseis y os dareis cuenta que se puede hacer click en un label sin evento individual y sin módulo de clase. Calendario mínimo.xlsm
  11. 1 point
    También valdría, o eso creo: Sub ExtraerDatosNOfacturar() Dim Fila As Long For Fila = 3 To Hoja1.Range("A" & Rows.Count).End(xlUp).Row If Hoja1.Range("AA" & Fila) = "NO SE REMITE" And _ Not Hoja1.Range("AF" & Fila) = "NO VENDIDAS" Then Hoja1.Rows(Fila).Copy _ Hoja2.Rows(Hoja2.Range("A" & Rows.Count).End(FilalUp).Row + 1) Hoja1.Rows(Fila).Delete Fila = Fila - 1 End If Next End Sub
  12. 1 point
    copiar pega esa formula Luis Antonio a ver si te funciona =SI(IZQUIERDA(B2,1)="T",B2,A1) saludos isidrod
  13. 1 point
    Gerson Pineda

    ANSWERED Contar.si.conjunto

    Juan ¿Ya intestaste usar la función CONTAR.SI.CONJUNTO? No veo tus intentos en el libro que subiste, debes esforzarte pues esto que solicitas es sencillo de aplicar, solo es cosa de seguir la sintaxis de la función, ademas estas obligado a leer la ayuda de las funciones Saludos
  14. 1 point
    Hola! Gersón a vba solo le hace falta hablar!.... por el momento la forma correcta que mencionas, no la había logrado encontrar en mis lecturas hasta llegar a este genial sitio y toparme con un personal el doble de genial (tú)que me ayudo a resolver el problema, ha quedado claro el error y solucionado. Tema concluido. Saludos cordiales JB
  15. 1 point
    PUABLANCO

    ANSWERED Contar.si.conjunto

    Buen dia, Considerando que los "Miembros" estén en la columna "A" y los "Criterios" en la columna "B" podrías utilizar la formula siguiente: Criterio 1= AM Criterio 2= PM =SI(CONTAR.SI($A$2:$A2;$A2)>1;0;SI(SUMA(CONTAR.SI.CONJUNTO($A$2:$A$7;$A2;$B$2:$B$7;"AM");CONTAR.SI.CONJUNTO($A$2:$A$7;$A2;$B$2:$B$7;"PM"))>1;1;0)) Contar.Si.xlsx
  16. 1 point
    Gerson Pineda

    ANSWERED Contar.si.conjunto

    Hola Prueba con Contar.si.conjunto Saludos
  17. 1 point
    @GabrielRaigosa me hiciste recordar BuscarV =BUSCARV(C2,ELEGIR({1,2},$B$2:$B$11,$A$2:$A$11),2,1) Ya tienes tu colección @Jormoar Saludos
  18. 1 point
    hola, ese era el error, que mi excel no usa la coma como separación de formulas si no la ; probando probando, al final lo consegui. aguantare un poco mas con el portatil, son tantos años metiendole mano y tantos disgustos que me ha dado que le quiero mas que a mucha gente jajajaj, muchas gracias y perdona lo pesado que he sido, es un placer conectarme la vuestra web, siempre encuentro solución. gracias de nuevo.
  19. 1 point
    no tengo ninguna tienda 😂, ya sabes que la tecnologia avanza tan rápido, igual que el celular, uno de hace 10 años no funciona con todos los recursos que consumimos ahora.. las apps.. y tanta cosa que uno pone en su cel, en las computadoras es igual.. Pues por aqui tal vez algún compañero te pueda sugerir algo al respecto... ese calculo que estás haciendo... lo podrías hacer con tablas dinámicas... pero limitalo por año.... y prueba si tu lap no explota.. 😨 (las tablas y tablas dinámicas, consumen muchos recursos, pero son muy atractivas y fáciles, no necesitas formulas) pedir condiciones a excel para sumar intereses3.xlsx
  20. 1 point
    tienes tienda de pcs, cual me recomiendas, La verdad que llevo un año queriendome comprar otro ordenador para tener uno en casa de mis padres y otro que va con migo. mi cumple ya pasó. me hare un regalo tardio, jajajaj, gracias.
  21. 1 point
    otra cosa, tal vez no te has dado cuenta y tu archivo tiene muchas en uso pero aparentemente están en blanco.. ve a la ultima celda escrita y elimina por debajo todas las filas hasta el final.., haz lo propio con las columnas.. quizás te ayude... tambien puedes intentar con esto https://www.ainur.es/blog/error-excel-2010-recursos-insuficientes-para-completar-esta-tarea/ pero yo que tu, me cambio de pc.. 😪
  22. 1 point
    Hola mi hoja de excel me da el siguiente mensaje: excel se ha quedado sin recursos al intentar calcular una o varias formulas, como resultado no pueden evaluarse estas formulas, ¿cual es el error?. Tal vez no os dije que tiene que hace esa formula hasta miles de filas de momento ya llevo 5024 filas en la que tiene que hacer esas formulas. esta es la formula vuestra =SUMAPRODUCTO(($J$5:$J$34>=A2)*($J$5:$J$34<=FIN.MES(A2;0))*($I$5:$I$34)) y la he cambiado por estas celdas y columnas originales =SUMAPRODUCTO(($LI$81:$LI$5024>=LC4)*($LI$81:$LI$5024<=FIN.MES(LC4;0))*($LH$81:$LH$5024))/LC9 solo he cambiado tus celdas y columnas por las reales. y me da el mensaje anterior, que se ha quedado sin recursos, JAJAJA ¿HE PETADO UN EXCEL?
  23. 1 point
    Llevas años por este foro, ya es tiempo primero que aclares con mayor explicites tus dudas, como sugerencia prueba, investiga un poco [ocultar/mostrar hojas], no esperes siempre todo ¿Te parece? Adjunto el archivo con esas leves modificaciones Saludos Contar Distintos VBA - Power Query_GP.zip
  24. 1 point
    Snake , tu formula sin entrada matricial puede quedar así: =SUMAPRODUCTO((MES($J$5:$J$34)=A$3)*($I$5:$I$34))
  25. 1 point
    Fantástico muchísimas gracias, Jo que envidia me dais no haberlo estudiado yo, con lo que me gusta excel, pero ya con 54 años no puedo sacar tiempo ni neuronas para estudiar, muchas gracias.
  26. 1 point
    hola Snake, Tu fórmula hace lo que pide, solamente habría que tomar en cuenta si en caso hubieran varios años, la formula sumará los meses sin importar el año... aunque como en el ejemplo no hay, probablemente solo habrán datos de un solo año 🙄😆
  27. 1 point
    Hola ROVER1965 Revisa el adjunto. saludos, Silvia pedir condiciones a excel para sumar intereses2.xlsx
  28. 1 point
    =INDICE($A$2:$A$11,COINCIDIR(C2,$B$2:$B$11,1))
  29. 1 point
    Muchas gracias @Gerson Pineda, funcionan muy bien pero para lo que tengo no me vale, tengo la hojas hojas ocultas y por ahora no quiero que se desoculten, se podría hacer de alguna otra forma sin filtro avanzado??. Muchas gracias.
  30. 1 point
    Mejor prueba este, lo mismo pero con menos código MODELO_FACTURACION_REVISION_PROYECTOS -PRUEBA5.xlsm
  31. 1 point
    Hola: Checa el adjunto, estoy utilizando una columna auxiliar en la Hoja TODOS (columna A) la cual puedes ocultar o utilizarla en otra parte. Saludos. ejemplo resumen de listados.xlsx
  32. 1 point
    Hola Jormoar.. adjunta un ejemplo en el propio excel , con lo que tienes y lo que quieres obtener.. (al menos yo, no he entendido muy bien lo que quieres) saludos, Silvia
  33. 1 point
    nickmartinez

    ANSWERED Excel no abre y da error

    Que tal comunidad,le cuento que hay muchas opiniones con referente a este tema que encontré en la pagina de microsoft ,y otros foros,los probé todos y nada,lo que resolvió el inconveniente fue darle a reparar office pero de forma profunda la que dice reparación en linea,no la opción rápida,tardo un tiempo largo pero el resultado es que reparo el error,saludos para todos,por mi parte doy como terminado el tema
  34. 1 point
    { 😂 , 😁 , 😂 }
  35. 1 point
    Hola, con una tabla dinámica tal vez? Comentas. Saludos Prueba Utilidades.xlsx
  36. 1 point
    se me olvido que es una formula matricial, ahora si funciona jejejee... lo dicho, muchas gracias.
  37. 1 point
    Los que deseas, solo debes agregarlos al array() Realiza tus pruebas... Saludos
  38. 1 point
    Es una potente herramienta de transformación, te la recomiendo, para muchos que la usamos es un "boom" Saludos
  39. 1 point
    precisamente, hice pruebas (printpreview) sobre tu adjunto después de haber eliminado las filas "sobrantes" al final (quizá por exceso de formatos ?) y eliminado el rango asignado al nombre de "área_de_impresión" y veo un total de 22 hojas "a imprimir" configuradas para tamaño A4 (dos boletas completas en cada hoja y de rangos variables -diferente número de registros en cada hoja- por los "saltos de página" ya establecidos) probablemente sea un detalle de configuración de la impresora a la que diriges la salida ?
  40. 1 point
    Hola Nick Revisa el adjunto, espero sea lo que necesitas Saludos Agrupar y Dinamizar Power Query_GP.zip
  41. 1 point
    Tanto la f como la x son contadores, la "f" es la fila del código que se esta evaluando para reemplazar, la x es para contar cuantos registros se van reemplazando Pero la f realmente no es necesario, se puede prescindir de ella Tal que la línea quedaría asi: If Not vcn Is Nothing Then x = x + 1: Cells(c.Row, "A") = Hoja1.Cells(vcn.Row, "B") Saludos
  42. 1 point
    Silvia

    ANSWERED buscar en intervalo de fechas

    hola underkar Puedes utilizar =SI.ERROR(BUSCARV(G4,$B$4:$E$6,4,1),0) **Mi separador de argumentos es la coma, si el tuyo es otro, corriges. ** la primera da error porque el año es 2008... no hay dato de búsqueda, coloqué cero. si fuera error tuyo, y siempre va a estar dentro de los rangos.. entonces puede quedar así: =BUSCARV(G4,$B$4:$E$6,4,1) saludos, silvia
  43. 1 point
    Hola Asumiendo que deseas copiar de la columna A, a columna B de hoja zona norte Te adjunto una solución [de varias] con Autofilter, pues solo mencionas que son 3 criterios y es mas que suficiente con este método Saludos Copiar a otra hoja multiples filtros_GP.zip
  44. 1 point
    Gerson Pineda

    Como Cambiar Formatos de fechas

    Hola Si funciona y es efectivo, pero debes seleccionar la columna o el rango completo, de lo contrario sube una muestra del archivo Saludos
  45. 1 point
    isidrod

    Como Cambiar Formatos de fechas

    buen día @ROVER1965 buscar y reemplazar ctrl b buscar por punto reemplazar por guion o diagonal es pero que te funcione https://support.office.com/es-es/article/buscar-o-reemplazar-texto-y-n%C3%BAmeros-en-una-hoja-de-c%C3%A1lculo-0e304ca5-ecef-4808-b90f-fdb42f892e90 saludos isidro
  46. 1 point
    Selection.AutoFill Destination:=Range(Range("K2"), Range("K2").End(xlDown)) Range(Range("K2"), Range("K2").End(xlDown)).Select Revisa toda la macro por si hubiera más instrucciones con este error. Si no te funciona, comentas.
  47. 1 point
    Hola de nuevo! Ademas del aporte de @JSDJSD, adjunto 2 mas, con VBA y Power Query [con este, se debe cambiar a la ruta correspondiente, en la consulta de PQ] Saludos Unir hojas VBA_GP.zip
  48. 1 point
    Hola Isidro Revisa el adjunto [elige 1 entre los 2 métodos] Saludos Copiar archivos entre carpetas_GP.zip
  49. 1 point

    Version 1.0.0

    27 downloads

    Amigos en este nuevo aporte les traigo el archivo Copa America Brasil 2019 - Pronosticos que nos permitirá hacer el seguimiento al evento futbolístico más importante del año; este puede ser usado de 2 maneras (en ambos casos el funcionamiento es el mismo): Simplemente como seguimiento de los juegos, donde vamos colocando los resultados de los juegos y vemos como va evolucionando la clasificación, se puede llevar el seguimiento hasta el juego final. Podemos usarlo para participar en una quiniela, hacemos nuestro pronóstico para todos los juegos, se le envía la quiniela a la persona encargada y esa persona con un archivo especial se encarga de llevar el control de todas las quinielas. Anexo está el archivo y la guía completa de uso, espero que les guste y disfruten del torneo siguiendolo con este archivo gracias
  50. 1 point
    Hola a todos, En el archivo adjunto tengo creada una lista con la referencia de unos productos, cuando inserto en la celda que se encuentra en ROJO, quisiera que se me autocompletara o me sacara coincidencias con la lista que existe, me han dicho que es mediante el uso de visual, pero la verdad no tengo la mas mínima idea. Muchas gracias. Adjunto el archivo. Libro2.zip


  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 5112 personas - Aprender Excel - Total: 4.7 / 5