Jump to content

Leaderboard

Popular Content

Showing content with the highest reputation since 04/13/2021 in all areas

  1. ea4djw

    Uso de ActiveControl

    Aquí está mi pequeño gran proyecto (Como he comentado está en pañales). Para acceder al mogollón del tema pulsar sobre probar luego sobre TPV->Entrada TPV TPV EXCEL.zip
    2 points
  2. Lo primero que te recomendaría es que te acostumbraras a trabajar con los mismos formatos en los datos y en los formularios. Lo primero que veo que me llama la atención y es una de las causas de tus problemas es que en las celdas AM3:AM19 las horas los valores de las horas las tienes introducidas en formato numérico, y al dar formato de celda a Hora Perú tu lo ves como hh/mm/ss a. m./p. m. incluidos espacios y puntos en am y pm. Lo que hace el listbox al seleccionar es tomar el valor REAL de la celda, que en este caso será un valor numérico (puedes verlo si cambias el formato de cel
    2 points
  3. Hola Entre varias opciones que existen, con power query [¿has escuchado sobre este complemento?] se resuelve de una forma un tanto fácil Te dejo el archivo Saludos Dinamizacion de columnas power query_GP.xlsx
    1 point
  4. GabrielRaigosa

    Formula Logica

    Hola, La formula que necesitas en I4 es: =BUSCARV(F2,A11:C15,3) =BUSCARV(F2;A11:C15;3)
    1 point
  5. @Antoni, Estoy leyendo el código poco a poco, porque hay varias instrucciones que no conocía como: la relacionadas con los arreglos y su redimensionamiento preservando los datos, el artificio que emplea para que se reconozca el clic derecho del mouse. Había descartando en principio el uso de Array, porque pensaba que no podía redimensionarlos manteniendo sus valores anteriores. Seguiré haciendo pruebas con el código que mando para dominar y emplear lo que necesito en mi código. Muchísimas Gracias, señor Antoni usted es famoso en lo relacionado Excel, está en todos lados, de cualquier consulta
    1 point
  6. No existe el evento click en un textbox, por lo que hay que detectarlo a través del evento MouseDown o MouseUp. Sí existe, el evento doble-click, pero cuidado, a todos los efectos, un doble-click se tratará como dos clicks, uno detrás de otro. Te dejo un ejemplo de como utilizar un módulo de clase para detectar los eventos de cualquier control, válido tanto para los creados en tiempo de diseño, como para los creados en tiempo de ejecución. En él encontrarás como detectar los eventos: Doble-click Click Clic-derecho Shift+click Shift+clic-derecho
    1 point
  7. Abre la conexión con la base de datos en el evento Initialize del Userform y ciérrala en el evento Terminate. De esta forma no es necesario estar abriendo y cerrando la base de datos, eso si, siempre que se trate de un entorno monousuario, en caso contrario debes ir con cuidado con los parámetros de la conexión para no dejar colgados al resto de usuarios.
    1 point
  8. Prueba así: Private Sub cmb_Hora_Change() If cmb_Hora.ListIndex > -1 Then cmb_Hora = Format(cmb_Hora, "hh:mm:ss am/pm") End Sub
    1 point
  9. La ejecución de Excel en formato web (365) no admite controles active x ni macros. Tienes obligatoriamente que abrir en el excel de esceritorio
    1 point
  10. En el evento change del combo hora: Private Sub cmb_Hora_Change() cmb_Hora = Format(cmb_Hora, "hh:mm:ss am/pm") End Sub
    1 point
  11. Hola No he visto tu archivo, pero solo es cosa que le cambies el formato a fecha Saludos
    1 point
  12. Buenos días; -Adjunto macro corregida. Ahora se puede elegir el logo que se coloca en el título de impresión. A ver que os parece. Saludos. MAjustesImpresión.zip
    1 point
  13. ¡Hola, @santravis! Revisa el adjunto, con una opción. ¡Bendiciones! PRUEBA_PESOS_AUTOC_2.xlsx
    1 point
  14. ok, ok, ahora lo he pillado. Pensaba que trabajabas con la tabla dinámica.. Se me ocurre... en vez de usar si.error, porque no usas algo así?? N5:
    1 point
  15. La protección es a nivel hoja, no obstante se puede cambiar la protección de la hoja al seleccionar una celda. Revisa el adjunto, he añadido esta macro en la hoja: Private Sub Worksheet_SelectionChange(ByVal Target As Range) If Target.Row > 20 Then 'Protección total hasta la fila 20 ActiveSheet.Protect "prueba", AllowFormattingCells:=True Else ActiveSheet.Protect "prueba", AllowFormattingCells:=False End If End Sub foro (1).xlsm
    1 point
  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×
×
  • Create New...

Important Information

Privacy Policy