Jump to content

BUSCAR ULTIMO, PENULTIMO Y ANTEPANULTIMO VALOR DE UNA FILA


hiram

Recommended Posts

Hola amigos, espero puedan ayudarme. busco 3 formulas que me den el ultimo, penultmo y antepenultimo valor de una serie de celdas de una fila que contiene celdas en blanco. Ejemplo:

Ene  |  Feb  |  Mar  |  Abr  |  May  |  Jun  |  Jul  |  Ago  |  Sep  |  Oct  |  Nov  |  Dic  |

80    |  89    |          |          |  72     |  78    |         |           |  90    |   87   |           |         |

Link to comment
Share on other sites

Hace 10 horas, Gerson Pineda dijo:

Hola

Una solución es la que te adjunto

=INDICE($A$2:$L$2,,AGREGAR(14,6,COLUMNA($A$2:$L$2)/($A$2:$L$2<>""),COLUMNAS($A$2:A2)))

Desde A1 los meses, desde A2 los valores

 

Saludos 

 

Muchas gracias Gerson. esta opcion que me das solo me da el ultimo valor, para esa opcion ya tengo la solucion (=BUSCAR(MAX(A2:L2)+2,(A2:L2))) ocupo una que me de el penultimo y antepenutimo valor.

Link to comment
Share on other sites

En 9/9/2021 at 9:50 , Gerson Pineda dijo:

Claro, solo es cosa de copiar la formula hacia la derecha y listo

 

Saludos 

Amigo Gerson... me funciono perfectamente la formula pero solo en las posiciones de columna de la a2 a la L2. si me llevo esa misma formula a otras columnas me marca error de referencia.. pordias ayudarme?

Link to comment
Share on other sites

Hace 8 minutos , Sergio dijo:

@hiram debes fijar las columnas introduciendo el símbolo $ delante de la letra de la columna.

Echa un vistazo a la siguiente publicación donde se explica cómo funcionan las referencias absolutas, relativas y mixtas.

https://ayudaexcel.com/el-uso-de-referencias-en-las-fórmulas/

Un saludo,

Hola Tocayo Sergio muchas gracias... Si se como anclar las clumnas y celdas, el tema es que si el mismo ejecicio me lo llevo a otra parte de la tabla ya no me funciona...

Funciona mientras esta en las columnas de la "A2 a la "L". Si el mismo ejercicio lo corro en otras columnas no funciona y no encuentro por que.


COLUMNAS DE LA "A" A LA "L". FUNCIONA CORRECTAMENTE

Ene Feb Mar Abr May Jun Jul Ago Sep Oct Nov Dic ULTIMO PENULTIMO ANTEPENULTIMO
89   90     76   82     98   98 82 76


COLUMNAS DE LA "A" A LA "L". FUNCIONA CORRECTAMENTE

Ene Feb Mar Abr May Jun Jul Ago Sep Oct Nov Dic ULTIMO PENULTIMO ANTEPENULTIMO
89   90     76   82     98   #¡REF! #¡REF! #¡REF!

 

 

Link to comment
Share on other sites

Hace 1 hora, Sergio dijo:

Sergio, indícame las referencias en las que tienes los datos de la tabla que da error.

 

ULTIMO:
=INDICE($R$2:$AC$2,,AGREGAR(14,6,COLUMNA($R$2:$AC$2)/($R$2:$AC$2<>""),COLUMNAS($R$2:R2)))

PENULTIMO:

=INDICE($R$2:$AC$2,,AGREGAR(14,6,COLUMNA($R$2:$AC$2)/($R$2:$AC$2<>""),COLUMNAS($R$2:S2)))

ANTEPENULTIMO:

=INDICE($R$2:$AC$2,,AGREGAR(14,6,COLUMNA($R$2:$AC$2)/($R$2:$AC$2<>""),COLUMNAS($R$2:T2)))

Link to comment
Share on other sites

Hace 1 hora, Gerson Pineda dijo:

Tu dificultad es de adaptación porque debes manejar mejor las referencias

Te sugiero leer el articulo de @Sergio

Mientras lo haces, en el argumento de columna de INDICE, escribe, 1, 2 y 3 y listo

 

Saludos!

Gracias amigos... si entreare a ver la informacion que me proporcionan... si me hace mucha falta. Saludos

Link to comment
Share on other sites

Hace 4 horas, hiram dijo:

ULTIMO:
=INDICE($R$2:$AC$2,,AGREGAR(14,6,COLUMNA($R$2:$AC$2)/($R$2:$AC$2<>""),COLUMNAS($R$2:R2)))

PENULTIMO:

=INDICE($R$2:$AC$2,,AGREGAR(14,6,COLUMNA($R$2:$AC$2)/($R$2:$AC$2<>""),COLUMNAS($R$2:S2)))

ANTEPENULTIMO:

=INDICE($R$2:$AC$2,,AGREGAR(14,6,COLUMNA($R$2:$AC$2)/($R$2:$AC$2<>""),COLUMNAS($R$2:T2)))

Complicado no?, si observas que las referencias si las movi al rango que necesita?. por alguna razon la formula INDICE me da un errro de referencia..

Link to comment
Share on other sites

                             
                               
ENE FEB MAR ABR MAY JUN JUL AGO SEP OCT NOV   ANTEPE… PENULT… ULTIMO  
                               
23 43   253 46 437 47 4 564 3 45   564 3 45  
28 48 5 258 51 442 52 9 569 8 50   569 8 50  
33 53 10 263 56 447 57 14 574 13 55   574 13 55  
38 58 15 268 61 452 62 19 579 18 60   579 18 60  
                               
                               
formulas de la fila 3     Antepenultimo   DESREF($A$1,FILA(A3)-FILA(A$1),CONTARA($A$1:$K$1)-3)  
        Penultimo     DESREF($A$1,FILA(A3)-FILA(A$1),CONTARA($A$1:$K$1)-2)  
        Ultimo     DESREF($A$1,FILA(A3)-FILA(A$1),CONTARA($A$1:$K$1)-1)  
                               
                               
Link to comment
Share on other sites

  • Crear macros Excel

  • Posts

    • Buenas noches a todos. Se lo que le voy a pedir, para ustedes es algo fácil en la cual para mi es algo difícil.  espero su gran ayuda. https://postimg.cc/1nnXDN5W   IMG del Proyecto esto es solo en suma y resta. El esquema es el siguiente: 1 Cartas  ----- dará  -1     -------  ejem: vemos arriba  "3 Energía" " 6 Cartas "  presionamos "1 Cartas" -- daría "2 Energía" "5 Cartas"  que se pueda jugar con los botones cuando agregan cartas, si tal caso da "0" que salga mensaje "No tiene mas energía"  Cuando presiones el el botón " Pasa Turno " dará la siguiente suma  "dará +2 Energía  +3 Carta" El botón  " + Energía " solo dará " +1 Energía "  Botón "Carta En 0 "  solo sumara +1 Energía"     Se que es fácil pero no se hacerlo.   Espero su gran ayuda.   Donde dice "       Archivo VBA
    • Hola Eso que me dices para mi ya es ciencia ficción. De momento para lo que necesito con esto ya tengo bastante. Cuando aprenda un poco ya ire intentando cosas mas complicadas. No te creas que comprender las macros que me habeis ayudado tu, Antoni y Gerson Pineda, me esta costando lo suyo. De momento mis conocimientos son muy basicos y tengo que estar constantemente mirando manuales y aun asi me cuesta.   Saludos
    • Primero dale forma a lo que quieres medir, evaluar, gestionar, etc. Con esto ya tendras un punto de partida Posteriormente, como lo quieres medir y por último como quieres ver los resultados con toda la información que acumularás. Espero te de una luz. Saludos.
    • Observo que el cuerpo de las preguntas no corresponde al cuerpo de la información obtenida. Te lo comento porque se podría obtener el resultado de la encuesta por cada pregunta, tiempos de respuetsa, opinion segmentado por sexo,etc.
    • Hola Por favor, quisiera su ayuda, guias, conocimiento ..ect..ect.. Quiero hacer un archivo en excel donde lleve una estadistica de beisbol donde lleve las posiciones de los equios de acuerdo a los resultados de los juegos entre ellos y que automaticamente me actualice las posiciones de cada uno de ellos en una tabla de posiciones general. Como comienzo?,,,,formulas a usar….etc..etc..etc.. muchas gracias
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy