Jump to content

Fórmula SUMAR.SI buscando datos parciales de celda


Recommended Posts

Hola, buenas tardes. Os pido ayuda para este problema. Quiero hacer sin necesidad de macros, si es posible y no veo como hacerlo. Se trata de sumar los importes de un rango teniendo en cuenta que el valor que se busca de la celda es las 4 cifras de la izquierda. Envío un ejemplo con el resultado en amarillo.

Por ejemplo todas las obras que empiecen por 1100 se refieren a la delegación 1100. La obra sería 11000001, 11000002 por ejemplo.

Como digo es un ejemplo, no tiene nada que ver con el fichero original que tiene muchas otras celdas y obras. pero siempre coincide los primeros 4 dígitos de la obra con el numero de delegación.

Gracias de antemano.

 

CuotaDelegación.xlsx

Link to comment
Share on other sites

Hace 2 horas, John Jairo V dijo:

¡Hola @Pirtrafilla!

Los comodines en la función SUMAR.SI solamente trabajan con textos, no con números.  Dicho esto, puedes usar como alternativa la función SUMAPRODUCTO, de la siguiente forma:

=SUMAPRODUCTO(--(IZQUIERDA(F$2:F$8;4)=A2&"");G$2:G$8)

¡Bendiciones!

@John Jairo VMuchas gracias!!

Solucionado.

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

Privacy Policy