Jump to content

Pirtrafilla

Pro Member
  • Content Count

    387
  • Joined

  • Last visited

  • Days Won

    2

Pirtrafilla last won the day on March 28

Pirtrafilla had the most liked content!

About Pirtrafilla

  • Rank
    Advanced Member
  • Birthday 06/09/1968

Converted

  • Campos
    ;

Recent Profile Visitors

940 profile views
  1. Hola a todos, no me ha podido ayudar nadie de momento. Entiendo que el Office 365 es un poco reciente y no hay tanta información. De todos modos he conseguido que la empresa me ponga el Outlook en escritorio y me vuelve a funcionar con los códigos que ya tenía, pero si a alguien se le ocurre como hacer lo que solicito ayuda os lo agradezco, seguro que será útil. Gracias de todos modos, un abrazo. Moisés.
  2. Hola a todos. Envío un fichero de muestra, a ver si podéis ayudarme. Con O365 no encuentro la misma información que las versiones convencionales. Tengo O365 con aplicaciones en escritorio. Gracias. Moisés. EnviarCorreoRangoCeldas.xlsm
  3. Hola a todos. De nuevo por aquí pidiendo ayuda. Nos han cambiado las licencias de Office a Office 365. He revisado las macros y las que me fallan tienen que ver con las que envío correos automatizados. He podido arreglar todas, cambiando el código porque de Office 2013 a Office 365 cambia el código, se usa el objeto CDO.Message. Pero se me resiste esta macro, que envía un correo e incluye como parte del cuerpo del correo un rango de celdas donde hay un gráfico. Os pego el código para ver si me podéis ayudar. Después de la instrucción "ActiveWorkbook.EnvelopeVisible = True" el programa ya
  4. De nada, no se merecen. Solamente he comentado la solución de @torquemada, la ayuda te la ha dado él. Un abrazo.
  5. Revisa bien como lo tienes, porque a mi me sale bien la fórmula de @torquemada. Seguramente sea una tontería, un error al transcribir, el formato de la celda... ERROR FORMULA DIVISON %.xlsx
  6. ¿Y si lo guardas en una variable pública? La puedes usar luego en el mismo proyecto mientras no cierres el libro. No soy muy erudito pero creo que es algo así.
  7. Muchas gracias. La he adaptado porque la celda "C2" la tengo que poner a mano, no es la fecha de hoya ya que el fichero lo puedo abrir otro mes pero quiero el dato de ese Período fijado. Así que: En C3 he puesto "=TEXTO(FECHA(IZQUIERDA(C3;4);DERECHA(C3;2);1)-1;"AAAAMM")" En D3 he puesto "=TEXTO(FECHA(IZQUIERDA(D3;4);DERECHA(D3;2);1)-1;"AAAAMM")" Al convertir a texto la celda C3 ya no he podido poner "=FIN.MES(C3;-1)". Y necesito se quede como texto porque después hay otras fórmulas que buscan el nombre de la hoja que da como resultado las formulas. Es decir que hay hoj
  8. Hola a todos, tengo una formula que no consigo dar con ella. En unas celdas tengo esto. Quisiera que al cambiar de Período me cambie el mes anterior y el segundo anterior bien. Para no tener que hacerlo a mano. Por ejemplo, si pongo en Período 202101 me ponga a la derecha 202101 y 202012 Y si pongo Período 202102 me ponga a la derecha 202101 y 202012. Gracias! Moisés.
  9. Hola, que tal. Prueba con esta fórmula. =SI(DERECHA(B3;1)=".";IZQUIERDA(B3;LARGO(B3)-1);B3) Saludos.
  10. Creo que ya lo he solucionado, lo de la lentitud..... Private Sub Boton1_Click() Application.ScreenUpdating = False Application.Calculation = xlCalculationManual ............ ............ ............ Application.ScreenUpdating = True Application.Calculation = xlCalculationAutomatic LimpiarTextbox Bt_Buscar End Sub @Antoni, MUCHAS GRACIAS!
  11. @Antoni, primero de todo gracias. He estado probando y funciona perfectamente. Pero hay un problema. Mira el pantallazo y fíjate en la fila que están estos datos. Cuando le doy al botón de MODIFICAR ha tardado 30 segundos en hacerlo. Y eso que ahora es marzo, cuando lleguemos a agosto no quiero pensar lo que va a tardar. Y cada paso se veía un parpadeo, creo que debido a que cada vez que modifica un dato en el Excel recalcula, porque eso me pasa cuando lo hago a mano sin el formulario. Y al final graba el dato correctamente. No se si hay manera que no recalcule y lo haga cuando ya
  12. Hola de nuevo. Necesito de vuestra ayuda, voy perdido con la segunda condición. Os lo agradezco. Moisés.
  13. Jolines, que patoso. Me estaba equivocado en el nombre de la hoja. Ahora encuentra el nombre pero no se como hacer la otra condición, que coincida además la fecha. Agradezco la ayuda. Moisés.
×
×
  • Create New...

Important Information

Privacy Policy