Jump to content

Sumar o restar si mayor o menor


Recommended Posts

Hola @luisalv.

Tengo un problema con la solución.

Según pides en el archivo, si los dos números son mayores de la referencia, 5, 50, 500...; se restan del mayor al menor.

Si los dos números son menores de la referencia se suman.

¿Y si uno es mayor y el otro menor de la referencia, que ocurre?

Saludos.

Link to post
Share on other sites

hola Luisalv   (y  torquemada 😀)

 

Hace 7 minutos , torquemada dijo:

¿Y si uno es mayor y el otro menor de la referencia, que ocurre?

256 985 729
587 397 190

Se restan...

😉

Link to post
Share on other sites

Hola Silvia.

Es que en el ejemplo de la hoja, en uno se suman y en otro se restan

587 397 190
587 543 44
123 486 609

 

Saludos.

   
P:D. Esperaremos una aclaración.    
     
Edited by torquemada
modificar
Link to post
Share on other sites

1. el 1ero sobrepasa 500 el otro no, se resta

2. el 1ero y el 2do sobrepasan 500, los resta. >> dijo esto>>  si los dos son mayores se restan, el superior del inferior

3.ninguno sobre pasa 500 , los suma..

 

Link to post
Share on other sites

Hola Silvia.

Supongo, que te refieres a compararlo como si "PX" fuese 500.

Hace 1 hora, torquemada dijo:

Hola @luisalv.

Tengo un problema con la solución.

Según pides en el archivo, si los dos números son mayores de la referencia, 5, 50, 500...; se restan del mayor al menor.

Si los dos números son menores de la referencia se suman.

¿Y si uno es mayor y el otro menor de la referencia, que ocurre?

Saludos.

Por eso era la pregunta.

Porque si te fijas:

587 397

190

Saludos.

Edited by torquemada
Link to post
Share on other sites

según los resultados, en estos casos

587 397 190  

- En ese caso se restan

985475 235 985240

- En ese caso también se restan...

Pero con tu formula se suman...  tampoco creas que estoy entendiendo...  , estoy intentandolo, pero cada vez me pierdo mas.. jaja

😁

 

 

 

Link to post
Share on other sites
Hace 9 minutos , Silvia dijo:
41258 523 42051

Esta no te cuadra

😄😄

y yo me estoy volviendo loca.....!!

 

si los dos son mayores, de 500; se restan, el superior del inferior.

Eso dicen las instrucciones.

En el ejemplo, Él los suma ???

Saludos.

Link to post
Share on other sites

Hola, si los dos son menores se suman, si los dos son mayores se reste el menor, si uno es mayor y otro menor se resta el menor, siempre teniendo en cuenta que el mas largo es el que manda, entre 0 y 4 del primer digito serian menores y de 5 a 9 serian mayores, espero que me explique un poco mejor, saludos

Link to post
Share on other sites

Estaba revisando, esta funciona pero al ser los dos menores los resta y tiene que sumarlos, voy a seguir viendo

 

=SI(Y(K.ESIMO.MAYOR($E3:$F3;FILA($A$1))>$P3;K.ESIMO.MAYOR($E3:$F3;FILA($A$2))>$P3);K.ESIMO.MAYOR($E3:$F3;FILA($A$1))-K.ESIMO.MAYOR($E3:$F3;FILA($A$2));SI(Y(K.ESIMO.MAYOR($E3:$F3;FILA($A$1))>$P3;K.ESIMO.MAYOR($E3:$F3;FILA($A$2))<$P3);K.ESIMO.MAYOR($E3:$F3;FILA($A$1))-K.ESIMO.MAYOR($E3:$F3;FILA($A$2));SUMA($E3:$F3)))

Link to post
Share on other sites
Hace 19 minutos , luisalv dijo:

Hola Silvia, estaba en eso, funciona correctamente sea cual se el largo del numero, lo que necesito es todo en una formula y que funcionara asa de bien, gracias por tu aporte.

 

Al menos para mi, está difícil.. ya que tienes que evaluar los dos importes con las dos columnas de la tabla...  

Por si acaso, acabo de notar que hice mal la copia en una de las columnas auxiliares, acabo de corregir.

saludos,

Silvia

 

 

Link to post
Share on other sites

Hola, habría alguna forma de adaptar esta formula a cualquier largo que tengan los números, gracias

 

=SI(Y(E4<=499;F4<=499);E4+F4;SI(O(E4>=500;F4>=500);MAX(E4:F4)-MIN(E4:F4);SI(Y(E4>=500;F4>=500);MAX(E4:F4)-MIN(E4:F4))))

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Crear macros Excel

  • Posts

    • Sustituye tu macro por esta: Sub Sumar() Dim fila As Byte Application.ScreenUpdating = False With Sheets("STOCK") .Range("H3:L7") = "" For I = 2 To .Range("A" & Rows.Count).End(xlUp).Row - 1 fila = 0 Select Case .Range("B" & I).Interior.Color Case Range("H3").Interior.Color: fila = 3 Case Range("H4").Interior.Color: fila = 4 Case Range("H5").Interior.Color: fila = 5 Case Range("H6").Interior.Color: fila = 6 End Select If fila > 0 Then .Range("I" & fila) = .Range("I" & fila) + .Range("F" & I) .Range("I7") = .Range("I7") + .Range("F" & I) .Range("J" & fila) = .Range("I" & fila) / 2.8 .Range("J7") = .Range("I7") / 2.8 .Range("L" & fila) = (.Range("L" & fila) + .Range("B" & I) * .Range("F" & I)) .Range("L7") = (.Range("L7") + .Range("B" & I) * .Range("F" & I)) End If Next For I = 3 To 7: .Range("K" & I) = .Range("L" & I) / .Range("I" & I): Next .Range("L3:L7") = "" End With End Sub  
    • @santravis perdona por la tardanza, voy muy mal de tiempo. Te dejo una idea para empezar... con unas puntualizaciones. No he resuelto las columnas que son combinacion de dos. Cuidado con los titulos de las columnas de la hoja ordenado, tienen al final un espacio y los nombres asi no son identicos a los homonimos de la hoja 1archivo consulta.xlsx archivo consulta.xlsx
    • muchísimas gracias! funciona perfecto y lo he probado adaptándolo a lo mío y también va bien. ;). Gracias!
    • Para la creación de la TC hay distintas formas, pero cada una es valida En efecto Jose, PBI es un gran universo pero Excel siempre será nuestro gran aliado, y es además un gran complemento de PBI   Saludos 
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy