Jump to content

Sumar o restar si mayor o menor


Recommended Posts

Hola @luisalv.

Tengo un problema con la solución.

Según pides en el archivo, si los dos números son mayores de la referencia, 5, 50, 500...; se restan del mayor al menor.

Si los dos números son menores de la referencia se suman.

¿Y si uno es mayor y el otro menor de la referencia, que ocurre?

Saludos.

Link to post
Share on other sites

hola Luisalv   (y  torquemada 😀)

 

Hace 7 minutos , torquemada dijo:

¿Y si uno es mayor y el otro menor de la referencia, que ocurre?

256 985 729
587 397 190

Se restan...

😉

Link to post
Share on other sites

Hola Silvia.

Es que en el ejemplo de la hoja, en uno se suman y en otro se restan

587 397 190
587 543 44
123 486 609

 

Saludos.

   
P:D. Esperaremos una aclaración.    
     
Edited by torquemada
modificar
Link to post
Share on other sites

1. el 1ero sobrepasa 500 el otro no, se resta

2. el 1ero y el 2do sobrepasan 500, los resta. >> dijo esto>>  si los dos son mayores se restan, el superior del inferior

3.ninguno sobre pasa 500 , los suma..

 

Link to post
Share on other sites

Hola Silvia.

Supongo, que te refieres a compararlo como si "PX" fuese 500.

Hace 1 hora, torquemada dijo:

Hola @luisalv.

Tengo un problema con la solución.

Según pides en el archivo, si los dos números son mayores de la referencia, 5, 50, 500...; se restan del mayor al menor.

Si los dos números son menores de la referencia se suman.

¿Y si uno es mayor y el otro menor de la referencia, que ocurre?

Saludos.

Por eso era la pregunta.

Porque si te fijas:

587 397

190

Saludos.

Edited by torquemada
Link to post
Share on other sites

según los resultados, en estos casos

587 397 190  

- En ese caso se restan

985475 235 985240

- En ese caso también se restan...

Pero con tu formula se suman...  tampoco creas que estoy entendiendo...  , estoy intentandolo, pero cada vez me pierdo mas.. jaja

😁

 

 

 

Link to post
Share on other sites
Hace 9 minutos , Silvia dijo:
41258 523 42051

Esta no te cuadra

😄😄

y yo me estoy volviendo loca.....!!

 

si los dos son mayores, de 500; se restan, el superior del inferior.

Eso dicen las instrucciones.

En el ejemplo, Él los suma ???

Saludos.

Link to post
Share on other sites

Hola, si los dos son menores se suman, si los dos son mayores se reste el menor, si uno es mayor y otro menor se resta el menor, siempre teniendo en cuenta que el mas largo es el que manda, entre 0 y 4 del primer digito serian menores y de 5 a 9 serian mayores, espero que me explique un poco mejor, saludos

Link to post
Share on other sites

Estaba revisando, esta funciona pero al ser los dos menores los resta y tiene que sumarlos, voy a seguir viendo

 

=SI(Y(K.ESIMO.MAYOR($E3:$F3;FILA($A$1))>$P3;K.ESIMO.MAYOR($E3:$F3;FILA($A$2))>$P3);K.ESIMO.MAYOR($E3:$F3;FILA($A$1))-K.ESIMO.MAYOR($E3:$F3;FILA($A$2));SI(Y(K.ESIMO.MAYOR($E3:$F3;FILA($A$1))>$P3;K.ESIMO.MAYOR($E3:$F3;FILA($A$2))<$P3);K.ESIMO.MAYOR($E3:$F3;FILA($A$1))-K.ESIMO.MAYOR($E3:$F3;FILA($A$2));SUMA($E3:$F3)))

Link to post
Share on other sites
Hace 19 minutos , luisalv dijo:

Hola Silvia, estaba en eso, funciona correctamente sea cual se el largo del numero, lo que necesito es todo en una formula y que funcionara asa de bien, gracias por tu aporte.

 

Al menos para mi, está difícil.. ya que tienes que evaluar los dos importes con las dos columnas de la tabla...  

Por si acaso, acabo de notar que hice mal la copia en una de las columnas auxiliares, acabo de corregir.

saludos,

Silvia

 

 

Link to post
Share on other sites

Hola, habría alguna forma de adaptar esta formula a cualquier largo que tengan los números, gracias

 

=SI(Y(E4<=499;F4<=499);E4+F4;SI(O(E4>=500;F4>=500);MAX(E4:F4)-MIN(E4:F4);SI(Y(E4>=500;F4>=500);MAX(E4:F4)-MIN(E4:F4))))

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Crear macros Excel

  • Posts

    • ¡¡¡¡ El archivo Libro1-1.xlsm
    • Prueba la macro, la solución en BD Solucion2de2, sin pasar por BD Solucion1de2. Sub FillRate() Application.ScreenUpdating = False With Sheets("BD Solución2de2") Sheets("BD").Cells.Copy .Cells .Select For x = 2 To .Range("A" & Rows.Count).End(xlUp).Row If x Mod 500 = 0 Then Application.StatusBar = "Tratando fila " & x If Not .Range("A" & x) = "" Then If .Range("C" & x) > 0 Then Base = "C" & x .Range("I" & x).Formula = "=D" & x & "/" & Base If .Range("I" & x) > 1 Or .Range("I" & x) < 0 Then .Rows(x).Delete x = x - 1 End If End If Next End With Application.StatusBar = False End Sub En la línea de estado de Excel se muestra un pequeño avance del proceso.
    • Un saludo a ambos, aquí te dejo otra opción
    • Private Sub TextBox1_Change() ActiveSheet.Range("C6").Value = TextBox1.Text TextBox3 = Range("C8").Text End Sub Private Sub TextBox2_Change() ActiveSheet.Range("C7").Value = TextBox2.Text TextBox3 = Range("C8").Text End Sub Private Sub CommandButton1_Click() TextBox1 = Empty TextBox2 = Empty TextBox3 = Empty TextBox1.SetFocus End Sub  
    • este es el archivo con userform   Libro1.xlsm
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy