Jump to content

¿Macros o Funciones?


CECILIO

Recommended Posts

Buenas tardes tengan todos ustedes

Tengo la siguiente inquietud, tengo un libro de excel con aproximadamente 15 ,000  registros /filas  de la cual en 13 columnas uso las funciones/formulas =SI(M11028="","",BUSCARV($M11028,CUENTAABONO,2,FALSO)), y obviamente esta lentisimo el archivo, ¿trabajándolo con macros( Application.VLookup) se podría aligerar este archivo? o no habría diferencia alguna?

 

de antemano Mil Gracias

 

 

Link to comment
Share on other sites

Hace 14 horas, CECILIO dijo:

¿trabajándolo con macros( Application.VLookup) se podría aligerar este archivo? o no habría diferencia alguna?

Pues supongo que, optimizando al máximo el código, sí que encontrarías mucha diferencia

Link to comment
Share on other sites

Hace 22 horas, CECILIO dijo:

Buenas tardes tengan todos ustedes

Tengo la siguiente inquietud, tengo un libro de excel con aproximadamente 15 ,000  registros /filas  de la cual en 13 columnas uso las funciones/formulas =SI(M11028="","",BUSCARV($M11028,CUENTAABONO,2,FALSO)), y obviamente esta lentisimo el archivo, ¿trabajándolo con macros( Application.VLookup) se podría aligerar este archivo? o no habría diferencia alguna?

 

de antemano Mil Gracias

 

 

La "lentitud" de los procesos en Excel, son relativos (a muchos factores y es un tema bastante largo)

Una simple función como la que estas utilizando, no debería ser la única razón de tu problema, pues Buscarv es de lo mejor que hay respecto a rendimiento, existen otras funciones mas optimizadas y que nos brindan mejores resultados, pero es cada cosa en su caso!

 

Saludos 

Link to comment
Share on other sites

ok Gracias a todos y a cada uno de ustedes por su valiosa sugerencia/opinión , en definitiva voy a implementar (Application.VLookup) ya les contaré como me va

y en cuanto a las características de la PC pues tengo las siguientes

Procesador:Intel(R) core (TM) i5-4460 CPU @  3.20 GHZ

Memoria instalada(RAM)8.00 GB(7.89 GB utilizable)

Tipo de sistema:Sistema operativo de 64 bits procesador x64

 

 

Link to comment
Share on other sites

Hace 25 minutos , CECILIO dijo:

en definitiva voy a implementar (Application.VLookup)

Como te respondí en el otro similar a este tema, Application.VLookup la sugiero para resultados de una sola celda, pues lo tuyo comentas que son mas de 15mil filas, estarías aplicando un ciclo bastante largo para aplicarlo

Tal como lo hice en "este" tu tema y como ves hay varios factores que pueden ralentizar nuestros procesos en Excel 

Saludos 

Link to comment
Share on other sites

Hace 3 horas, CECILIO dijo:

ok Gracias a todos y a cada uno de ustedes por su valiosa sugerencia/opinión , en definitiva voy a implementar (Application.VLookup) ya les contaré como me va

y en cuanto a las características de la PC pues tengo las siguientes

Procesador:Intel(R) core (TM) i5-4460 CPU @  3.20 GHZ

Memoria instalada(RAM)8.00 GB(7.89 GB utilizable)

Tipo de sistema:Sistema operativo de 64 bits procesador x64

Jajaja... @CECILIO, debes de estar de broma obviamente no es tu equipo el problema. Me sorprende ver que muchos usuarios tienen la idea de que necesitan grandes recursos para una hoja de calculo... sin duda debe ser algo en tu libro. So pena de no poder contar con el, seria didáctico descubrir cual es la raiz de esa lentitud que mencionas!

Saludos!

Link to comment
Share on other sites

Mientras más fórmulas tenga y más grande sea el campo calculado y más datos tenga el libro de excel cada vez será más lento, esto se debe a que las fórmulas se recalculan cada vez que realices un cambio o modificación. Una solución sería activar el cálculo manual, así solo se calculara cuando tu decidas actualizarlas, entonces tu libro solamente será lenta cuando actualices la Fórmula.

En lo personal me he deshecho de la mayoría de las fórmulas y aplicado macros, ya que en ellos puedo decidir cuando, donde y como actualizar los campos de datos, y he ganado velocidad en mis libros de excel.

Yo no aconsejaría la utilización de fórmulas cuando se tiene libros muy grandes, si hay oportunidad y es posible es mejor una macro.

Link to comment
Share on other sites

Hace 15 horas, CECILIO dijo:

así es  , realmente en ocasiones se queda como calculando y si le doy clik , me ha pasado que hasta se queda sin responder por buen rato, pero es la realidad que vivo con esta pc

Tu problema no es probablemente Excel, pueden ser otros factores

En este tema https://ayudaexcel.com/foro/topic/38083-buscarvconsultav-con-vba/ 

Te brinde esta opcion

Private Sub Worksheet_Change(ByVal Target As Range)

If Target.Column <> 1 Then Exit Sub
vuf = Range("A" & Rows.Count).End(xlUp).Row
With Range("A3:A" & vuf)
    vr = .Resize(, 2).Address
    With .Offset(, 5).Resize(, 1)
        .Formula = "=iferror(vlookup(A3, " & vr & ",2,0),"""")"
        .Formula = .Value
    End With
End With

End Sub

Y no es razón para ralentizar tus procesos

 

Suerte!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Privacy Policy