Jump to content

isidrod

Members
  • Content Count

    212
  • Joined

  • Last visited

  • Days Won

    2

1 Follower

About isidrod

  • Rank
    Advanced Member

Contact Methods

  • Website URL Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. copiar pega esa formula Luis Antonio a ver si te funciona =SI(IZQUIERDA(B2,1)="T",B2,A1) saludos isidrod
  2. ahí esta por si no lo quiere con tabla dinámica https://onedrive.live.com/?id=5AAEBD13773A2C23%21130&cid=5AAEBD13773A2C23 se llama: resultado de Prueba Utilidades.xlsm saludos isidro
  3. buen día @Iphant te dejo un ejemplo a ver si es lo que quieres ejemplo.xlsx
  4. como comprenderás los xml no tienen un solo formato te dejo estos link https://lerh13.blogspot.com/2018/11/vba-excel-macro-para-leer-xml-cfdi-33-y.html https://ayudaexcel.com/foro/topic/39035-importar-datos-de-xml-cfdi-33-a-excel/ 'https://www.extendoffice.com Sub From_XML_To_XL() 'UpdatebyKutoolsforExcel20151214 Dim xWb As Workbook Dim xSWb As Workbook Dim xStrPath As String Dim xFileDialog As FileDialog Dim xFile As String Dim xCount As Long With Application .ScreenUpdating = False .Calculation = xlCalculationManual On Error GoTo ErrHandler With Worksheets("Hoja1").Select Set xFileDialog = Application.FileDialog(msoFileDialogFolderPicker) xFileDialog.AllowMultiSelect = False xFileDialog.Title = "Select a folder [Kutools for Excel]" If xFileDialog.Show = -1 Then xStrPath = xFileDialog.SelectedItems(1) End If If xStrPath = "" Then Exit Sub Application.ScreenUpdating = False Set xSWb = ThisWorkbook xCount = 1 xFile = Dir(xStrPath & "\*.xml") Do While xFile <> "" Set xWb = Workbooks.OpenXML(xStrPath & "\" & xFile) xWb.Sheets(1).UsedRange.Copy xSWb.Sheets(1).Cells(xCount, 1) xWb.Close False xCount = xSWb.Sheets(1).UsedRange.Rows.Count + 2 xFile = Dir() Loop End With .ScreenUpdating = True .Calculation = xlCalculationAutomatic End With xSWb.Save Exit Sub ErrHandler: MsgBox "no files xml", , "Kutools for Excel" End Sub de este código no tengo exactamente el link pero de esa pagina lo baje
  5. ahí esta formula para =SI(F3="002",(C3*0.16),"") saludos isidro
  6. hola @Banguala sube un ejemplo para poner ahí la formula, pero si te funciona así ahí esta
  7. ahí mira ya con formato personalizado https://sheepotaku.wordpress.com/2011/01/29/convertir-fecha-de-formato-sap-a-excel/ saludos isidro
  8. ahí esta de nuevo con formula EJEMPLO de fechas.xlsx
  9. buen día @ROVER1965 buscar y reemplazar ctrl b buscar por punto reemplazar por guion o diagonal es pero que te funcione https://support.office.com/es-es/article/buscar-o-reemplazar-texto-y-n%C3%BAmeros-en-una-hoja-de-c%C3%A1lculo-0e304ca5-ecef-4808-b90f-fdb42f892e90 saludos isidro
  10. @Gerson Pineda gracias por esta ayuda que me has proporcionado, y a todos los que apoyan en esta foro tema solucionado @Gerson Pineda dios derrame bendiciones a ti a tu familia y tu pueblo entero saludos isidro
  11. @Gerson Pineda mil gracias funciona bien, solo un pequeño comentario. Se podrá poner una leyenda en la columna C "no se encuentra la ruta destino"? cuando la ruta no esta bien en la columna "D" si no ya con eso me doy por bueno y solucionado, gracias tu colaboración saludos isidro
  12. gracias @Gerson Pineda funciona bien, pero por favor no cierres el tema el lunes voy probar en lo real copiar de unidad C a unidad de red, mil gracias saludos isidro
  13. buen día foro alguien sabe de como copiar archivo de una carpeta a otra teniendo las rutas de origen y destino con macros. estado batallando con este tipo de situación, pero no logro hacerlo tengo la ruta de origen en la columna A y el nombre de archivo en la columna B y en C una leyenda que diga " archivo no encontrado" y D las rutas de destino, en la columna D esta varios destino dependiendo el archivo, subo ejemplo, gracias por sus ayudas o comentarios. saludos isidro COPIAR DE UNA CARPETA A OTRA.xlsm
  14. gracias @Héctor Miguel, es una pagina donde se descarga mas 300 facturas al día, esa maquina seria exclusivo para descargar esas facturas solo tendría acceso único y exclusivo a esa pagina, pero eso lo haría sistema yo no tengo permiso. cada link es una factura lo pienso ejecutar con macros mil gracias por tu aportación saludos isidro
  15. buena tarde equipo de este foro, tengo en excel una lista de hipervinculo que son para descargar factura en pdf, pero cada link que doy click me aparece este mensaje, por favor alguien sabe como desactivarlo . Gracias por su amable interés saludos isidro
×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 5112 personas - Aprender Excel - Total: 4.7 / 5