Jump to content

Toldeman

Moderators
  • Content Count

    3,389
  • Joined

  • Last visited

  • Days Won

    20

Toldeman last won the day on January 17

Toldeman had the most liked content!

2 Followers

About Toldeman

  • Rank
    Juan
  • Birthday 03/12/1965

Contact Methods

  • Website URL
    http://www.toldospino.es/

Converted

  • Campos
    ;

Recent Profile Visitors

1,816 profile views
  1. Hola, unicamente debes de copiar el codigo en el editor de visual basic y ejecutar la macro Sub Abrir_Archivos() Dim Hoja As Object Application.ScreenUpdating = False 'Definir la variable como tipo Variante Dim X As Variant 'Abrir cuadro de dialogo X = Application.GetOpenFilename _ ("Excel Files (*.xlsx), *.xlsx", 2, "Abrir archivos", , True) 'Validar si se seleccionaron archivos If IsArray(X) Then ' Si se seleccionan 'Crea Libro nuevo Set newBook = Workbooks.Add 'Captura nombre de archivo destino donde se grabaran los archivos seleccionados A = ActiveWorkbook.Name For y = LBound(X) To UBound(X) Application.StatusBar = "Importando Archivos: " & X(y) Workbooks.Open X(y) b = ActiveWorkbook.Name For Each Hoja In ActiveWorkbook.Sheets Hoja.Copy after:=Workbooks(A).Sheets(Workbooks(A).Sheets.Count) Next Workbooks(b).Close False Next Application.StatusBar = "Listo" Call Unir_Hojas End If Application.ScreenUpdating = False End Sub Sub Unir_Hojas() Dim Sig As Byte, eliminar As Boolean For Sig = 2 To Worksheets.Count Worksheets(Sig).UsedRange.Copy _ Worksheets(1).Range("a1000000").End(xlUp).Offset(1) Next Application.DisplayAlerts = False For Sig = 2 To Worksheets.Count Worksheets(2).Delete Next Application.DisplayAlerts = True End Sub Este codigo no lo he probado, pero tiene buena pinta. Ejecutalo y comenta si hace lo que pretendes o necesitas alguna modificacion. Un saludo.
  2. Hola, revisa este enlace. https://es.justexw.com/como-combinar-dos-libros-de-excel.html Hay varias formas. Un saludo.
  3. Hola, prueba el adjunto. Un saludo. HISTORICO DE PRODUCCION.xls
  4. Hola. Prueba poniendo esta linea de codigo para que te vuelva a poner la formula. [e6].Formula = "=IFERROR(vlookup(B4,B41:H43,2,0)," & "" & ")" Antoni un placer saludarte. Un abrazo y suerte en champions.
  5. Hola, segun la formula que tienes puedes añadirle otro Si. =SI(E6="Media Jornada";SI(E6="Inspector";BUSCARV(I2;Datos!B15:J22;2;0);BUSCARV(I2;Datos!B4:I11;2;0))/2;SI(E6="Inspector";BUSCARV(I2;Datos!B15:J22;2;0);BUSCARV(I2;Datos!B4:I11;2;0))) Saludos.
  6. Lo siento pero no te entiendo. Esa formula que hace aparte de traerte el año. No comentas nada sobre el archivo que te he subido, si es lo que buscas o no lo es. Lo mejor es que pusieras de forma manual los resultados esperados y la logica de los mismos. Saludos.
  7. Hola. Vamos a ir por partes, te he subido tu archivo con una formula que cuenta por meses, la referencia del mes esta puesta debajo de la celda que Has puesto Mes. Revisa y comentas. Un saludo. prueba-1.xls
  8. Buenos dias. He estado mirando tu archivo y no tengo nada claro lo de las x y los SI. Lo unico que he visto que en la hoja principal solicitas una formula para que te traiga la oficina del agente. Con un buscarv tienes resuelta esa parte: =BUSCARV(A4;Variables!A$2:B$31;2;0)[/cod]. Saludos.
  9. Hola, segun he entendido prueba esta formula: =SI(CONTAR(H:H)=1;SUMA(E:E);"") Saludos.
  10. Hola. Segun he entendido prueba esta formula: =INDICE('Acu Viajes'!Q$3:Q$58;MAX(INDICE(('Acu Viajes'!D$3:D$58=N17)*('Acu Viajes'!Q$3:Q$58<>"")*(FILA(A$3:A$58)-2);))) Saludos.
  11. Hola, lo que pretendes solo se puede hacer por codigo. Pega este codigo en la hoja del editor vba: Public cr Public Sub Worksheet_Change(ByVal Target As Range) If Target.Column = 5 And Target.Value = 0 Then Range("J" & Target.Row) = cr End If End Sub Public Sub Worksheet_SelectionChange(ByVal Target As Range) cr = Target.Value End Sub Un saludo.
  12. Hola. Prueba esta formula: =SI(CONTAR.SI($D31:D31;D31)>1;JERARQUIA(D31;$D31:$AE31)+CONTAR.SI($D31:D31;D31)-1;JERARQUIA(D31;$D31:$AE31)) Un saludo.
  13. Hola. Sube tu archivo para poder verlo y ofrecerte una solucion. Saludos.
  14. Hola. Asi de cabeza y sin probar porque no tengo referencias de tu libro, prueba esto: =SI(SI.ERROR(BUSCARV(K4;'[SISTEMA.xlsm]REGISTRAR PRODUCTOS'!$A$1:$G$800;6;0);"")=SI.ERROR(BUSCARV(K4;'[SISTEMA.xlsm]REGISTRAR PRODUCTOS'!$A$1:$G$800;5;0);"");"";SI(SI.ERROR(BUSCARV(K4;'[SISTEMA.xlsm]REGISTRAR PRODUCTOS'!$A$1:$G$800;6;0);"")<SI.ERROR(BUSCARV(K4;'[SISTEMA.xlsm]REGISTRAR PRODUCTOS'!$A$1:$G$800;5;0);"");"BAJA";"SUBE")) Un saludo.
  15. Hola. Prueba asi: ActiveSheet.Range("$C$10:$J$19").AutoFilter Field:=2, Criteria1:="*" & Range("G8") & "*", Operator:=xlAnd Saludos.
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png