Jump to content

Toldeman

Moderators
  • Content Count

    3,369
  • Joined

  • Last visited

  • Days Won

    17

1 Follower

About Toldeman

  • Rank
    Juan

Contact Methods

  • Website URL Array

Profile information

  • Gender Array

Converted

  • Campos Array

Recent Profile Visitors

1,435 profile views
  1. Hola. Sube un pequeño ejemplo de lo que quieres hacer, y en base al archivo podremos trabajar tu consulta. Un saludo.
  2. Hola. Prueba poniendo este codigo en el evento change de la hoja. Private Sub Worksheet_Change(ByVal Target As Range) If Target.Offset(0, -1).Value = Target.Value Then Target.Interior.ColorIndex = 45 If WorksheetFunction.Sum(Target.Value - Target.Offset(0, -1).Value) = -1000 Then Target.Interior.ColorIndex = 3 End Sub Saludos.
  3. Hola. Prueba este codigo. Lo manda de forma individual, solo ajustalo a tus necesidades. For i = 7 To Range("A" & Rows.Count).End(xlUp).Row Set dam = CreateObject("outlook.application").CreateItem(0) dam.To = Range("A" & i).Value 'Destinatarios dam.Subject = "tuasunto" dam.body = Range("B" & i).Value '"Cuerpo del mensaje dam.send 'El correo se envía en automático 'dam.Display 'El correo se muestra Next Saludos.
  4. Hola. Sube un archivo, con un pequeño ejemplo de lo que quieres hacer. Un saludo.
  5. Hola. Ya lo solucione. Tenia que declarar la variable correo. Dim Correo As Outlook.MailItem Gracias.
  6. Hola Abraham. Gracias por responder. El lunes que vuelvo al trabajo lo pruebo y te comento. De nuevo muchas gracias.
  7. Buenos dias, hace tiempo el gran Antoni me ayudo con un codigo para enviar un email eligiendo la cuenta de envio. Este codigo en un libro de excel que tengo funciona perfecto. Ahora he querido trasladarlo a una base de datos hecha en access pero me da un error, le estoy dando mil vueltas pero no logro entender porque se para en la linea donde debe poner la cuenta de envio. Adjunto una captura.
  8. Hola. No lo tengo muy claro, pero prueba este codigo. Sub encontrar() Dim rng As Range Dim ult As Long ult = Hoja1.Range("B2:B" & Rows.Count).End(xlDown).Row Set rng = Hoja1.Range("B2:B" & ult) For Each cel In rng If cel = "Completar con Documento UUID" Then MsgBox "Ingresar Documento UUID" Next End Sub Saludos.
  9. Cambia la linea de la variable ult por esta ult = Range("A2:A" & Rows.Count).End(xlDown).Row Saludos
  10. Es verdad antoni, estoy muy liado con mi trabajo y cuando entro casi todos los post estan contestados por lo que no participo mucho. Pero de mis grandes amigos me sigo acordando. Un abrazo muy fuerte.
  11. Hola revisa el adjunto. Lo que pretendes solo se puede hacer con vba. Un saludo. Cambia color Texto de imagenes.xlsm
  12. Hola. Prueba esta formula: =BUSCARV(Producto1;Tabla2[[Producto]:[Precio compra]];4;0) Saludos.
  13. Hola, prueba esta formula arrastrandola hacia abajo. =CONTAR.SI(A$1:A1;A1) Saludos.
  14. Hola a todos. Prueba este codigo: Sub enviar() Dim objout, mapi, mail Set objout = CreateObject("outlook.application") Set mapi = objout.getnamespace("mapi") Set mail = objout.createitem(0) With mail .To = "tucorreo" .Subject = "Copia datos toldo" .body = "Este es el texto del mail" .attachments.Add ActiveWorkbook.FullName .send End With MsgBox "enviado email satisfactoriamente" End Sub Un saludo.
×
×
  • Create New...

Important Information

Privacy Policy