Saltar al contenido

Toldeman

Miembros
  • Contador de contenido

    3352
  • Unido

  • Última visita

  • Days Won

    17

2Seguidores

Sobre Toldeman

  • Rango
    Juan

Formas de contacto

  • Web http://www.toldospino.es/

Información de perfil

  • Sexo

Configuraciones

  • Campo que utilizas como separador de argumentos ;

Visitantes recientes del perfil

796 visitas de perfil
  1. Toldeman

    SUMAR 2 O MAS CIRTERIOS

    Hola. Prueba asi: =SUMAR.SI(A2:A40;"<>"&"Pendiente";B2:B40) Saludos.
  2. Toldeman

    Buscar celdas con texto y copiar segun orden de aparición

    Hola a los dos, por meter un poco la cuchara y si no tienes la funcion agregar como es mi caso, aprovecho el ejemplo que subio silva para dar mi pequeño aporte. =SI.ERROR(INDICE($K$2:$R$2;K.ESIMO.MENOR(INDICE(($K3:$R3<>"")*(COLUMNA($K$3:$R$3))-10;);CONTAR.BLANCO($K3:$R3)+COLUMNA(A1)));"") Un saludo.
  3. Hola. Sin un ejemplo es dificil aclopar un codigo a lo que pretendes hacer. Si te sirve de orientacion he asignado a una variable, una funcion que te extrae la informacion que requieres, unicamente seria implantarla a los rangos de tu hoja mediante algun bucle u otro tipo de control. x = InStr(Range("A1"), "/") r = Val(Mid(Range("A1"), 2, x - 2)) Saludos.
  4. Hola. Prueba esta macro que esta adaptada para valores en la columna A, seria cuestion de adaptarla a tu rango. Sub eliminarfilas() Dim x As Long x = Range("A" & Rows.Count).End(xlUp).Row For i = x To 1 Step -1 If Cells(i, 1) = 1 Then Cells(i, 1).Offset(-1, 0).EntireRow.Delete: i = i - 1 Next End Sub Saludos.
  5. Toldeman

    Suma condicional

    Hola. Sube un ejemplo de lo que quieres y de paso revisa las normas del foro para proximas consultas. Un saludo.
  6. Hola. Prueba asi cuando escribes en el rango B2:B160 Private Sub Worksheet_Change(ByVal Target As Range) If Not Intersect(Target, Range("B2:B160")) Is Nothing Then For Each cel In Range("B2:B160") If LCase(Target) Like "*por tanto*" Then Target.Interior.Color = vbRed Else Target.Interior.Color = xlNone End If Next End If End Sub Y si quieres cambiar todos los textos prueba esta macro: Sub cambiarcolor() Dim cel As Range For Each cel In Range("B2:B160") If LCase(cel) Like "*por tanto*" Then cel.Interior.Color = vbRed End If Next End Sub Saludos.
  7. Hola. No me entere de nada, mi pregunta es?.. sabes algo sobre excel o solamente quieres que te hagan un programa a tu medida. Perdona que sea brusco, pero aqui estamos para ayudar sobre problemas puntuales que surgan al INTENTAR elaborar algo. Un saludo.
  8. Hola. Revisa el adjunto. Saludos. Copia de horarios y precios.xlsx
  9. Toldeman

    Jerarquia en varios criterios.

    Hola. Prueba esta formula: =K.ESIMO.MAYOR(INDICE(--(A2:A19=A2););CONTAR.SI(A2:A2;A2))-1 + CONTAR.SI(A$2:A2;A2) Saludos.
  10. Toldeman

    formulas

    leyendo las normas del foro y subiendo un pequeño ejemplo de lo que necesitas. Saludos.
  11. Toldeman

    Orden de compra

    Hola. Sube un pequeño ejemplo de lo que tienes hecho y quieres hacer. Saludos.
  12. Toldeman

    Bucle con on error

    Hola. Prueba con Error Resumen Next Saludos.
  13. Toldeman

    Selección en Tabla

    Me parece que es un problema de permisos de administracion del foro. Saludos.
  14. Toldeman

    Combobox condicionado

    Hola. Prueba asi: Private Sub UserForm_Activate() Dim i As Integer Dim hj As Long For i = 1 To Sheets.Count hj = InStr(1, Sheets(i).Name, "Base") If hj > 0 Then ComboBox1.AddItem Sheets(i).Name ComboBox1 = ActiveSheet.Name End If Next i For i = 1 To 15: ComboBox2.AddItem Hoja1.Cells(1, i): Next ComboBox2.ListIndex = 0 txt_Buscarr.SetFocus End Sub Un saludo a los dos.
  15. Toldeman

    bloquear imagenes en excell

    Hola. Selecciona la imagen, boton derecho, tamaño y propiedades, propiedades. tilda la opcion que mas te convenga. saludos.
×

Información importante

Echa un vistazo a nuestra política de cookies para ayudarte a tener una mejor experiencia de navegación. Puedes ajustar aquí la configuración. Pulsa el botón Aceptar, si estás de acuerdo.