Saltar al contenido

Toldeman

Miembros
  • Contador de contenido

    3297
  • Unido

  • Última visita

  • Days Won

    16

1Seguidor

Sobre Toldeman

  • Rango
    juan

Formas de contacto

  • Web http://www.toldospino.es/

Información de perfil

  • Sexo

Configuraciones

  • Campo que utilizas como separador de argumentos ;

Visitantes recientes del perfil

370 visitas de perfil
  1. #¡valor!, quiero quitarlo

    Hola. Para versiones superiores a excel 2003. =SI.ERROR(JERARQUIA.EQV(AM3;$AM$3:$AM$47;0);"") Anteriores =SI(ESERROR(JERARQUIA.EQV(AM3;$AM$3:$AM$47;0));"";JERARQUIA.EQV(AM3;$AM$3:$AM$47;0)) Saludos.
  2. Consulta entre 2 fechas.

    Hola. Asi se soluciona. Sub consultafechas() Dim fechainicial As Date Dim fechafinal As Date Range("G1:H1") = "FECHA" fechainicial = InputBox("fecha inicial") fechafinal = InputBox("fechafinal") Range("G2").FormulaR1C1 = "<=" & CLng(fechafinal) Range("H2").FormulaR1C1 = ">=" & CLng(fechainicial) Sheets("ventas").Range("A4:I10000").AdvancedFilter Action:=xlFilterCopy, _ CriteriaRange:=Range("G1:h2"), CopyToRange:=Range("A9:I9"), Unique:=False Range("A7:I7").Select Selection.ClearContents Range("G1:H2").ClearContents Exit Sub err: MsgBox "formato incorrecto" Exit Sub End Sub Saludos.
  3. Consulta entre 2 fechas.

    Hola. Sub BUSQUEDA_PAQUITO() Dim rng As Range Sheets("compras").Range("A4:I10000").AdvancedFilter Action:=xlFilterCopy, _ CriteriaRange:=Range("A6:I7"), CopyToRange:=Range("A9:I9"), Unique:=False Range("A7:I7").Select Selection.ClearContents Range("A10").Select Set rng = ActiveCell.CurrentRegion rng.Interior.Color = vbYellow End Sub Sub BUSQUEDA_PAQUITO() Dim rng As Range Sheets("ventas").Range("A4:I10000").AdvancedFilter Action:=xlFilterCopy, _ CriteriaRange:=Range("A6:I7"), CopyToRange:=Range("A9:I9"), Unique:=False Range("A7:I7").Select Selection.ClearContents Range("A10").Select Set rng = ActiveCell.CurrentRegion rng.Interior.Color = vbRed End Sub Saludos.
  4. Consulta entre 2 fechas.

    Hola. Por partes. Te da error porque te falta esta linea de codigo: On Error GoTo err Vuelve a copiar el codigo ultimo que te mande y pruebas otra vez. Tu segunda pregunta ahora cuando pueda la reviso con calma. Saludos.
  5. Consulta entre 2 fechas.

    Hola. Yo lo pruebo y no me aparece el error que comentas. Sube de nuevo el archivo e indica desde donde lanzas la macro, para probar. Saludos.
  6. Consulta entre 2 fechas.

    Hola. Prueba asi: Sub consultafechas() Dim fechainicial As Date Dim fechafinal As Date On Error GoTo err Range("G1:H1") = "FECHA" fechainicial = InputBox("fecha inicial") fechafinal = InputBox("fechafinal") Range("G2").FormulaR1C1 = "<=" & CLng(fechafinal) Range("H2").FormulaR1C1 = ">=" & CLng(fechainicial) Sheets("ventas").Range("A4:I10000").AdvancedFilter Action:=xlFilterCopy, _ CriteriaRange:=Range("G1:h2"), CopyToRange:=Range("A9:I9"), Unique:=False Range("A7:I7").Select Selection.ClearContents Range("G1:H2").ClearContents err: MsgBox "formato incorrecto" Exit Sub End Sub Saludos.
  7. Complemento para programar con VBA

    Hola juan. Aqui en la pagina hay un complemento interesante. https://ayudaexcel.com/complementos-de-excel/ Saludos.
  8. CONDICIONAL

    Hola. No se si entendi muy bien lo que planteas, por el resultado que has puesto manual que no logro entender. De todas maneras prueba asi: =SI(Y(CONTAR.SI(D$6:D$8;D6)=1;CONTAR.SI(E6;"N")=1);1;0) Saludos.
  9. Consulta entre 2 fechas.

    Hola. Prueba esta macro. Sub consultafechas() Dim fechainicial As Date Dim fechafinal As Date Range("G1:H1") = "FECHA" fechainicial = InputBox("fecha inicial") fechafinal = InputBox("fechafinal") Range("G2").FormulaR1C1 = "<=" & CLng(fechafinal) Range("H2").FormulaR1C1 = ">=" & CLng(fechainicial) Sheets("ventas").Range("A4:I10000").AdvancedFilter Action:=xlFilterCopy, _ CriteriaRange:=Range("G1:h2"), CopyToRange:=Range("A9:I9"), Unique:=False Range("A7:I7").Select Selection.ClearContents Range("G1:H2").ClearContents End Sub Saludos.
  10. ***MOSTRAR RESULTADO EN UN COMENTARIO***

    Hola a todos. Prueba esta macro Sub comentarios() Dim rng As Range Dim cel As Range Dim ig As String Dim codigo As Variant Dim juan(5) As Variant Set rng = Range("D3:D9") ig = Range("G3") Range("G4").Comment.Delete For Each cel In rng If cel = ig Then x = x + 1 r = cel.Offset(0, -3).Address codigo = cel.Offset(0, -3) producto = cel.Offset(0, -2) precio = cel.Offset(0, -1) juan(x) = codigo & "-" & producto & "-" & precio End If Next Range("G4").AddComment Range("G4").Comment.Visible = True Range("G4").Comment.Text Text:="tu nombre:" & Chr(10) & juan(1) & Chr(10) & juan(2) & Chr(10) & juan(3) & Chr(10) & juan(4) End Sub Saludos.
  11. Consulta entre 2 fechas.

    Hola. Si subes un pequeño ejemplo no tendras problemas, luego es adaptarlo a tu libro original.
  12. Consulta entre 2 fechas.

    Hola. Sube un pequeño ejemplo de como tienes estructurado tu libro y de forma manual escribe los resultados esperados. Por favor postea en el foro adecuado. Muevo el tema al lugar correspondiente. Saludos.
  13. Reporte usando Jerarquías

    Hola. Utiliza el valor del campo $ como argumento en funciones de busqueda, como por ejemplo buscarv. Un saludo a todos.
  14. Reporte usando Jerarquías

    Hola. Prueba asi: =K.ESIMO.MAYOR(INDICE((Data!D$2:D$7="E")*Data!$E$2:$E$7;);A5) Un saludo.
  15. FORMULA

    Hola. Prueba asi: =SI('Datos Originales'!I18='Deriva Patron'!B2;'Deriva Patron'!D31;"") Saludos.
×