Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 04/28/2016 in Posts

  1. 1 point
    Gerson Pineda

    FORMULA CONSULTAV

    Hola @smiory Sube un archivo Excel con datos ficticios pero usa el cargador del foro, de esta forma recibirás la ayuda precisa de parte de @Silvia u otros miembros que deseen colaborar contigo Eso si tienes que ser mas que explicit@ cuando subas el nuevo archivo Saludos
  2. 1 point
    johnmpl

    FILTRAR VALORES DE MATRIZ CON FORMULA

    ¡Hola a todos! Revisa el adjunto, donde con fórmula propongo otra opción. La ventaja de esta fórmula es que independientemente del rango, la fórmula funciona. (rg : rango nombrado) Nota: dejar K1 vacía. ¡Bendiciones! Filtrar_Países.xlsx
  3. 1 point
    Antoni

    Hacer un If

    If IsDate(TextBox19) Then ActiveCell.Offset(0, 20) = CDate(TextBox19)
  4. 1 point
    Saludos a ambos @Diego2015 tambien puedes obtenerlo mediante macro Adjunto el archivo Paises Unicos.rar
  5. 1 point
    No he podido probar porqué el archivo origen me da error de lectura, ya que no puede abrir archivos .xls 64 bits. Si no se soluciona con lo siguiente, vuélvelo a subir como xlsx. De todas formas creo que los tiros van por aquí: Sustituye: FilaOtroLibro = HojaOrigen.Range("A" & Cells.Rows.Count).End(xlUp).Row '<<<<<-------AQUI EL ERROR <<<<<<<<<<<<<< Por: FilaOtroLibro = HojaOrigen.Range("A" & Rows.Count).End(xlUp).Row
  6. 1 point
    Buenas y si lo que deseas es que sea de todas las columnas coloca en la celda J3 la siguiente formula =SI.ERROR(INDICE(A$2:A$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;A$2:A$12)=0)*1;0);0));SI.ERROR(INDICE(B$2:B$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;B$2:B$12)=0)*1;0);0));SI.ERROR(INDICE(C$2:C$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;C$2:C$12)=0)*1;0);0));SI.ERROR(INDICE(D$2:D$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;D$2:D$12)=0)*1;0);0));SI.ERROR(INDICE(E$2:E$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;E$2:E$12)=0)*1;0);0));SI.ERROR(INDICE(F$2:F$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;F$2:F$12)=0)*1;0);0));SI.ERROR(INDICE(G$2:G$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;G$2:G$12)=0)*1;0);0));SI.ERROR(INDICE(H$2:H$12;COINCIDIR(1;INDICE((CONTAR.SI(J$2:J2;H$2:H$12)=0)*1;0);0));"")))))))) y luego copia y pega en el resto de celdas Un saludo
  7. 1 point
    Buenas coloca en la celda J2 la siguiente formula =SI.ERROR(INDICE(A$2:A$12;COINCIDIR(1;INDICE((CONTAR.SI(J$1:J1;A$2:A$12)=0)*1;0);0));"") Luego copia y pega en el resto de celdas de la columna J Espero que te sea de utilidad
  8. 1 point
    Buenas en el siguiente enlace Configurar Formulario y libros posees ejemplos para ocultar libro sin ocultar el resto de libros y en el siguiente Video Configurar Formulario y Libro Un saludo
  9. 1 point
    Prueba a ver si es esto. Fíjate que no es necesario activar ni libros, ni hojas, ni rangos para copiar y pegar. Sub ImportING() Dim PrimeraFila As Integer, UltimaFila As Integer, FilaOtroLibro As Integer Dim NumCuentaOrigen As String, NumCuentaDestino As String, Entidad As String Dim HojaOrigen As Worksheet Dim Parámetros As Worksheet Dim HojaDestino As Worksheet 'Asignamos valores a las variables Set HojaDestino = Workbooks(1).ActiveSheet Set Parámetros = Workbooks(1).Sheets("Parámetros") Set HojaOrigen = Workbooks(2).ActiveSheet 'Verificamos si el libro es correcto Application.ScreenUpdating = False NumCuentaDestino = Parámetros.Range("C2").Value NumCuentaOrigen = HojaOrigen.Range("B1").Value '<<<--Aquí entra sin problemas If NumCuentaDestino <> NumCuentaOrigen Then MsgBox "EL LIBRO ABIERTO NO ES DE ING", vbExclamation, "IMPORTACIÓN DATOS" Else 'Verifica última fila con datos de esta hoja UltimaFila = 1 + HojaDestino.Range("A" & Rows.Count).End(xlUp).Row 'Copia y pega fechas FilaOtroLibro = HojaOrigen.Range("A" & Cells.Rows.Count).End(xlUp).Row HojaOrigen.Range("A5:A" & FilaOtroLibro).Copy HojaDestino.Range("A" & UltimaFila).PasteSpecial xlPasteValues 'Copia y pega Descripción HojaOrigen.Range("D5:D" & FilaOtroLibro).Copy HojaDestino.Range("C" & UltimaFila).PasteSpecial xlPasteValues 'Copia y pega Importe HojaOrigen.Range("I5:I" & FilaOtroLibro).Copy HojaDestino.Range("D" & UltimaFila).PasteSpecial xlPasteValues 'Añade Entidad en columna E PrimeraFila = UltimaFila UltimaFila = HojaDestino.Range("A" & Rows.Count).End(xlUp).Row Entidad = Parámetros.Range("B2").Value For x = PrimeraFila To UltimaFila HojaDestino.Cells(x, 5) = Entidad Next x 'Autoajuste filas HojaDestino.Range(Cells(PrimeraFila, 3), Cells(UltimaFila, 3)).WrapText = True 'Importes a positivos HojaDestino.Cells(3, 4).Select Call NegativoPositivo End If Application.ScreenUpdating = True Application.CutCopyMode = False HojaDestino.Cells(4, 1).Select End Sub
  10. 1 point
    Que tal German es un gusto poder saludarte nuevamente! @nemodigital agrego mas enlaces de aportes, seguro te van a servir y aprenderas Saludos
  11. 1 point
    bfelix

    Bloquear celdas para no modificar texto

    Hola RIGOR, todas las celdas de tu hoja, por defecto, están bloqueadas y al proteger la hoja (pestaña de la cinta "Revisar") significa que no puedes alterar ninguna celda. Si son pocas las celdas que han de quedar desprotegidas las seleccionas y botón derecho "Formato de celdas" y en la pestaña "Proteger" desmarcas "Bloqueada". Estas celdas serán las únicas que podrá manipular tu amigo. Proteges la hoja y en las opciones que te da marcas todo (o lo que creas conveniente) menos "Seleccionar celdas bloqueadas". Con el libro protegido el usuario de tu hoja NO podrá situarse en ninguna de las celdas que están bloqueadas. Si se trata de que sólo hay unas pocas celdas a bloquear la operación es: Seleccionar la hoja (arriba a la izquierda, en el ángulo entre el 1 y la A y con el botón derecho "Formato de celdas" y en la pestaña "Proteger" desmarcas "Bloqueada" Ahora está justo al revés de la hoja "normal". Seleccionas las celdas que han de estar bloqueadas y con "Formato de celdas" las bloqueas. Al proteger la hoja serán esa pocas celdas las que no se puedan modificar. Saludos, bfelix editado>>> Hay una herramienta, a modo de pincel, que se puede añadir a la "Barra de herramientas de acceso rápido" para facilitar (?) esta tarea.


  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png