Jump to content

Ordenar listado por grupos


Recommended Posts

Buenas tardes,

Estoy haciendo un listado similar al que muestro a continuación pero con muchos más datos.

 

Me gustaría ordenar a los clientes que han pagado:

- primero los de Sevilla,

- después los de Albacete y

- a continuación indistintamente el resto (mejor si el 5 está antes que el  y el 10).

Estoy usando la siguiente formula, pero no sé como  encontrar a los clientes no incluidos anteriormente y que cumplen la condición. 

¿Alguna sugerencia por favor?

=IFERROR(INDEX($C$5:$C$39,AGGREGATE(15,6,ROW($C$5:$C$39)-4/($E$5:$E$39=1)/($D$5:$D$39="Sevilla"),ROWS(A$1:$A5))),IFERROR(INDEX($C$5:$C$39,AGGREGATE(15,6,ROW($C$5:$C$39)-4/($E$5:$E$39=1)/($D$5:$D$39="Albacete"),ROWS(A$1:OFFSET(A9,-ROW(A9)+1+COUNTIF($H$4:H8,"Albacete"),0)))),""))

Gracias de antemano.

image.thumb.png.8429f9b28eedc6cba06cbbdb04b260f2.png

Orden listado.xlsx

Link to comment
Share on other sites

Hola,

añade una columna a la lista y pon esta formula: =+SI(E5=1;1;2) & SI(D5="Sevilla";"01";SI(D5="Albacete";"02";TEXTO(C5+1;"00")))

después ordena la lista por la columna Orden

image.thumb.png.10b1838ca9c9ebde80676f5189dcd48a.png

 

Saludos

 

Link to comment
Share on other sites

Ahora mismo, javierc dijo:

¿Alguna otra idea por favor?

También puedes ordenar por "Lista personalizada" desde la opcion Ordenar

Si tienes dudas de como hacerlo, avisas

 

Saludos 

Link to comment
Share on other sites

Gracias.

 

Me gustaria que fuera automatico. 

En la realidad, la primera tabla está en una hoja con todos los datos. La segunda tabla está en otra hoja, y es la limpia. Quiero tener la formula arrastrada y que se automatice sola, sin necesidad de modificarla. 

Por eso quiero saber si conoceis alguna formula. 

 

Un saludo

Link to comment
Share on other sites

Gracias Gerson. 

 

Me ha dado un error.

Por otra parte, los usuarios de este archivo se van a liar con la VBA. 

Compartiré cualquier idea que se me ocurra.

 

Un saludo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Privacy Policy