Jump to content

Formula en columna de "cálculo automático"


gogua

Recommended Posts

Hola , 

A ver si soy capaz de explicarme. 

Estoy intentando hacer un inventario "sencillo" para la gestión de EPIs y Vestuario Laboral de mi empresa.Más o menos tengo lo que necesito aunque poco a poco iré añadiendo cosas

Una libro excel con 2 hojas (ARTICULOS  , ENTRADAS Y SALIDAS).

En ARTICULOS introduzco los productos con un codigo maestro y me sirve para ver el stock actual de todos los productos.

En ENTRADAS Y SALIDAS voy introduciendo los articulos utilizando el CODIGO de forma manual o utilizando la "lupa" que hay encima de la columna Ent./Sal. En la columna Existencia actual lo que pretendo es ven en cada momento , haya entrada o salida de artículo, como estába el inventario en ese momento (fecha). Para ello utilizo la formula. 

=SUMAR.SI.CONJUNTO($J$7:J7;$C$7:C7;[@CODIGO])

y este código se replica en toda la columna de forma automática.

 

image.thumb.png.0396d8b45aee379a8ea5978e285a0810.png

Pero me ocurre, que cuando inserto un nuevo registro, ya sea manual o con la lupa, esa formula me la cambia y me hace el sumatorio de toda la columna  para el CODIGO en concreto en la posición-fila anterior y ya no me va haciendo lo que pretendo, sino que me hace el inventario total.

 

image.thumb.png.f7922750eff031c17ead0d804a3f57fd.png

 

Os dejo el fichero, que quizás se pueda ver mejor lo que quiero explicar y su funcionamiento.

 

gracias

 

 

Inventario_01 - copia.xlsm

Edited by gogua
Link to comment
Share on other sites

¡Hola, @gogua!

El tema de los rangos expandibles en tabla tienen un comportamiento "peculiar" cuando llegan al final de la misma.  Entonces, una opción para trabajar con ellos es "jugar" con las referencias estructuradas.  Tu fórmula, al tener un solo criterio, puede usarse con la función SUMAR.SI de la siguiente forma:

=SUMAR.SI(C$7:[@CODIGO];[@CODIGO];J$7:[@[Ent./Sal.]])

¡Pruébala y comentas! ¡Bendiciones!

Link to comment
Share on other sites

Hace 17 minutos , gogua dijo:

@John Jairo V @Gerson Pineda

Gracias a los 2 por la respuesta, cada día me sorprendo más de lo poco que se de excel, la verdad.

Aunque sigo sin entender el comportamiento erratico de mi "formula" 😭

 

gracias 

El resultado no es errático, solo que depende del resultado que buscas

Las tablas, hacen referencias al rango completo de la misma, aquí ya no existe referencias relativas nativamente, por lo tanto la función lo toma como tal

Pero afortunadamente siempre encontraremos métodos y formas de resolver problemas en Excel

Algo mas, el formato tabla tiene mas ventajas respecto a rangos normales, comenzando pe: con el rango dinámico de sus filas 

 

Saludos 

Link to comment
Share on other sites

  • Crear macros Excel

  • Posts

    • Buenas noches a todos. Se lo que le voy a pedir, para ustedes es algo fácil en la cual para mi es algo difícil.  espero su gran ayuda. https://postimg.cc/1nnXDN5W   IMG del Proyecto esto es solo en suma y resta. El esquema es el siguiente: 1 Cartas  ----- dará  -1     -------  ejem: vemos arriba  "3 Energía" " 6 Cartas "  presionamos "1 Cartas" -- daría "2 Energía" "5 Cartas"  que se pueda jugar con los botones cuando agregan cartas, si tal caso da "0" que salga mensaje "No tiene mas energía"  Cuando presiones el el botón " Pasa Turno " dará la siguiente suma  "dará +2 Energía  +3 Carta" El botón  " + Energía " solo dará " +1 Energía "  Botón "Carta En 0 "  solo sumara +1 Energía"     Se que es fácil pero no se hacerlo.   Espero su gran ayuda.   Donde dice "       Archivo VBA
    • Hola Eso que me dices para mi ya es ciencia ficción. De momento para lo que necesito con esto ya tengo bastante. Cuando aprenda un poco ya ire intentando cosas mas complicadas. No te creas que comprender las macros que me habeis ayudado tu, Antoni y Gerson Pineda, me esta costando lo suyo. De momento mis conocimientos son muy basicos y tengo que estar constantemente mirando manuales y aun asi me cuesta.   Saludos
    • Primero dale forma a lo que quieres medir, evaluar, gestionar, etc. Con esto ya tendras un punto de partida Posteriormente, como lo quieres medir y por último como quieres ver los resultados con toda la información que acumularás. Espero te de una luz. Saludos.
    • Observo que el cuerpo de las preguntas no corresponde al cuerpo de la información obtenida. Te lo comento porque se podría obtener el resultado de la encuesta por cada pregunta, tiempos de respuetsa, opinion segmentado por sexo,etc.
    • Hola Por favor, quisiera su ayuda, guias, conocimiento ..ect..ect.. Quiero hacer un archivo en excel donde lleve una estadistica de beisbol donde lleve las posiciones de los equios de acuerdo a los resultados de los juegos entre ellos y que automaticamente me actualice las posiciones de cada uno de ellos en una tabla de posiciones general. Como comienzo?,,,,formulas a usar….etc..etc..etc.. muchas gracias
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy