Jump to content

Calcular un porcentaje si se cumplen condiciones


Guada

Recommended Posts

Estoy tratando de hacer un calculo que no me sale

Necesito que el valor ingreso, se calcule de acuerdo al parámetro Estado
y que en función del Estado, si se cumple la condición de C, entonces, se multiplique por el porcentaje correspondiente
y el resultado vaya en I4.-

Quiero poder combinar estas formulas, pero no me sale

BUSCARV(G5;A1:D7;1)
SI.ERROR(BUSCARV($H$5;$C$1:$D$7;2;1);"")

H51*I5

adjunto el excel de ejemplo para ver si me pueden orientar

Busqué sobre Si, con condiciones usando Y -. pero no me sale el proceso

gracias

 

 

Ejemplo.xlsx

Link to comment
Share on other sites

Buenos días,

Si, justamente esto es lo que buscaba.-

PREGUNTA

Le quise agregar 2 buscarv mas, y me dice que tiene demasiados argumentos, 

=SI(G6=1;BUSCARV(H6;C4:D8;2;1);BUSCARV(H6;C9:D12;2;1);BUSCARV(H6;C13:D16;2;1);BUSCARV(H6;C17:D120;2;1))*H6

Tendría que combinarlo con otra función para que funcione? porque probé con Y / O  pero no me lo toma-.

 

Gracias por tu ayuda

Link to comment
Share on other sites

Pense que yo estaba bloqueado.

al parecer la pagina desde ayer es de paga.

Se agradece a la gente que ayudaba ,ojala salga otro foro con la misma comunidad amiga de este foro. ya eran conocidos la gente que ayudaba.

Estaba en todo excel pero mi contraseña no me acuerdo y el mail de confirmacion para cambiar de contraseña nunca me llega a mi correo xd xd xd . Mala suerte xd xd xd 

 

Link to comment
Share on other sites

  • Crear macros Excel

  • Posts

    • Buenos días, Tengo un problema con un archivo de excel al que quiero mediante un botón ocultar las columnas cuyas celdas estén vacías,  es un inventario de productos por almacen que muestra las cantidades del mismo de acuerdo al código de cada producto. Me oculta las columnas del rango que estoy usando sin tomar en cuenta si están vacías o no. En una archivo con menos datos lo he probado y si funciona. Adjunto el archivo para que lo miren. También tiene programado un buscador para que muestre solo la referencia del producto requerida, entonces la mecánica del archivo sería mostrar solo una referencia de producto y poder ocultar las columnas (almacenes) que no tengan ningún producto de dicha búsqueda realizada.   Gracias de antemano por su ayuda. master-retirar-beta.xls
    • @Alberto González, prueba el adjunto. Salu2, Pedro Wave   Cantidades Consumidas PW1.xlsx
    • Observaciones. Los meses deberas tenerlos en No. de mes (septiembre=9) En la Hoja "C1" encontraras un Boton "Genera" y ejecutara la macro, procesando "C1" y "C2" Espero te sirva. PRUEBA_CONSOLOCIDACION - Janlui.xlsm
    • Esa solución me ayudó bastante, muchas gracias, con eso ya pude solucionar el problema
    • Hola Con una tabla dinámica, seria mas eficiente Lo que hice fue pasar a formato tabla la hoja pedido y luego arme la TD Te lo dejo como solución    Saludos  PRUEBA_CONSOLOCIDACION.xlsm
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy