Jump to content

Recommended Posts

mmmmmm

otra Matricial// Control+Shift+Enter//

=SUMA(SUMAR.SI(D7:AH7,B27:F27,INDICE(D9:AH12,COINCIDIR(B28,A9:A12,),0)))

No Matricial:

=SUMAPRODUCTO(SUMAR.SI(D7:AH7,B27:F27,INDICE(D9:AH12,COINCIDIR(B28,A9:A12,),0)))

mi separador de argumentos es la coma (,) .

 

saludos..

Silvia

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Crear macros Excel

  • Posts

    • no se si esto funciona en mac (hace mucho que no lo uso) antes de mostrar el mensaje, agrega estas dos lineas: AppActivate Application.Caption DoEvents si no funciona, buscamos otras alternativas
    • Héctor, gracias por tu respuesta pero a pesar de cambiar a valor numérico pero aun me mantiene el problema mostrándome el mensaje detrás del formulario.    
    • Buenas noches Antoni primeramente déjame agradecerte por el tiempo que te has tomando en ayudarme con mi proyecto; el dódigo hace lo que esperaba, pero quiciera que al buscar un determinado lote poder teclear el lote primero y al aplastar en el botón donde está la lupa ahí recien se cargue el lote buscado en el formulario; ahorita lo que hace es si tecleo el número 1 del lote "14-0162" y si quiero teclear otro lote  que comience con el 1 me sale el mismo no me deja escribir un nuevo lote y se salta a casillero del código. Al aumentar muchos lotes unos 5000 por ejemplo es demoroso estar buscando en el combobox en el desplegable  el lote que necesito seria mejor que quede como antes que tecleaba el lote en el textbox de "Lote" y al dar click en botón de la lupa(Buscar item) recien aparezca o se carge en los casillero. Por favor es el único inconveniente que se me presentó por lo demás está muy bien. Gracias nuevamente por tu tiempo y espero contar con tu ayuda. Copia de ModificarPintandoFila-1.xlsb
    • Siguiendo con el hilo modifique el código anterior a:  Dim rngDV As Range Dim oldVal As String Dim newVal As String 'Ejecuta el código sólo si cambia una celda If Target.Count > 1 Then GoTo exitHandler Select Case Target.Column Case 7, 24 On Error Resume Next 'check the cell for data validation Set rngDV = Target.SpecialCells(xlCellTypeAllValidation) On Error GoTo exitHandler If rngDV Is Nothing Then GoTo exitHandler If Intersect(Target, rngDV) Is Nothing Then Else Application.EnableEvents = False newVal = Target.Value Application.Undo oldVal = Target.Value Target.Value = newVal If oldVal <> "" Then If newVal <> "" Then Target.Value = oldVal _ & "- " & newVal End If End If End If End Select exitHandler: Application.EnableEvents = True La razón fue que afecta otro código que esta inserto en el evento Private Sub Worksheet_Change. 
    • Buenas tardes tengan todos ustedes, sin encontrar una solución a mi problema hoy acudo a su apoyo. Tengo el siguiente código que me ayuda a seleccionar varios elementos de una lista desplegable: Private Sub Worksheet_Change(ByVal Target As Range) Dim I As Integer Dim xRgVal As Range Dim xStrNew As String Dim xStrOld As String Dim xFlag As Boolean Dim xArr Select Case Target.Column Case 7 On Error Resume Next Set xRgVal = Cells.SpecialCells(xlCellTypeAllValidation) If (Target.Count > 1) Or (xRgVal Is Nothing) Then Exit Sub If Intersect(Target, xRgVal) Is Nothing Then Exit Sub Application.EnableEvents = False xFlag = True xStrNew = " " & Target.Value & " " Application.Undo xStrOld = Target.Value If InStr(1, xStrOld, xStrNew) = 0 Then xStrNew = xStrNew & xStrOld & " " Else xStrNew = xStrOld End If End Select Target.Value = xStrNew Application.EnableEvents = True End Sub Sin embargo con el anterior código ya no me deja borrar datos de la celda donde esta la lista desplegable.  De antemano gracias por los consejos que podrían darme.     
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy