Jump to content

Seleccionar celda de valor encontrado


Go to solution Solved by tierra_pampa,

Recommended Posts

si tengo esta macro

Sub ejemplo()
    valor = 5
    NameO = "BaseX"
    
    Set Rng = Sheets(NameO).Range("A:A").Find(valor, LookAt:=xlWhole)
    
    Sheets(NameO).Rng.Select '<= asi no funciona y coloco separado Sheet(nameO).select y en otra fila Rng.select si lo hace.

End Sub

pero necesito tomar los vlaores de las filas sin necesidad de selecionar la hoja, como hago eso.

Como me posiciono en la celda del valor encontrado  y copio toda la fila a otra hoja

Link to post
Share on other sites

Saludos @Potter08, cuando haces esto

Set Rng = Sheets(NameO).Range("A:A").Find(valor, LookAt:=xlWhole)

y se consigue el valor buscado, ya Rng hace referencia a esa celda, incluyendo hoja y todo, es decir, tu pudieras hacer por ejemplo

Rng.Resize(1, 10).Copy

y con eso estas copiando desde la celda Rgn, hasta 10 columnas a la derecha

Suerte

Link to post
Share on other sites
Hace 1 hora, bigpetroman dijo:

Saludos @Potter08, cuando haces esto

Set Rng = Sheets(NameO).Range("A:A").Find(valor, LookAt:=xlWhole)

y se consigue el valor buscado, ya Rng hace referencia a esa celda, incluyendo hoja y todo, es decir, tu pudieras hacer por ejemplo

Rng.Resize(1, 10).Copy

y con eso estas copiando desde la celda Rgn, hasta 10 columnas a la derecha

Suerte

Excelente solucion es exacto lo que necesitaba, gracias.

Link to post
Share on other sites
Hace 1 hora, tierra_pampa dijo:

Hola @Potter08!

Perdón, pero no bajé el archivo cuando armé la prueba.

De todas maneras, lo comparto!

Fijate si cumple con lo que necesitas.

Suerte!
 

ae20200924_post44039_find.xlsm 18.57 kB · 1 descarga

Gracias muy buen aporte me servira para otro reporte que estoy en proceso, gracias

 

Salu2 a todos, pueden dar por cerrado el caso

JSDJSD gracias por tu interes en otra ocacion sera.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Crear macros Excel

  • Posts

    • Buenos días. Es mi primera intervención, y ya es para pedir ayuda.  Ver si puedo contar con vuestras experiencias.   Tengo una tabla, en una columna días, y en la otro la puntualidad de ese día en concreto en "%"   Ya he calculado en el total de año el nr de días que la puntualidad ha sido del 100%   Pero (y ahí es donde me he quedado atascado), necesitaría un contador que me dijera el número de días que llevamos con una puntualidad de los empleados del 100%   He encontrado este tema que me ha servido de algo de ayuda, pero o bien no se interpretarlo, o no es exactamente lo que busco.     Comunidad, anticipadamente, muchas gracias por vuestra ayuda. EJEMPLO 1.xlsx
    • Buenas a tod@s, Os adjunto un calendario al que quiero hacer lo siguiente: como veis tengo una celda que es la E22 en color rojo que usaré para los dias festivos. Justamente debajo incluiré los dias festivos (1 de enero, 6 de enero, etc) estos dias al incluirlo en el listado querria que cambiaran el color segun el relleno de la Celda E22. Tambien busco la forma de que si cambio el año estos dias se actualicen Luego tengo la celda I18 que tiene el color amarillo y querria que al incluir los dias del calendario me cambiaran al color de relleno de dicha celda. Es posible? 2021.xlsm
    • Después de varios años sin abrir una hoja de cálculo, me encuentro ante nuevos retos, espero poder aportar mis antiguos conociminentos y aprender de los vuestros.   Un Saludo. !!
    • ¡Hola a ambos! @YOUSAFJAMALD, para la próxima, sube un archivo Excel en vez de una imagen.  Nos ayuda mucho más a ayudarte. Ahora, en cuanto a tu problema y como bien te comenta @DiegoPC, efectivamente, con la función BUSCAR "solita", el problema no es posible realizarlo, pero con "ayuda" si que es posible. =BUSCAR(2;1/FRECUENCIA(0;1/(1+(K$37:K$43<=N37)*K$37:K$43));L$37:L$43) otra alternativa un poco más "digerible": =INDICE(L$37:L$43;COINCIDIR(MAX(INDICE(K$37:K$43*(K$37:K$43<=N37);));K$37:K$43;)) o también usar la función BUSCARX (solo disponible en Microsoft 365 / Excel 2021 / Excel Online 😞 =BUSCARX(N37:N63;K37:K43;L37:L43;"No Existe";-1) Analiza detenidamente las propuestas.  ¡Bendiciones!
    • Saludos espero me puedan ayudar, he intentado todo y no lo consigo. estoy tratando de descargar datos de una web la cual es "post" y posteriormente es "get" redirecciona a otra pagina, solo lo he logrado con el navegadro explorer pero el detalle que es muy tardado ya que son 170mil datos y con explorer es como si fuera navegando, abrir explorador, poner url, bucar las etiquetas donde se hace la cosulta y despues click en un boton, esperar a que cargue la pagina y extraer los datos de esa consulta.   me gustaria poderlo hacer mediante xmlhttp   anexo link de la pagina  https://serviciosfinanzas.villahermosa.gob.mx:8800/serviciosfinanzas/dp/busqueda-agua.html y mi codigo    Sub Web_Data()     Dim str_arg As String    Dim URL     str_arg = "xContrato=000001&Buscar=Buscar"     URL = "https://serviciosfinanzas.villahermosa.gob.mx:8800/serviciosfinanzas/dp/busqueda-agua.html" Set OBJHTTP = CreateObject("MSXML2.XMLHTTP")     With OBJHTTP              .Open "GET", URL, False         .setRequestHeader "User-Agent", "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.114 Safari/537.36"         .setRequestHeader "contenido-type", "text/html"         .setRequestHeader "contenido-type", "application/xhtml+xml"         .setRequestHeader "contenido-type", "application/x-www-form-urlencoded"                  .setRequestHeader "contenido-type", "application/javascript"         .send str_arg         TXT = .responseText         Debug.Print TXT              End With     [A1] = html.getElementsByTagName("td")(1).innerText 'valor a extraer numero de contrato, nombre y direccion End Sub
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy