Jump to content
Xanito

ANSWERED Jalar los números de pedidos de un mismo código

Recommended Posts

Buen día genios en Excel, aquí de nuevo solicitando su ayuda, tengo la matriz a buscar desde la columna A hasta la columna C,  entonces en la columna E tengo el código a buscar, lo que me gustaría lograr es que alguna fórmula jale todos los números de solicitud que aparecen en la común B a la columna F de los códigos repetidos que aparecen en la columna A; y asimismo en la misma forma que jale la fecha de siaf de la columna C a la columna G, intente usar la fórmula de índice y coincidir pero no me funciono no sé qué hice mal, me podrían ayudar por favor de antemano gracias.

Pedidos.xlsx

Share this post


Link to post
Share on other sites

Hola Xanito

Hace 4 horas, Xanito dijo:

intente usar la fórmula de índice y coincidir pero no me funciono no sé qué hice mal,

Con indice y coincidir, solo te traerá uno de los resultados, el primero que encuentre.

En esta fórmula

=SI.ERROR(B3&", "&INDICE(F3:F$49,COINCIDIR(A3:A$2037,)),B3)

Realmente no sé que has tratado de hacer..  Si fuera un solo resultado a buscar, solo sería:

con Indice traes el resultado de la columna que necesitas, me parece que es la B

con coincidir coincides el código del medicamento, con la columna A

en F3:  =SI.ERROR(INDICE($B$2:$B$2037,COINCIDIR(E3,$A$2:$A$2037,)),"")

pero en fin como te digo, eso solo te traería un solo resultado y tu deseas algo así como un concatenado ... y eso con ejemplos como este:  El código 448 se repite 79 veces 🤕 . 🙄

 

 Lo que necesitas, se resuelve muy bien con una macro.

Pero yo... :(   no te puedo ayudar con eso..

 

saludos,

Silvia

Share this post


Link to post
Share on other sites

Gracias por tu comentario Silvia, si así es el código 448 esta repetido varias veces y eso es lo que necesito que jale toda la información de cada código, estoy en espera tal vez habrá alguien que me ayude con eso, de antemano gracias.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Moderar y responder comentarios de usuarios. Recuerda que la información que facilites es pública, y los datos que incluyas los leerá cualquier visitante de esta web, así como el avatar que poseas.

Legitimación: Consentimiento del interesado.

Destinatarios: Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.




×
×
  • Create New...

Important Information

Privacy Policy