Jump to content

johnmpl

Moderators
  • Content Count

    3,443
  • Joined

  • Last visited

  • Days Won

    189

About johnmpl

  • Rank
    Advanced Member

Profile information

  • Gender Array
  • Localización: Array

Converted

  • Campos Array

Recent Profile Visitors

4,413 profile views
  1. ¡Hola, @alistair! Puedes usar la siguiente fórmula (en F3 y arrastrarla / copiarla donde la necesites hacia abajo y la derecha) : =BUSCARV($A3;CURVAH;COINCIDIR(F$1;INDICE(CURVAH;1;););) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. La ventaja de trabajar así, es que no tendrás que colocar manualmente la columna a traer, y esta fórmula te funcionará para todas las celdas de igual forma, dependiendo de la fecha que tengas en la fila 1. ¡Bendiciones!
  2. ¡Hola, @Xanito! Puedes usar la siguiente fórmula: =INDICE(C$2:C$4;COINCIDIR(E2&"*";INDICE(B$2:B$4&"";);)) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  3. Hola, @nico0601! Puedes usar la siguiente fórmula de introducción matricial (CSE): =CONTAR(1/FRECUENCIA(SI((C2:C5=1)*(D2:D5>=1);B2:B5);B2:B5)) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. Bendiciones!
  4. me puedes asesorar¡

  5. ¡Hola, de nuevo! Si encontraste el archivo, pero solo pesa 2 kb es que ya Windows - como Sistema Operativo - ha reemplazado una parte del cluster donde estaba almacenado el archivo con otra cosa... asi que... probablemente ya no lo puedas recuperar. ¡Bendiciones!
  6. ¡Hola, @julayala! Lo que comentas lo puedes solucionar con ayuda de la función BUSCARV en Excel, combinada con SI.ERROR. Para ver el funcionamiento de la función BUSCARV, puedes visitar el siguiente link (de la misma microsoft) : https://support.office.com/es-es/article/buscarv-función-buscarv-0bbc8083-26fe-4963-8ab8-93a18ad188a1 Revisa el archivo adjunto, donde aplico las funciones arriba expuestas. ¡Bendiciones! Ejemplo1.xlsx
  7. ¡Hola, de nuevo! En el archivo están 2 propuestas. La mía corregida (igual a la que te propuso @Leopoldo Blancas en el post anterior... podrías haberlo hecho tu en mi fórmula), y una propuesta con VBA (presionando en la flecha azul). ¡Comentas! ¡Bendiciones! Ejemplo.xlsb
  8. ¡Hola, a todos! Una opción que podría funcionarte es, agregar a lo que ya tienes, una condición adicional por si están los días. con lo que tienes, podría ser: =SI(O(B4="CONFIRMADO";B4="CANCELADO";E4="");"";SI(E4<=0;$K$6;SI(E4<=$K$5;$K$7;$K$8))) que, podría recortarse un poco a: =SI(O(B4={"CONFIRMADO";"CANCELADO"};E4="");"";SI(E4>K$5;K$8;SI(E4>0;K$7;K$6))) o, también: =SI(O(B4={"CONFIRMADO";"CANCELADO"};E4="");"";BUSCAR(E4;{-9E+307;1;6};K$6:K$8)) ¡Bendiciones!
  9. ¡Hola, @paikerr! Podrías usar un programa gratuito de recuperación de archivos llamado recuva. Dependiendo del tiempo que ha pasado y uso del computador donde lo borraste, tendrás éxito en recuperarlo. ¡Bendiciones!
  10. ¡Hola, a ambos! Otra opción puede ser: =EXTRAE(A2;2;MIN(HALLAR({".";"/";" "};EXTRAE(A2;2;99)&"./ "))-1) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  11. ¡Hola, a ambos! Opción formuliana: =SUMA(N(MMULT(N(CONTAR.SI(DESREF(B$3:G$3;FILA(B$3:B$10)-FILA(B$3););J3:L3)>0);{1;1;1})=3)) Revisa el adjunto. ¡Bendiciones! CONTAR COINCIDENCIAS FILAS FORO.xlsm
  12. ¡Hola, de nuevo! Efectivamente, no había leido lo de sumar la columna L... entonces, solo basta con agregar la condición al final en todas las fórmulas, y cambiar el contar.si.conjunto por el sumar.si.conjunto. =SUMA((D9:D199="PING")*(J9:J199="PLANA")*(L9:L199>0)*L9:L199) <-- CSE (Ctrl + Shift + Enter) =SUMAPRODUCTO((D9:D199="PING")*(J9:J199="PLANA")*(L9:L199>0)*L9:L199) =SUMAPRODUCTO(--(D9:D199="PING");--(J9:J199="PLANA");--(L9:L199>0);L9:L199) =SUMAR.SI.CONJUNTO(L9:L199;D9:D199;"PING";J9:J199;"Plana";L9:L199;">0") Nota: La de Sumar.si.conjunto ya te la mostró @GabrielRaigosa. ¡Bendiciones!
  13. ¡Hola, @lursaildi! En orden (de menos a más recomendada) : =SUMA((D9:D199="PING")*(J9:J199="PLANA")*(L9:L199>0)) <-- CSE (Ctrl + Shift + Enter) =SUMAPRODUCTO((D9:D199="PING")*(J9:J199="PLANA")*(L9:L199>0)) =SUMAPRODUCTO(--(D9:D199="PING");--(J9:J199="PLANA");--(L9:L199>0)) =CONTAR.SI.CONJUNTO(D9:D199;"PING";J9:J199;"Plana";L9:L199;">0") Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  14. Hola Sil! Se que no me preguntaste a mí... pero eso puede hacer agrupando manualmente en la TD... seleccionas los elementos, clic derecho, agrupar. Así continúas con los demás. Para los subtotales, haces clic derecho en el nuevo campo generado (grupo 1, grupo 2) y luego, muestras Subtotal. ¡Bendiciones!
  15. ¡Hola, a todos! Mientras @DiegoLG se manifiesta... dejo una posible opción. let Origen = Excel.CurrentWorkbook(){[Name="Tabla1"]}[Content], #"Tipo cambiado" = Table.TransformColumnTypes(Origen,{{"Clave", Int64.Type}, {"Factura", type text}, {"Importe", Int64.Type}}), #"Filas agrupadas" = Table.Group(#"Tipo cambiado", {"Clave"}, {{"Todo", each _, type table [Clave=number, Factura=text, Importe=number]}}), #"Personalizada agregada" = Table.AddColumn(#"Filas agrupadas", "Personalizado", each Table.AddIndexColumn([Todo], "Índice", 1, 1)), #"Columnas quitadas" = Table.RemoveColumns(#"Personalizada agregada",{"Todo"}), #"Se expandió Personalizado" = Table.ExpandTableColumn(#"Columnas quitadas", "Personalizado", {"Factura", "Importe", "Índice"}, {"Factura", "Importe", "Índice"}), #"División entera insertada" = Table.AddColumn(#"Se expandió Personalizado", "Grupo", each "Grupo " & Text.From(1 + Number.IntegerDivide([Índice] - 1, 6)), type text), #"Filas agrupadas1" = Table.Group(#"División entera insertada", {"Clave", "Grupo"}, {{"Todo", each List.Sum([Importe]), type number}}) in #"Filas agrupadas1" ¡Bendiciones! Libro9.xlsx
×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 5112 personas - Aprender Excel - Total: 4.7 / 5