Saltar al contenido

johnmpl

Moderadores
  • Contador de contenido

    3163
  • Unido

  • Última visita

  • Days Won

    163

Sobre johnmpl

  • Rango
    Miembro

Información de perfil

  • Sexo Hombre
  • Localización: Colombia, Excel 2016

Configuraciones

  • Campo que utilizas como separador de argumentos ;

Visitantes recientes del perfil

2599 visitas de perfil
  1. SUMAR.SI en FÓRMULAS MATRICIALES

    ¡Hola, a ambos! La razón por la cual no puedes usarla de la forma en que la planteas, es porque, por definición de la función, las dimensiones del rango del criterio y el rango de la suma deben ser iguales. Como el rango del criterio es 5 x 1 (5 Filas por 1 Columna), esas deben ser las dimensiones del rango a sumar (pero estás usando 5 x 3). Si quieres usarlo con SUMAR.SI, puedes ayudarte de otra función como DESREF y SUMA, así (introducción normal, no CSE): =SUMA(SUMAR.SI(Provincia;"Madrid";DESREF(Enero;;{0;1;2}))) El DESREF en este caso pasa a SUMAR.SI tres rangos 5 x 1, por lo que arma una matriz 3 x 1 con las sumas de cada mes. Con la función SUMA lo que haces es sumar esos 3 valores resultantes. Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema (Excepto, en este caso, en la constante matricial {0;1;2} el cual lo debes dejar con ";"). Nota2: Es mejor usar, para este caso, la propuesta de @Snake con SUMAPRODUCTO, ya que se evita la función volátil DESREF. ¡Bendiciones!
  2. ¡Hola, @Cristian RC! En estos tiempos he estado bastante ocupado, pero no me he olvidado de ti. En los ratos que he tenido libres he mirado tu archivo, y la verdad es que denotó un buen tiempo, no por lo complicado, sino por lo detallado en tu explicación. La verdad la esencia del foro no es resolver a pedido cosas del consultante, sino resolver dudas puntuales con respecto a los procesos que propone el consultante. Me he sentido contigo "inexplicablemente comprometido" a ayudarte, así que dejo una propuesta con respecto a lo que pediste. De todas formas, no estoy actualmente contando con mucho tiempo para ayudar (puedes ver que en estos tiempos muy poco entro al foro, y si entro, es para resolver dudas muy puntuales no tan frecuente como lo hacía anteriormente). Revísalo y comentas. ¡Bendiciones! Gráfica (2).xlsm
  3. busqueda de fechas extrema

    ¡Hola, @luchito11! Puedes usar: [A4]: =INDICE(D$1:FQ$1;COINCIDIR("x";D4:FQ4;)) [B4]: =A4+C4-1 Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  4. Como modificar formula

    ¡Hola, @lursaildi! Cambia tu fórmula por ésta: [E10]: =SI(Y(ESNUMERO(Hoja2!$L10);Hoja2!$L10>=1);SI.ERROR(BUSCARV("Jn3";Hoja2!$D10:$K10;1;);"");"") ¡Bendiciones!
  5. Duda con filtro

    ¡Hola, @hectorcalleja! ¡Bienvenido al foro! Para hacer lo que pides, puedes usar la herramienta Filtro Avanzado de Excel (Ficha Datos - Avanzadas). Revisa el archivo adjunto. ¡Bendiciones! Ejemplo BBDD Resultados ligafutbol1.uphero.com.xls
  6. contar color de fuente con condición

    ¡Hola, a ambos! Puedes usar esta función: Function CuentaCond&(CeldaColor As Range, Rango As Range, Condicion$) Dim Celda As Range, aux& For Each Celda In Rango If Celda.Font.Color = CeldaColor.Font.Color Then If Evaluate(Celda.Address & Condicion) Then aux = 1 + aux End If End If Next Celda CuentaCond = aux End Function y la puedes usar así, en Excel: =CuentaCond(A1;A1:A20;">0") Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  7. Dos tablas, una búsqueda y un criterio. :(

    ¡Hola, @ErickSiloe! (y @Cristian 1985) Puedes usar: [F8]: =INDICE('Tabla de cierre'!E$10:E$21;COINCIDIR(1;INDICE(('Tabla de cierre'!C$10:C$21=D8)*('Tabla de cierre'!D$10:D$21=E8););)) Y copias hacia abajo. Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  8. ¡Hola, a todos! Pues, en este caso, sin necesidad de Macros, podría ser como te lo muestro en el adjunto. ¡Bendiciones! Ejemplo (23).xlsx
  9. Hola, @Salvita! ¡[email protected] al foro! Ve al Editor de Visual Basic para Aplicaciones, crea un módulo y pega el siguiente código VBA: Sub ResetearNombresCamposTD() Dim wb As Workbook, ws As Worksheet Dim pt As PivotTable, pf As PivotField Application.ScreenUpdating = False Set wb = ActiveWorkbook For Each ws In wb.Worksheets For Each pt In ws.PivotTables pt.RowAxisLayout xlOutlineRow For Each pf In pt.PivotFields pf.Caption = pf.SourceName Next pf Next pt Next ws Set wb = Nothing: Set ws = Nothing Set pt = Nothing: Set pf = Nothing Application.ScreenUpdating = True End Sub Recuerda guardar el archivo habilitado para macros, para que esta macro se guarde junto con el archivo. Por si no sabes hacer el proceso anterior, te indico el paso a paso: Para ir al Editor de Visual Basic para Aplicaciones: --> En Excel presiona la combinación de teclas Alt + F11 Para crear un módulo en el Editor: --> Ve al menú Insertar - Módulo En el espacio blanco a la derecha, pegas el código. Para ejecutar el código: --> En Excel, presiona Alt + F8, busca la macro ResetearNombresCamposTD y la ejecutas. Para guardar el archivo habilitado para macros: --> Presiona la tecla F12, y en tipo escoges "Libro de Excel habilitado para macros" ¡Bendiciones!
  10. Atascado con archivo (tablas)

    ¡Hola, a todos! En el último archivo de @Cristian 1985, puedes usar: [D3]: =SI.ERROR(BUSCARV(C$2;INDIRECTO("'"&C3&"'!A6:F1000");COINCIDIR(D$2;INDIRECTO("'"&C3&"'!A5:F5");););"") ¡Bendiciones!
  11. Atascado con archivo (tablas)

    ¡Hola, a ambos! En el archivo de @Cristian 1985, puedes usar también, en A6 de la hoja Resumen: =BUSCARV($F$2;INDIRECTO("'"&BUSCARV($B$2;$I$4:$J$13;2;)&"'!A6:F1000");COLUMNAS($A6:A6);) Y arrastrarla hacia la derecha. Nota: Si no quieres que se dañe el formato que ya tiene, puedes hacer lo siguiente: 1. Selecciona el rango A6:F6 de la hoja resumen. 2. Sin perder la selección, y con A6 como celda activa, coloca la fórmula en la barra de fórmulas (o presionas F2 y la colocas en la misma celda). 3. Al introducirla, no lo hagas con Enter, sino con Ctrl + Enter. Así, se pega la fórmula en todas las celdas sin dañar el formato previo. Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  12. Rangos discontinuos

    ¡Hola, @njnsp! Puedes probar con: [AJ14]: =CONTAR.SI.CONJUNTO(A14:AF14;"A";A$13:AF$13;">0") ¡Bendiciones!
  13. Formula Meses y Días

    ¡Hola de nuevo, @TitoFart! Nunca hablaste en tu pregunta inicial de automatizaciones, solo de fórmulas para lograr un cometido. ¡No te acostumbres a dejar detalles de lo que quieres en el tintero cuando preguntes! haces que la persona que te ayude brinde soluciones que al final no van al caso. A ver si lo nuevo que te propongo te sirve. Mejoré la fórmula anterior en la hoja fórmula, y puse la dichosa "automatización" en las otras dos hojas. ¡Bendiciones! MesesyDías.xlsm
  14. Formula Meses y Días

    ¡Hola de nuevo, @TitoFart! He manejado dos columnas auxiliares D y E (que están ocultas) para que la fórmula no quede estrepitosamente larga. Cosas a tener en cuenta: 1. Para facilidad de la fórmula, debes ingresar los valores en formato 00m 00d hayan o no hayan meses o días. 2. He convertido el listado en una tabla, para que los cálculos con fechas adicionales en la parte inferior se calculen de forma automática en caso tal se necesiten. 3. He colocado solo un Formato condicional con la fuente en rojo cuando haya un valor negativo. La fuente positiva, por defecto la he puesto verde. 4. No se calculará la diferencia entre fechas si no ingresas ambas fechas. ¡Analiza bien la fórmula y comentas! ¡Bendiciones! MesesyDías.xlsx
  15. Formula SI

    ¡Hola, a todos! Creo que este tema se debe zanjar aquí... @TitoFart, si tienes más preguntas, debes abrir otro tema de forma puntual. Un tema en específico no se debe volver una "asesoría personalizada" con todas las preguntas que se le ocurran al consultante, cuando no se refiere al problema - pregunta original. Como consejo para futuras consultas: Trata de organizar mejor tus ideas y con ejemplos, mostrar lo que quieres. Dejo una última propuesta de fórmula, usando el sistema de fechas 1904, formato condicional para el rojo y formato personalizado [h]:mm:ss. =SI.ERROR(G11-SI(O(D18={0;"-"});SI(D16="";"";D16);D18);"") En cuanto a tu pregunta: Es casi como lo dices... Excel no conoce las horas mas allá de la 9999:59:59. Así que, si quieres trabajar con este tipo de horas más grandes, debes trabajar con las horas separadas en celdas: Una celda para la hora, otra para los minutos, y otra para los segundos y armar un texto con ellas, o formular estas horas de forma independiente (horas, minutos y segundos) dentro de la misma fórmula y armar un texto con estos números. Al hacerlo como texto, no se podrán hacer operaciones convencionales con horas fuera del límite especificado en la parte superior. ¡Revisa el archivo, y comentas! ¡Bendiciones! Libro1 (25).xlsx
×