Jump to content

johnmpl

Moderators
  • Content Count

    3,480
  • Joined

  • Last visited

  • Days Won

    193

johnmpl last won the day on November 7

johnmpl had the most liked content!

About johnmpl

Profile information

  • Gender
    Hombre
  • Localización:
    Colombia, Excel 2016

Converted

  • Campos
    ;

Recent Profile Visitors

4,888 profile views
  1. Al introducir la fórmula, debes hacerlo con Ctrl + Shift + Enter. ¡Bendiciones!
  2. ¡Hola, @julayala! (y @GabrielRaigosa) Ten en cuenta los nombres de los respectivos programas que funcionan como hojas de cálculo. Una cosa es "Excel" y otra cosa es "Hojas de Cálculo de Google". Aunque hay varias cosas en común entre las dos, ciertamente difieren en la forma en que se trabajan ciertas cosas. Ten en cuenta que este es un foro de Excel, no de Hojas de Cálculo de Google. Ahora bien, puedes usar lo que te muestro en el adjunto, duplicando la hoja por cada Oficina que aparezca, y referenciándola en la celda B1. https://docs.google.com/spreadsheets/d/1Fw4eUWLjyl3U34JEHmrGf7GVPWEZYFZQ2LPPFV1CTro/edit?usp=sharing ¡Bendiciones!
  3. ¡Hola, @JSDJSD! El problema, puntualmente, está en el uso de la función Y. Puedes usar su forma booleana, la cual corresponde a la multiplicación, o hacer un doble SI, preguntando por cada condición. Entonces, la fórmula podría quedar así (no olvides el CSE : Ctrl + Shift + Enter) : =INDICE(D3:D11;MODA(SI((B3:B11=I3)*(C3:C11=J3);COINCIDIR(D3:D11;D3:D11;)))) =INDICE(D3:D11;MODA(SI(B3:B11=I3;SI(C3:C11=J3;COINCIDIR(D3:D11;D3:D11;))))) ¡Bendiciones!
  4. ¡Hola, @Carusha! Puedes usar la siguiente fórmula, en C2 y arrastrar hacia abajo según tu necesidad: =SI(B2;BUSCAR(2;1/(Programación!B$4:B$13=A2);Programación!D$4:D$13);"") Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  5. ¡Hola, a ambos! Podríamos usar, también: =(B3>1000)*SUMA(REDONDEAR(C3*(IZQUIERDA(A3)={"W";"M"})*{15;8}%;2)) Aunque, para ser precisos con lo que muestra el consultante, se puede usar: =(B3>1000)*SUMA(REDONDEAR(C3*(A3={"WEJ"\"MEJ"}&{1;2;3})*{15\8}%;2)) Creo que hay que puntualizar que, aunque en el ejemplo del consultante no hay diferencia, no es lo mismo redondear una suma entre dos valores, que sumar dos valores redondeados. ¡Bendiciones!
  6. ¡Hola, a ambos! Puedes también probar con: =(B3>1000)*(REDONDEAR(O(A3="WEJ"&{1;2;3})*C3*15%;2)+REDONDEAR(O(A3="MEJ"&{1;2;3})*C3*8%;2)) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  7. ¡Hola de nuevo @feliche! Ya entendí lo que pretendes, y según tengo entendido, la opción no existe en Excel... pero, se puede buscar hacer un truco para que puedas hacerlo, haciendo único el campo por el que buscas expandir/contraer a través de formulación, entendiendo que si el campo es diferente en cada grupo donde está contenido, se expandirá/contraerá de forma sencilla, y no por grupos como Excel lo hace por defecto. Si con lo que te digo crees que lo puedes hacer tu, ahí está una posible solución. Si no es así, sube un archivo Excel de ejemplo de lo que tienes, tus campos con la TD armada, y te podría mostrar qué se me ocurre para hacerlo. ¡Bendiciones!
  8. Hola, @feliche! Puedes jugar con el tema de contraer o expandir algún campo de la Tabla Dinámica. Si está expandido, en el campo que quieres contraer puedes hacer clic derecho, Expandir o Contraer, Contraer todo el campo. Ahí se contraerán todos los elementos del campo en cuestión. Una vez contraidos, puedes hacer clic en el botón del elemento Error (según tu ejemplo, o cualquier otro que quieras), y se Expandirá en todos los campos en los que esté contenido. Pruébalo y comentas! Bendiciones!
  9. ¡Hola, a ambos! Otra perspectiva de lo mismo, en el adjunto. ¡Bendiciones! AYUDA CON FORMULA FECHA.xlsx
  10. Hola johnmpl, perdona que te asalte de esta manera, pero necesito ayuda con una plantilla que tengo hecha y necesito ahora ponerle unas modificaciones. La plantilla en cuestión es un cuadrante simple de Vigilantes de Seguridad, el tema es que más o menos me funcionaba pero ahora necesito que me calcule en una celda todas las horas nocturnas realizadas en el mes y del mismo modo las horas festivas. Se que es muy complicado y la verdad mis conocimientos de excel no son muchos y me esta costando muchisimo hacer las modificaciones. Decirte que las horas nocturnas van desde las 22:00 a las 06:00 y las festivas desde las 00:00 del viernes a las 00:00 del domingo. Te adjunto archivo para ver si me puedes ayudar con esto pues me es de muchisima importancia.

    Muy agradecido de antemano, un saludo desde Canarias

    Plantilla Cuadrante_Mod_3.xlsm

    1. johnmpl

      johnmpl

      ¡Hola, @Kalima!

      En primera instancia, las preguntas en el foro debes hacerlas públicamente, no de forma privada como la acabas de hacer.

      En segunda instancia, ya Silvia te ha hecho una recomendación en la pregunta que ya hiciste en el foro.  Síguela.  Haz la pregunta de nuevo en el foro, pero puntualmente.  Cuando la resuelvan, si tienes más dudas, haz otra pregunta en otro post diferente, y así irás aprendiendo, siempre que coloques de todo tu empeño para resolver.

      No te desanimes.  Hazlo, y si tengo un tiempito, te hecho una mano en el foro.  ¡Bendiciones!

  11. ¡Hola, a ambos! Ten en cuenta, para la próxima vez, subir un archivo Excel con un ejemplo de lo que tienes y deseas obtener. Ahora bien, voy a jugar un poco "al adivino". Verifica el adjunto. ¡Bendiciones! ValoresEnOtraHoja.xlsx
  12. ¡Hola, @Julioferral! Puedes usar cualquiera de las siguientes fórmulas (si así lo quieres): =SI.ERROR(INDICE(Fecha!D$3:D$43;COINCIDIR(1;(B2>=Fecha!B$3:B$43)*(B2<=Fecha!C$3:C$43);));"") =SI.ERROR(BUSCAR(2;1/(B2>=Fecha!B$3:B$43)/(B2<=Fecha!C$3:C$43);Fecha!D$3:D$43);"") Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones! ¡Bendiciones!
  13. ¡Hola, a todos! @DiegoPC, Ya que pusiste el tema "Power Query"... pos también dejo mi propuesta. ¡Bendiciones! PowerQuery - GruposAltos.xlsx
  14. ¡Hola, @Nalito! Puedes usar la siguiente fórmula: (en G7 y cópiala hasta G8) =SI.ERROR(INDICE(Lunes!$A$11:$A$701;COINCIDIR(G$5;INDICE(Lunes!$B$11:$X$701;;COINCIDIR($C7;Lunes!$B$7:$X$7;));));"") Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  15. ¡Hola, @DiegoPC! Un gusto tenerte de nuevo por estos lares. "locos" hemos estado siempre... 🥴😂😁. ¡ Bienvenido de nuevo a la "locura colectiva" ! Con gusto, @pedrosilv. ¡Un saludo!
×
×
  • Create New...

Important Information

Privacy Policy