Jump to content

johnmpl

Moderators
  • Content Count

    3,501
  • Joined

  • Last visited

  • Days Won

    197

johnmpl last won the day on January 24

johnmpl had the most liked content!

About johnmpl

  • Rank
    Advanced Member
  • Birthday 07/14/1983

Profile information

  • Gender
    Hombre
  • Localización:
    Colombia, Excel 2016

Converted

  • Campos
    ;

Recent Profile Visitors

5,125 profile views
  1. ¡Hola, @Haplox! No das muchos detalles, pero puedes intentar, entre varias opciones, con: =CONTAR.SI.CONJUNTO(M$5:M$34;">="&FECHA(2020;FILAS(A$1:A1);1);M$5:M$34;"<"&FECHA(2020;1+FILAS(A$1:A1);1)) o, también: =SUMAPRODUCTO(CONTAR.SI(M$5:M$34;">="&FECHA(2020;FILAS(A$1:A1)+{0;1};1));{1;-1}) =SUMAPRODUCTO(--(TEXTO(M$5:M$34;"yyymm")="2020"&TEXTO(FILAS(A$1:A1);"00")) y copiar la fórmula hacia abajo tanto como lo necesites. ¡Bendiciones!
  2. ¡Hola, @EduA! ¡Bienvenido al foro! Revisa el adjunto, donde dejo una propuesta. ¡Bendiciones! BUSCAR HORAS.xlsx
  3. ¡Hola, a ambos! Si el Excel que te mando es correcto, entonces revisa el modelo de datos, donde con una columna calculada en DAX muestro el resultado. ¡Bendiciones! EJEMPLO PROMEDIOS.xlsx
  4. ¡Hola, a todos! Otra opción más económica, puede ser: Sub SoloFecha() Range("M2", Range("M" & Rows.Count).End(xlUp)).TextToColumns _ Range("M2"), 1, 1, 1, 0, 0, 0, 1, 0, , Array(Array(1, 5), Array(2, 9)) End Sub ¡Bendiciones!
  5. ¡Hola, a ambos! (SIL... RPC de vuelta pa' ti) Ya estaba redactando una posible respuesta, cuando Sil compartió una fórmula muy similar a la que yo iba a compartir. De todas formas la pongo (igual, de entrada matricial). =SUMA(EXTRAE(0&A1;1+K.ESIMO.MAYOR(FILA($1:$99)*(1-ESERR(-EXTRAE(A1;FILA($1:$99);1)));FILA($1:$99));1)*10^(FILA($1:$99)-1)) Tal y como lo comenta Sil, ese 99 (en mi fórmula) corresponde a la cantidad de caracteres posible que tenga la cadena alfanumérica. Con esto, lo que quiero decir es que siempre debes colocar un número igual o mayor a la cantidad de caracteres de la cadena alfanumérica. Si tienes Excel 2019, o Office 365, puedes usar (también de introducción matricial): =UNIRCADENAS("";;SI.ERROR(--EXTRAE(A1;FILA($1:$99);1);"")) ¡Bendiciones!
  6. ¡Hola, @ROVER1965! Puedes usar la siguiente fórmula: =EXTRAE(A1;4;10) ' Si quieres el resultado como texto =--EXTRAE(A1;4;10) ' Si quieres el resultado como número Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  7. ¡Saludos @MAURO_1512! ( y a todos los integrantes de este post ). Creo debes tener en cuenta que aquí en el foro estamos para ayudar en cosas puntuales, siempre y cuando se tenga claro qué es lo que se quiere hacer. Ten en cuenta que el foro es gratuito, y cada quien ayuda según su disposición, y en algunas ocasiones, su paciencia, como bien la ha tenido el amigo @bigpetroman. Te recomiendo para una nueva oportunidad de pregunta, y un nuevo tema, ordenes tus ideas y tengas súper claro lo que quieres hacer, para que la ayuda sea precisa y concreta. Es muy incómodo (al menos para mi y lo que he percibido, para la mayoría), hacer algo y luego se cambie, y se den vueltas sin sentido alrededor de un tema que parece no "llega a su fin". Para mi, este tema ya ha sido resuelto (según tus mismos comentarios anteriores) con creces. Espero lo tomes con la mejor actitud posible, y puedas reflexionar al respecto. ¡Bendiciones!
  8. Hola, @Heiner Guillén Alvarado. Sube un archivo ejemplo con lo que tienes y deseas obtener, para que la ayuda pueda venir de forma adecuada. ¡Bendiciones!
  9. ¡Hola, a todos! @GIOVANNYVANEGAS: según entiendo, la cantidad de notas por cada asignatura es variable. Entonces, bastaría con que coloques, en una columna auxiliar, la cantidad de notas que tendrá cada asignatura (que en el ejemplo la definí como CN). Esto hará que la fórmula propuesta pueda hacer el cálculo de la Nota para Aprobar (NPA). Revisa el adjunto. ¡Bendiciones! CALIFICACIONES.xlsx
  10. ¡Hola, a ambos! Esta podría ser una forma con fórmulas para lo que necesitas. Si necesitas más repeticiones de las 20 que te dejo en el ejemplo adjunto, solamente arrastra la fórmula hasta donde la necesites (o un poco más). ¡Bendiciones! ejemplo (9).xlsx
  11. ¡Hola, @carlosrg! Disculpa por no haberte respondido antes. He estado un poco ocupado. Revisa el adjunto, donde te hago una propuesta. ¡Bendiciones! ValidaciónCondicionada.xlsm
  12. ¡Hola de nuevo, @afkael! La pregunta del porcentaje la hiciste en el "otro foro". ¿Estás turnándote por pasos en un foro y en el otro? 😂 Revisa el adjunto, con una propuesta. ¡Bendiciones! ejemplo (8).xlsx
  13. ¡Hola, a todos! La fórmula, puede reducirse a: =BUSCARV(I2;SI(E6="Inspector";Datos!B5:J22;Datos!B4:I11);2;)/(1+(E6="Media Jornada")) ¡Bendiciones!
  14. ¡Hola, @carlosrg! La verdad, al menos para mi, es confusa tu pregunta. 1. ¿En qué parte quieres la validación? 2. ¿En la primera columna siempre va Nombre 1, en la Segunda Nombre 2, En la tercera Nombre 3, y así sucesivamente? 3. ¿Siempre es una sola condición que se debe cumplir, y la colocas en el rango C22:D22? Ayúdanos a ayudarte. Si hay más detalles que creas debes contar, no ahorres en ello. ¡Bendiciones!
  15. ¡Hola, @fsabater! Revisa el archivo adjunto, con una propuesta. ¡Bendiciones! Ejemplo (7).xlsx
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png