Jump to content

Gerson Pineda

Administrators
  • Posts

    12,510
  • Joined

  • Last visited

  • Days Won

    446

Everything posted by Gerson Pineda

  1. Hola Te dejo una alternativa con VBA macro de evento Si borras un celda, Excel va escribir la leyenda "sin notas", si escribes algo diferente, pues quedara como tal Saludos Escribir sin notas_GP.xlsm
  2. En efecto mucho se puede hacer con la validación de datos, pero acomodar no es sinónimo de seguridad o funcionalidad, además con el formato en Excel es solo una mascara o capa... Para burlar la entrada de una validación es tan simple, como copiar una celda y pegar en la celda de validación y me aceptara sin mostrarme errores Excel tiene limitantes como cualquier otro software y a lo largo de los años, hemos experimentado que debemos burlarle o jugarle la vuelta y muchas cosas se pueden superar Saludos
  3. Solo es mover una tecla, mira Range("A1").CurrentRegion.Offset(1).Address(, , , 1) Pues ten cuidado Saludos!
  4. Hola a ambos! Mientras subes una pequeña muestra y asumiendo que lo que deseas es obtener el rango actual Puedes probar así ListBox1.RowSource = Range("A4").CurrentRegion.Address(, , , 1) Saludos!
  5. Tal como necesitas tu ejercicio, no es posible, puesto que las celdas tienen ciertas limitantes, que por ejemplo a nivel de VBA, se podrían superar La validación de datos es muy buena, pero fácil de burlar Por ejemplo yo introduzco 12 o así 1-1-2300 y la validación lo aceptara porque es una fecha [guárdatelo bien, es fecha] Y pues tratando de burlar un poco, prueba así =SI(ESNUMERO(A1),Y(365609>A1,36526<=A1)) o equivalente =ESNUMERO(A1)*Y(365609>A1,36526<=A1) Lo que hago es restringir el inicio [1-1-2000] y final [31-12-2900], la clave es la de inicio, puesto que no podrá ingresar un numero muy pequeño [modifica a gusto] Pero insisto este método se puede romper fácilmente Saludos
  6. Pues creo que si hay algo... aunque si ya lo hiciste, pues no estaría mal que lo compartas Saludos!
  7. Hola a todos! Una mas, sin esas odiosas funciones volátiles =SUMA(INDICE(F:F,H1):INDICE(F:F,H2)) Mi separador es la coma Saludos!
  8. Y si buscas en la sección de aportes, seguro encuentras mucho material Saludos
  9. Con una leve vuelta de tuerca, quedaría así =5*(INDICE(Cuadrante!$D$2:$K$10,COINCIDIR(A2,Cuadrante!$A$2:$A$10,),COINCIDIR(E2,Cuadrante!$D$2:$K$2,))<>"") o =SI(INDICE(Cuadrante!$D$2:$K$10,COINCIDIR(A2,Cuadrante!$A$2:$A$10,),COINCIDIR(E2,Cuadrante!$D$2:$K$2,))<>"",5,0) Saludos a ambos!
  10. Entonces solo arrastra ese campo y listo, la TD te dara un iva por cada proveedor, no debes tener mayores problemas Saludos
  11. Hola a ambos! Otras 2 soluciones mas para variar, una de ellas es utilizando BUSCARX [disponible en Excel 365] Saludos Prueba turnos.xlsx
  12. Hola Alber y bienvenido a nuestro foro! Te diría lo mismo que te mencione en el otro foro, con tu mismo tema En aquel foro, respondes como casi, sin saber de ciertos aspectos que no habías considerado, sin embargo con esto Es muy sencillo, pero cuando te lo consulte, no mire/sentí clara tu respuesta Si el iva se repite y es el mismo, solo es cosa de usar Min y ya, pero si el iva se repite pero y son distintos, ¿Cuál de ellos se debe elegir? Saludos
  13. Hola Nori Si es posible realizar esos controles, en Excel, pero para las imágenes, es recomendable realizar lo programación VBA y guardar las mismas en una carpeta, de manera que no se carguen a Excel Saludos
  14. Hola Susana Si es posible, solo agrega la función de redondeo, tal que: =REDONDEAR($D$65/4,) Saludos
  15. Hola Diego ¿Cuál es la razón de realizar esa operación? Además el resultado es correcto, a razón de la división que por lo general arroja decimales, lo tuyo solo pasa por realizar un redondeo Te sugiero usar también esta función =SIFECHA(fechainicial,fechafinal,"m") Saludos
  16. Pero entendí que eso ya estaba resuelto con la función Distinctcount pues el resultado es el mismo La parte que suponía no podías obtener era la del promedio Por lo que seguro también lo lograste Yo realice algunas pruebas, pero ya me quedo la duda sobre lo que buscabas Saludos
  17. Para ello, incluye la función ALLEXCEPT Lee sobre ella Saludos
  18. Hola Marc Para lograr que la medida te arroje el resultado que deseas, debes hacer uso de la función ALL, de tal forma que con ella, vas ignorar el contexto de filtro, la cual seria de la siguiente forma: Fechas distintas = COUNTROWS(ALL(CSI[SoloFecha])) Esta medida, además puedes ocultarla para que simplemente solo sea utilizada en tu medida de división, es decir que no es necesaria agregarla a la visualización, en tu caso a la matriz Espero con eso ya continúes y te funcione Saludos
  19. wow! pues a ver si nos muestras como lo haces y de paso, la comunidad te lo agradecerá! Respecto a tu otra duda, pues de pronto un formulario, te puede servir, para que puedas ingresar la clave y acceder a esa hoja Saludos
  20. ¿Por qué te gustan tanto las matriciales?
  21. Hola Utilizar macros en "Excel online" no es posible Saludos
  22. Hola Revisa el archivo, te dejo 2 soluciones, y te sugiero utilices la segunda Saludos SumarSi mas de un criterio_GP.xlsx
  23. Hola a ambos! Adjunto una solución mas Saludos Extraer cadenas te texto_GP.xlsx
  24. Hola xanito Te dejo 2 soluciones Saludos EXTRAE-MARCA.xlsx
  25. Con toda es explicación clara de @Antoni entiendo mejor el termino de "galones", aunque actualmente esas chapas, por estos lares no tiene casi ningún valor Saludos a todos!
×
×
  • Create New...

Important Information

Privacy Policy