Mostrar el contenido de una celda que contiene cierto texto

Para mostrar el contenido de una celda que contiene un determinado texto he utilizado la función SI junto con ESNUMERO y HALLAR.

Posiblemente conozcas alguna otra forma de hacerlo. Te invito a que dejes un comentario con tu método.

En el ejemplo de hoy, quiero que se muestre un mensaje si la celda contiene el texto “aa” que se busca.

Entiende “texto” como cadena de caracteres, es decir, que puede estar compuesto por letras, números, o ambos a la vez.

Para verlo más claramente he creado una secuencia de caracteres en la columna A y he aplicado la siguiente fórmula en la columna B:

=SI(ESNUMERO(HALLAR("aa";A2));"SÍ";"")

Primero quiero saber si la celda contiene la secuencia “aa” o no. Para eso utilizo la función HALLAR, que devuelve el número de caracteres en el que se encuentra la cadena a buscar. En caso de no encontrarla, devuelve el error #VALOR!.

ESNUMERO me dice si el resultado es un número. Si HALLAR no encuentra el texto, devuelve el error y por lo tanto ESNUMERO dará como resultado FALSO. En caso de que se encuentre el texto, ESNUMERO devolverá VERDADERO.

Y ya está prácticamente resuelta la fórmula. Ahora se aplica la fórmula condicional SI para mostrar el texto “SÍ” en caso de que ESNUMERO devuelva VERDADERO.

Descárgate el ejemplo y pruébalo.

135 - Encontrar cierto texto en una celda
Título: 135 - Encontrar cierto texto en una celda (1876 clics)
Tamaño: 33 KB

¿Conoces otra forma de llegar a este resultado?

¡Haz tu comentario!

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.
Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!