5

Mostrar el contenido de una celda que contiene cierto texto

Para mostrar el contenido de una celda que contiene un determinado texto he utilizado la función SI junto con ESNUMERO y HALLAR.

Posiblemente conozcas alguna otra forma de hacerlo. Te invito a que dejes un comentario con tu método.

En el ejemplo de hoy, quiero que se muestre un mensaje si la celda contiene el texto “aa” que se busca.

Entiende “texto” como cadena de caracteres, es decir, que puede estar compuesto por letras, números, o ambos a la vez.

Para verlo más claramente he creado una secuencia de caracteres en la columna A y he aplicado la siguiente fórmula en la columna B:

=SI(ESNUMERO(HALLAR(«aa»;A2));»SÍ»;»»)

Primero quiero saber si la celda contiene la secuencia “aa” o no. Para eso utilizo la función HALLAR, que devuelve el número de caracteres en el que se encuentra la cadena a buscar. En caso de no encontrarla, devuelve el error #VALOR!.

ESNUMERO me dice si el resultado es un número. Si HALLAR no encuentra el texto, devuelve el error y por lo tanto ESNUMERO dará como resultado FALSO. En caso de que se encuentre el texto, ESNUMERO devolverá VERDADERO.

Y ya está prácticamente resuelta la fórmula. Ahora se aplica la fórmula condicional SI para mostrar el texto “SÍ” en caso de que ESNUMERO devuelva VERDADERO.

Descárgate el ejemplo y pruébalo.

135 - Encontrar cierto texto en una celda
Título: 135 - Encontrar cierto texto en una celda (1868 clics)
Tamaño: 33 KB

¿Conoces otra forma de llegar a este resultado?

¡Haz tu comentario!

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 5 comentarios
Leonardo

Hola, buen día, agradecido por el articulo, tengo un pequeño caso:

Quiero ver si una celda tiene la palabra «a partir de» (que refleja una condición de tarifa compuesta). Para ello tengo la formula debajo, quiero reflejar que si una celda tiene la palabra «a partir de», entonces arroje «Compuesta», de lo contrario «Simple».

Para ello tengo esta formula:
=SI(HALLAR(«p»;AX6;3);»Compuesta»;SI.ERROR(HALLAR(«p»;AX6;3);»Simple»)).

Me arroja Compuesta, pero cuando no se cumple esa condición, sale #¡VALOR!, desconozco porque sale aún cuando especifiqué con SI.ERROR que me saliera la palabra «Simple» cuando encuentra un error así.

Agradecido de antemano.

Saludos,

Responder
    Sergio

    Leonardo, ¿no te valdría algo así?

    =SI(NO(ESERROR(HALLAR(«a partir de»;B11;1)));»compuesta»;»Simple»)

    Responder
Jorge

Buenas tardes Sergio. Necesito aplicar tu formula , pero con varias condiciones….como lo haria en este caso??

Ejemplo: que exista : «aa», «bb» «cc»…y que si encuentra una de estas palabras, me arroje un valor distinto en la celda formulada.

Gracias Sergio de antemano, y felicidades, eres un genio!.

Seguire tu pagina!

Responder
Sofía VargasLópez

Hola,

Hay alguna fórmula para rellenar una celda con el número de un año, si otro celda contiene algo y no esté en blanco? (sea número o letras)

Responder
    Sergio

    Hola Sofía!
    Para lo que indicas debes utilizar la función SI.

    Saludos,

    Responder

Escribe una respuesta: