Jump to content

Calcular mediante el año de nacimiento cuantos años me faltan para llegar a una determinada edad


Recommended Posts

Hola, tengo una hoja de cálculo en la cual tengo un listado de personas, en una columna tengo el año de nacimiento de cada una de estas personas, querría saber como podría averiguar cuantas personas cumplen 60 años en 2024, cuantas en 2025.

Para averiguar la edad la edad utilizo la siguiente fórmula     =SIFECHA(F2;(HOY());"Y")

Un saludo y muchas gracias.

Link to comment
Share on other sites

Hola Toneti

Sin un archivo de ejemplo es difícil darte una respuesta acertada. No sabemos como tienes estructurado los datos.

Pero ... si tienes los datos en tres columnas, una con los nombres, otra con las fechas de nacimiento, y la tercera con la edad resultante mediante tu fórmula, en una celda podrías colocar la función "contar.si" de esta manera:

=CONTAR.SI(H2:H12;"="&60)

Saludos.

Link to comment
Share on other sites

hace 34 minutos , torquemada dijo:

Hola Toneti

Sin un archivo de ejemplo es difícil darte una respuesta acertada. No sabemos como tienes estructurado los datos.

Pero ... si tienes los datos en tres columnas, una con los nombres, otra con las fechas de nacimiento, y la tercera con la edad resultante mediante tu fórmula, en una celda podrías colocar la función "contar.si" de esta manera:

=CONTAR.SI(H2:H12;"="&60)

Saludos.

Antes de nada darte las gracias por contestar, finalmente he averiguado lo que quería buscando información por la red, te comento:

Tengo una columna con fechas de nacimiento con el siguiente formato  01/01/1980 (día, mes y año) lo que quería averiguar era que celdas tienen una fecha que cumple X años a lo largo de un periodo de un determinado año, por ejemplo, quiero averiguar que celdas de la columna con fechas de nacimiento van a cumplir 60 años a lo largo de un determinado año, esto lo consigo con la siguiente fórmula:

="cumplen 60 años a lo largo del 2024  " &SUMAPRODUCTO((F2:F199>=FECHANUMERO("1/1/1964"))*(F2:F199<=FECHANUMERO("31/12/1964")))

Con esta fórmula averiguo cuantas personas cumplen 60 años a lo largo del 2024

Gracias de nuevo.

Link to comment
Share on other sites

@Toneti, puedes partir también de una idea básica: durante 2024 cumplirá 60 años todo aquel que haya nacido en 1964, así que si ya tienes las fechas de nacimiento en el rango F2:F199, bastará con:

=SUMAPRODUCTO(1*(AÑO(F2:F199)=1964))

Saludos,

Link to comment
Share on other sites

hace 22 horas, Victor7 dijo:

@Toneti, puedes partir también de una idea básica: durante 2024 cumplirá 60 años todo aquel que haya nacido en 1964, así que si ya tienes las fechas de nacimiento en el rango F2:F199, bastará con:

=SUMAPRODUCTO(1*(AÑO(F2:F199)=1964))

Saludos,

OK, tú fórmula es bastante más simple y funciona perfectamente igual, al final me quedo con la tuya.

Muchas gracias.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 88 ¿Te parecen útiles los tips de las funciones? (ver tema completo)

    1. 1. ¿Te parecen útiles los tips de las funciones?


      • No
      • Ni me he fijado en ellos

  • Ayúdanos a mejorar la comunidad

    • Donaciones recibidas este mes: 0.00 EUR
      Objetivo: 130.00 EUR
  • Files

  • Download Statistics

    • Files
      177
    • Comments
      89
    • Reviews
      27

  • Crear macros Excel

  • Posts

    • Hola, Te doy la idea de cómo lo haría yo, sin complicarme demasiado la vida. La hoja 'Datos2' es la misma que tu hoja 'Datos'.  Ahora observa la hoja 'Informe2', donde he reconstruido apoyándome en =BUSCARH las fórmulas necesarias de búsqueda. Ahora fíjate en 'Datos3', donde he insertado una columna y he añadido supuestos datos de 2024. La hoja 'Informe3' se ha reconstruido ella sola.  La lógica consiste en situar en B1 el mayor  (último) año, lo que conseguimos con =MAX.  En C1 formulamos de forma que aparezca el año anterior, y las subsiguientes fórmulas de búsqueda hacen su trabajo automáticamente. Vigila que los rangos sean suficientes: quizá haya que ampliar A2:Z2 para la fila 1, y el rango 2:7 en la/s búsqueda/s. Saludos, Libro1 (J).xlsx
    • Hol@ Foro, Hace tiempo que no formulo un tema y de nuevo busco la ayuda de los maestros, Libro con dos hojas, una con datos y otra de resumen. Bien, en la de DATOS hay las unidades anuales en columnas con lineas de detalle de producto. En la hoja de INFORME solo se  debe reflejar la información de dos ejercicios, el n y n-1. En base al año de la celda B1, y la B2 es B1-1, debe proporcionar la información de la hoja DAATOS de los respectivos años. Los años nuevos en la hoja DATOS siempre serán en la columna D, por lo que el año más viejo siempre se moverá hacia la derecha, cuando añada el 2024, la D será 2024 y el 2019 se moverá a la H. Estoy haciendo pruebas mediante la formulación, BUSCARH, BUSCARV,  INDICE y COINCIDIR, pero no logro el objetivo. Alguna fórmula sencilla a usar? Gracias por anticipado por la ayuda.. Adjunto libro ejemplo reducido a dos productos.. Xavi Libro1.xlsx
    • Perfecto, lo solucione con las variables. Muchísimas gracias a todos por vuestra atención. Un cordial saludo
    • Genial, me funcionó, mil gracias!!
    • MUCHAS GRACIAS JSDJSD ❤️, ME DISTE LA SOLUCION, YA HABIA PROBADO DE TODO.  
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy