Jump to content

Ordenar listado por grupos


Recommended Posts

Buenas tardes,

Estoy haciendo un listado similar al que muestro a continuación pero con muchos más datos.

 

Me gustaría ordenar a los clientes que han pagado:

- primero los de Sevilla,

- después los de Albacete y

- a continuación indistintamente el resto (mejor si el 5 está antes que el  y el 10).

Estoy usando la siguiente formula, pero no sé como  encontrar a los clientes no incluidos anteriormente y que cumplen la condición. 

¿Alguna sugerencia por favor?

=IFERROR(INDEX($C$5:$C$39,AGGREGATE(15,6,ROW($C$5:$C$39)-4/($E$5:$E$39=1)/($D$5:$D$39="Sevilla"),ROWS(A$1:$A5))),IFERROR(INDEX($C$5:$C$39,AGGREGATE(15,6,ROW($C$5:$C$39)-4/($E$5:$E$39=1)/($D$5:$D$39="Albacete"),ROWS(A$1:OFFSET(A9,-ROW(A9)+1+COUNTIF($H$4:H8,"Albacete"),0)))),""))

Gracias de antemano.

image.thumb.png.8429f9b28eedc6cba06cbbdb04b260f2.png

Orden listado.xlsx

Link to comment
Share on other sites

Hola,

añade una columna a la lista y pon esta formula: =+SI(E5=1;1;2) & SI(D5="Sevilla";"01";SI(D5="Albacete";"02";TEXTO(C5+1;"00")))

después ordena la lista por la columna Orden

image.thumb.png.10b1838ca9c9ebde80676f5189dcd48a.png

 

Saludos

 

Link to comment
Share on other sites

Gracias.

 

Me gustaria que fuera automatico. 

En la realidad, la primera tabla está en una hoja con todos los datos. La segunda tabla está en otra hoja, y es la limpia. Quiero tener la formula arrastrada y que se automatice sola, sin necesidad de modificarla. 

Por eso quiero saber si conoceis alguna formula. 

 

Un saludo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • 28 ¿Te parecen útiles los tips de las funciones? (ver tema completo)

    1. 1. ¿Te parecen útiles los tips de las funciones?


      • No
      • Ni me he fijado en ellos

  • Ayúdanos a mejorar la comunidad

    • Donaciones recibidas este mes: 0.00 EUR
      Objetivo: 130.00 EUR
  • Files

  • Download Statistics

    • Files
      150
    • Comments
      88
    • Reviews
      25

  • Crear macros Excel

  • Posts

    • Gracias a @Israel Cassales que me advirtió de un fallo en la formula del archivo, pero el procedimiento VBA si esta bien Lo correcto es  =INDICE(B2:N11,COINCIDIR(Q1,A2:A11,),COINCIDIR(P1,B1:N1,)) Es decir, estaba invertido la fila y columna, como argumento de INDICE  
    • Gracias por la confianza, a lo que yo me refiero es que en la formula INDICE ves que después de la matriz, sigue la fila y luego la columna, como en el ejemplo hace referencia a la celda, ésta toma primero la columna y después la fila. Eso hace que el resultado no sea el mismo con respecto al que da el ejemplo correcto del VBA.   Y como dices, esperar la respuesta, que la opción del VBA debería cumplir con la solicitud sin problema. Saludines.  
    • Hola Israel Tranquilo nada de entrometido... he visto el archivo y no lo veo invertido o no entiendo exactamente a que te refieres Esperemos que el consultante, suba su propio libro, para ver claramente su caso ¡Gracias por el aviso!   Saludos   
    • Saludos cordiales @Gerson Pineda Lamento si escribo en tu presentación pero no me dejo mandarte algún mensaje, me dice que estoy limitado a 0 mensajes por día 😁 No quiero parecer entrometido y me disculpo de antemano pero me pareció bien el avisarte sobre el detalle en el tema siguiente: Extraer valor de una tabla Las referencias de columna y celda en el COINCIDIR están invertidas devolviendo un valor diferente al correcto como te da la sentencia en VBA. Saludines
    • ¡Hola! ¿Como estan? Me gustaría de saber cómo hacer un hipervínculo dinámico, que lleve a un sitio web externo, al elegir una opción de una lista desplegable. Es decir, cada opción que elijo de la lista desplegable, el hipervínculo cambiará. EN EL CASO DE LA IMAGEN A CONTINUACIÓN, QUIERO QUE CADA NOMBRE DE EJERCÍCIO QUE ELIJO DE LA LISTADESPLEGABLE 'D3' , EL HIPERVÍNCULO DE I3 CAMBIE AL VÍNCULO DEL VIDEO CORRESPONDIENTE AL EJERCICIO EN YOUTUBE:
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy