Jump to content

Duplicar hoja que contenga macro asociada


Go to solution Solved by Gerson Pineda,

Recommended Posts

Buenas tardes,

Me gustaría saber si sería posible duplicar una hoja que  contiene una macro y  que siga conteniendo esa macro. Es decir, que en cada hoja nueva siga funcionando la macro. En el caso que adjunto, cuando las celdas de la columna F  contienen un "SI" envía un mail.

 

Muchisimas gracias de antemano.

Duplicar con MACRO.rar

Link to comment
Share on other sites

Muchísimas gracias!

Justo lo que necesitaba. La tabla real se basa en que cada vez que se rellene una celda de la columna A dentro la Pestaña "GENERAL"  se cree una hoja nueva con el formato de la "HOJA TIPO" ahora tengo que intentar relacionar celdas con las hojas nuevas automáticamente..

Si tienes alguna idea 🙂

Link to comment
Share on other sites

Hace 3 horas, ndepablo dijo:

ahora tengo que intentar relacionar celdas con las hojas nuevas automáticamente..

No termino de entenderte, pero cualquier otra modificación, la debes implementar en la macro de evento y en cada hoja se va disparar el evento

 

Saludos 

Link to comment
Share on other sites

Hola otra vez Gerson. 

Perdóname que no me explicara bien. Lo que quería decir es que, una vez hecho lo del duplicado de hoja necesito hacer otra cosa. No se si tu o alguien me  me podría ayudar...

El libro se compone de una hoja "RESUMEN" y otra  "MODELO"

Cuando rellenas una celda de la columna B  en RESUMEN (equivale a una dirección), se crea una pestaña nueva  con el nombre de la celda en cuestión, manteniendo el formato, fórmulas y macro (gracias otra vez).

Ahora, en cada línea  de RESUMEN (cada línea es la información de una obra) tiene que beber datos de la nueva hoja creada de manera automática, ejemplo:

Fila 3: creo una nueva dirección con el nombre de Goya, 6 (B3) automáticamente se crea una pestaña nueva con el nombre Goya, 6 con todo el formato de "MODELO". A partir de aquí,  los datos que se metan en la nueva pestaña Goya,6  aparecerán en RESUMEN en su respectiva línea . Si de forma manual sería por ejemplo en I3   ='Goya, 6'!F9 lo que me gustaría es que de manera automática,  cada celda de esta fila siempre coja el valor del mismo sitio de su hoja en cuestión al crearse una hoja nueva. No se si esto se podría conseguir de alguna manera.

Adjunto archivo que crea nueva  (MODELO) con nombre de celda.

 

Gracias de Antemano 😊

PARA FORO.rar

Link to comment
Share on other sites

Hola JasallBcn, en principio tu solución me funciona muy bien y hace  justo lo que quería. Como el ejemplo que os pongo es una versión muy reducida y simple, voy a ver si me valdría para todo lo que quiero hacer.

 

Muchísimas gracias!

Link to comment
Share on other sites

  • Solution
Hace 2 horas, ndepablo dijo:

voy a ver si me valdría para todo lo que quiero hacer.

Te va servir, siempre que ese total sea en la fila 9

Para superar eso, te dejo mas alternativas

=INDICE(INDIRECTO("'"&B3&"'!F:F"),COINCIDIR("TOTAL",INDIRECTO("'"&B3&"'!E:E"),))

=SUMAR.SI(INDIRECTO("'"&B3&"'!E:E"),"TOTAL",INDIRECTO("'"&B3&"'!F:F"))

Te sugiero utilizar la segunda, pues es mas eficiente en su calculo

 

Saludos!

Link to comment
Share on other sites

Buenos días Gerson,  

No entiendo bien que hacen tus fórmulas (perdona mi ignorancia).  La solución de JasallBcn me sirve para ciertas columnas ya que siempre coge el valor del mismo sitio. Pero, hay una celda  en concreto (de otra columna independiente a las de Jasal) que me tiene que dar el último valor que haya en una columna especifica de su respectiva hoja.

Creo que van los tiros por una de las que tú me das pero no sabría configurarla del todo...

=INDICE(INDIRECTO("'"&B3&"'!F:F"),COINCIDIR("TOTAL",INDIRECTO("'"&B3&"'!E:E"),))

Muchísimas gracias 

Link to comment
Share on other sites

Hace 7 horas, ndepablo dijo:

Pero, hay una celda  en concreto (de otra columna independiente a las de Jasal) que me tiene que dar el último valor que haya en una columna especifica de su respectiva hoja.

Precisamente por eso te indique esto, que busca la palabra "total" y se traerá lo que esta en la columna F, estudia un poco cada formula

Hace 22 horas, Gerson Pineda dijo:

Te va servir, siempre que ese total sea en la fila 9

Para superar eso, te dejo mas alternativas

=INDICE(INDIRECTO("'"&B3&"'!F:F"),COINCIDIR("TOTAL",INDIRECTO("'"&B3&"'!E:E"),))

=SUMAR.SI(INDIRECTO("'"&B3&"'!E:E"),"TOTAL",INDIRECTO("'"&B3&"'!F:F"))

En cuanto a ultimo valor, explica un poco mas, o de acuerdo a que criterio se debe obtener ese valor [aun que este tema se trataba de macro y no de funciones o formulas]

 

Saludos 

Link to comment
Share on other sites

  • 2 weeks later...

Buenos días expertos de Excel. 

Quiero dar una vuelta de tuerca más a este proyecto. Y lo que necesito es que cuando se cree la pestaña nueva, automáticamente me cree un hipervínculo (celda-pestaña).  He grabado una macro para ver la función que es, pero no la se definir bien...😐

'ActiveSheet.Hyperlinks.Add Anchor:=Selection, Address:="", SubAddress:= _
       ' "'Mayor, 17'!A1", TextToDisplay:="Mayor, 17"

Esta es la función que crea hipervínculo de celda a pestaña, entonces yo la he adaptado dentro del código de esta manera que funciona, pero no cambia a la pestaña en cuestión (es decir, no funciona). Creo que el fallo es que no se definir la pestaña nueva correctamente... Una ayudita porfii 😔

Private Sub Worksheet_Change(ByVal Target As Range)

    If Target.Rows.Count > 1 Then
    
    Exit Sub
    End If
   
   
    If Target.Column = 2 Then
        If Target <> "" Then
    
        Application.ScreenUpdating = False
    
        Dim sh As Worksheet
        Set sh = ActiveSheet
    
        Dim ws As Worksheet
        Set ws = Worksheets("MODELO")
        
        If Not ExistsWorkSheet(Target.Value) Then
            ws.Copy After:=Worksheets(Worksheets.Count)
            
            On Error Resume Next
            ActiveSheet.Name = Target
            
            If Err.Description <> "" Then
               Application.DisplayAlerts = False
               ActiveSheet.Delete
               Application.DisplayAlerts = True
            End If
        End If
        
        sh.Activate
        
        ActiveSheet.Hyperlinks.Add Anchor:=Selection, Address:="", SubAddress:=sh.Name & "!A1", TextToDisplay:=ActiveCell.Value  'ESTA ES MI LÍNEA ADAPTADA
        
        
    End If
   End If
  End Sub

Private Function ExistsWorkSheet(Name As String) As Boolean

    Dim i As Long
    For i = 1 To Sheets.Count
        If Sheets(i).Name = Name Then
            ExistsWorkSheet = True
            Exit Function
        End If
    Next
    
    ExistsWorkSheet = False

End Function

 

Estoy llegando ya al final de este proyecto, que está saliendo gracias a vosotros. Os lo agradezco de veras.

Link to comment
Share on other sites

Hola otra vez, ya lo he solucionado tenía que cambiar a:

ActiveSheet.Hyperlinks.Add Anchor:=Selection, Address:="", SubAddress:="'" & ActiveCell.Text & "'!a1", TextToDisplay:=MyVar

Un saludo.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Privacy Policy