Jump to content

Extraer registros entre dos fechas


Recommended Posts

Buenas tardes.

He buscado en este foro por si hay alguna consulta igual o parecida.

He visto algo con macros y no se si mi consulta se puede hacer o no sin macros, si se puede prefiero que sea sin macros.

Subo un archivo con 2 hojas de como debe quedar el mismo con las fórmulas. 

Con una fecha de inicio y una fecha final saber si se pueden extraer esos registros.

Saludos

EXTRAER REGISTROS ENTRE DOS FECHAS.xlsx

Link to post
Share on other sites

Recientemente estaba trabajando algo muy parecido a su consulta, pero usando Power Query.

Para filtrar una tabla usando como parametros externos las celdas donde estan las fechas encontré la información en esta página WEB:

Power Query – Using Parameters

Adjunto archivo con la tabla "resumen", que cumple como criterio las fechas inicial y final que ha en las celdas nombradas como

Fecha_INI y Fecha_FIN

EXTRAER REGISTROS ENTRE DOS FECHAS.xlsx

Link to post
Share on other sites

Hola Gerson

Muchas gracias por tus archivos.

No tengo Office 365 por lo que el primer archivo no lo puede utilizar.

El segundo funciona perfectamente pero si intento crear más columnas me aparece error.

El tercero no lo entiendo porque no veo ninguna fórmula en la tabla resumen.

¿Me puedes explicar el significado de lo que he marcado en verde?

=SI(FILAS($A$1:$A1)>$B$12;"";INDICE(data!$A$10:$F$29;AGREGAR(15;6;FILA(data!$A$10:$A$29)-9/((data!$A$10:$A$29>=$C$7)*(data!$A$10:$A$29<=$C$8));FILAS($A$1:$A1));COLUMNAS($A$1:A$1)))

Muchas gracias de nuevo Gerson.

Saludos 

Link to post
Share on other sites
Hace 5 horas, VALENTIN dijo:

¿Me puedes explicar el significado de lo que he marcado en verde?

El 15 es kesimomenor y el 6 significa que, si en la división existen errores los va ignorar, el -9 es restar 9 filas para redimensionar la matriz, si deseas adicionar mas columnas extiende el rango de INDICE

Estudia a fondo la función AGREGAR 

Si tienes mas dudas pues nos avisas

 

Saludos 

Link to post
Share on other sites
Hace 20 horas, VALENTIN dijo:

Buenas Gerson.

Funciona perfectamente en excel, pero también tengo que utilizar LibreOffice en mi trabajo y me desconfigura todo los datos.

No se si estas fórmulas son compatibles.

Muchas gracias por todo.

Saludos

Lamento decirte que no utilizo esa herramienta, por lo que no puedo valorar dicha compatibilidad

 

Saludos 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Privacy Policy