Jump to content
Luis Antonio Torres

Formula para recorrer celda con condicional

Recommended Posts

Estimados amigos,

 

Buenas tardes, por favor alguien me podría dar una mano con una fórmula/macro para recorrer una columna validando la columna de al lado.

Por ejemplo en la columna A tengo que escribir la fórmula dependiendo de la columna B

Validando que mientras no exista en columna b otra tienda en columna a quede el mismo nombre de tienda

así más o menos:

 

image.thumb.png.32e8ef11543b018f0a6414d92d10c019.png

y que pueda quedar así dependiendo de la columna b, puede haber más días.

image.thumb.png.bb9461738108a4bd2f24a77b2d3d67f5.png

De antemano muchas gracias por su ayuda. Adjunto archivo.

https://drive.google.com/file/d/1y7ux28jiCreITudkEmtS8rqbAAT7ARRL/view?usp=sharing

 

Share this post


Link to post
Share on other sites
Hace 2 horas, isidrod dijo:

copiar pega esa formula Luis Antonio  a ver si te funciona

=SI(IZQUIERDA(B2,1)="T",B2,A1) 

saludos isidrod

Hola, muchas gracias por tu respuesta me funcionó como lo esperaba. Obviamente la celda A1 la referencié a B1 para que pueda continuar la fòrmula.

Hay la posibilidad de hacerla con una macro?

 

Gracias nuevamente.

Share this post


Link to post
Share on other sites
En 19/7/2019 at 20:52 , Luis Antonio Torres dijo:

 

Hay la posibilidad de hacerla con una macro?

 

Gracias nuevamente.

si hay solo grabando esa formula y insertas un modulo y pegas este código

Sub Macro1()

With Worksheets("Hoja1").Range("A2:A" & Range("B65536").End(xlUp).Row)
   .FormulaR1C1 = "=IF(LEFT(RC[1],1)=""T"",RC[1],R[-1]C)"
    
    .Value = .Value
    End With
    
End Sub

ahí esta a ver si te funciona

saludos isidro

Share this post


Link to post
Share on other sites
Hace 42 minutos , isidrod dijo:

listo para ejecutar macros

tiendas dias.xlsm 20 kB · 0 downloads

Hola @isidrod realmente muchas gracias por tu ayuda. Me sirvió muchísimo.

Solamente al código he incluído lo siguiente:

 

Sub Macro1()

If Range("A1").Value = "" Then 'valida que haya texto en la celda "A1" para que pueda realizarlo.
Range("A1").FormulaR1C1 = "=+RC[1]"


With Worksheets("Hoja1").Range("A2:A" & Range("B65536").End(xlUp).Row)
    .FormulaR1C1 = "=IF(LEFT(RC[1],1)=""T"",RC[1],R[-1]C)"
    .Value = .Value
    End With
End If
End Sub

Muchas gracias de nuevo por tu valiosa ayuda.

Share this post


Link to post
Share on other sites
Sub Macro3()

If Range("A1").Value = "" Then 'valida que haya texto en la celda "A1" para que pueda realizarlo.
Range("A1").FormulaR1C1 = "=+RC[1]"
End If

With Worksheets("Hoja1").Range("A2:A" & Range("B65536").End(xlUp).Row)
    .FormulaR1C1 = "=IF(LEFT(RC[1],1)=""T"",RC[1],R[-1]C)"
    .Value = .Value
    End With

End Sub

así funciono en mi equipo

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 6254 personas - Aprender Excel - Total: 4.7 / 5