Jump to content
SALAVERRINO

Mejorar la Función SI con Función SI y BuscarV

Recommended Posts

Buenas tardes a los integrantes de este prestigioso foro, en esta ocasión recurro a uds para solicitar su apoyo en como mejorar las siguientes formulas que detallo a continuación:

Cita

FORMULA EN CELDA P2

Cuando la fórmula es evaluada

=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$8;G2=BASE_AUXILIAR!$B$9;G2=BASE_AUXILIAR!$B$10;G2=BASE_AUXILIAR!$B$11;G2=BASE_AUXILIAR!$B$12;G2=BASE_AUXILIAR!$B$13;G2=BASE_AUXILIAR!$B$14;G2=BASE_AUXILIAR!$B$15;G2=BASE_AUXILIAR!$B$16;G2=BASE_AUXILIAR!$B$17;G2=BASE_AUXILIAR!$B$18;G2=BASE_AUXILIAR!$B$19=BASE_AUXILIAR!$B$20=BASE_AUXILIAR!$B$21=BASE_AUXILIAR!$B$22=BASE_AUXILIAR!$B$23=BASE_AUXILIAR!$B$24=BASE_AUXILIAR!$B$25=BASE_AUXILIAR!$B$26=BASE_AUXILIAR!$B$27=BASE_AUXILIAR!$B$28=BASE_AUXILIAR!$B$29=BASE_AUXILIAR!$B$30=BASE_AUXILIAR!$B$31=BASE_AUXILIAR!$B$32=BASE_AUXILIAR!$B$33=BASE_AUXILIAR!$B$34=BASE_AUXILIAR!$B$35=BASE_AUXILIAR!$B$36=BASE_AUXILIAR!$B$37=BASE_AUXILIAR!$B$38=BASE_AUXILIAR!$B$39=BASE_AUXILIAR!$B$40=BASE_AUXILIAR!$B$41=BASE_AUXILIAR!$B$42=BASE_AUXILIAR!$B$43=BASE_AUXILIAR!$B$44=BASE_AUXILIAR!$B$45=BASE_AUXILIAR!$B$46=BASE_AUXILIAR!$B$47);0;E2))

G2 no contiene los criterios: 01: WINCHERO  (hoja base_auxiliar B2) -- 02: WINCHERO T (hoja base_auxiliar B3) -- 03: MURO (hoja base_auxiliar B4) -- 04: MURO T hoja base_auxiliar B5) -- 05 BODEGUERO (hoja base_auxiliar B6) -- 06 BODEGUERO T (hoja base_auxiliar B7)

Asigna el valor de la celda E2, y para el resto de criterios desde la hoja base_auxiliar (B8:B47) será 0 (cero)

formula desarrollada en celda Q2: =SI.ERROR(SI(G2="";"";SI(G2=AAA;BUSCARV(G2;BASE_AUXILIAR!$B$8:$B$47;1;FALSO);));E2)

Utilice:

Nombre de Rango: AAA (base_auxiliar D2:D7) y para BUSCARV (base_auxiliar B8:B47) y se hay mejor opción de mejora acepto ideas.

 

Cita

FORMULA EN CELDA S2

Cuando la fórmula es evaluada:

=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$2;G2=BASE_AUXILIAR!$B$4;G2=BASE_AUXILIAR!$B$6;G2=BASE_AUXILIAR!$B$8;G2=BASE_AUXILIAR!$B$9;G2=BASE_AUXILIAR!$B$10;G2=BASE_AUXILIAR!$B$11;G2=BASE_AUXILIAR!$B$12;G2=BASE_AUXILIAR!$B$13;G2=BASE_AUXILIAR!$B$14;G2=BASE_AUXILIAR!$B$15;G2=BASE_AUXILIAR!$B$16;G2=BASE_AUXILIAR!$B$17;G2=BASE_AUXILIAR!$B$18;G2=BASE_AUXILIAR!$B$19;G2=BASE_AUXILIAR!$B$20;G2=BASE_AUXILIAR!$BF$21;G2=BASE_AUXILIAR!$B$22;G2=BASE_AUXILIAR!$B$23;G2=BASE_AUXILIAR!$B$24;G2=BASE_AUXILIAR!$B$25;G2=BASE_AUXILIAR!$B$26;G2=BASE_AUXILIAR!$B$27;G2=BASE_AUXILIAR!$B$28;G2=BASE_AUXILIAR!$B$29;G2=BASE_AUXILIAR!$B$30;G2=BASE_AUXILIAR!$B$31;G2=BASE_AUXILIAR!$B$32;G2=BASE_AUXILIAR!$B$33;G2=BASE_AUXILIAR!$B$34;G2=BASE_AUXILIAR!$B$35;G2=BASE_AUXILIAR!$B$36;G2=BASE_AUXILIAR!$B$37;G2=BASE_AUXILIAR!$B$38;G2=BASE_AUXILIAR!$B$39;G2=BASE_AUXILIAR!$B$40;G2=BASE_AUXILIAR!$B$41;G2=BASE_AUXILIAR!$B$42;G2=BASE_AUXILIAR!$B$43;G2=BASE_AUXILIAR!$B$44;G2=BASE_AUXILIAR!$B$45;G2=BASE_AUXILIAR!$B$46;G2=BASE_AUXILIAR!$B$47);0;K2))

G2 contiene los criterios: 02: WINCHERO T (hoja base_auxiliar B3) -- 04: MURO T (hoja base_auxiliar B5) -- 06 BODEGUERO T (hoja base_auxiliar B7)

Asigna el valor de la celda K2, y para el resto de criterios desde la hoja base_auxiliar (B8:B47) será 0 (cero)

Y es ahí donde quisiera usar Función SI y Función BUSCARV como se aprecia la formula en celda S2 o quizás haya otro método.

FUNCION SI CON BUSCARV.xlsx

Share this post


Link to post
Share on other sites

hola salaverrino

=SI.ERROR(SI(G2="";"";SI(G2=AAA;BUSCARV(G2;BASE_AUXILIAR!$B$8:$B$47;1;FALSO);));E2)

Explica que es lo que quieres hacer, porque no se entiende la formula.

Ahí dice que si G2=a un rango  ¿como así?, en esta parte hay varios resultados.

{VERDADERO;FALSO;FALSO;FALSO;FALSO;FALSO} >> ese es el resultado de esa parte de tu formula,  nunca revisará el resto, tu formula siempre tomará el primer resultado que encuentre. :(

Después, para que utilizas buscar?  buscas nuevamente G2 en un rango y traes el mismo resultado...  🙄

Es mejor que expliques lo que necesitas , mas bien coloca el resultado que debe salir y explica el porqué del resultado.

 

Ahora, sobre la otra formula,  buscas que G2 sea igual ciertas celdas del rango en la otra hoja?  aunque veo que intercalas unas cuantas y luego son todas. ¿?

si no hay problema en buscar en toda la columna, puedes utilizar la función coincidir.

 

saludos,

Silvia

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites



×
×
  • Create New...

Important Information

Privacy Policy