Jump to content

Hallar la fecha más próxima a una fecha dada


Fleming

Recommended Posts

Buena tarde, compañeros

Al hilo de una reciente consulta realizada en el Foro con un contenido afín a este tema, acompaño archivo con diversas soluciones.

Un cordial saludo

@[uSER=1101]Fleming[/uSER] como siempre tan claro con tus aportes, gracias por compartir

Saludos

Link to comment
Share on other sites

Hola, mi apreciado Gerson.

La he probado en el archivo de mi 2º post y funciona bien, pero daría error #¡NUM! en los casos en que MIN(B9:B23)>D7

Pero tendría fácil arreglo si para evitar el error le ponemos delante

=SI(MIN(B9:B23)>D7;"No existe";.....

No estoy satisfecho con la solución (V) de dicho archivo. Es la nombrada "Fecha más próxima,superior o inferior, pero no igual" La he complicado mucho y me falla en ciertos casos, concretamente cuando D7>MAX(B9:B23) y cuando D7<MIN(B9:B23)

Si le vieras una buena solución sería estupendo.

Gracias

Link to comment
Share on other sites

Hola, mi apreciado Gerson.

La he probado en el archivo de mi 2º post y funciona bien, pero daría error #¡NUM! en los casos en que MIN(B9:B23)>D7

Pero tendría fácil arreglo si para evitar el error le ponemos delante

=SI(MIN(B9:B23)>D7;"No existe";.....

No estoy satisfecho con la solución (V) de dicho archivo. Es la nombrada "Fecha más próxima,superior o inferior, pero no igual" La he complicado mucho y me falla en ciertos casos, concretamente cuando D7>MAX(B9:B23) y cuando D7<MIN(B9:B23)

Si le vieras una buena solución sería estupendo.

Gracias

Fleming ya sabes como soy con el caso de los errores jeje, pues eso se resuelve de varias formas y tu ya la sabes

Dejame ver tu archivo detenidamente y en un chance que me quede hoy (pues tengo que terminar algo en mi trabajo) y te aviso

Pd: por aqui cae una lluvia hermosa y por alla @[uSER=1101]Fleming[/uSER] como esta el clima?

Saludos

Link to comment
Share on other sites

Gerson, como te conozco un poco, por eso "me dejé caer".

Lo tomaremos con calma, sin prisas (que no las hay), pero no creas que tiré la toalla ante la solución (V).

Con paciencia y una caña...

Pues mándanos un poco de lluvia, ya que por aquí está haciendo casi verano desde hace un mes, por lo que los agricultores están alborotados ante la falta de agua, y los no agricultores también, porque a todos nos afecta. Afortunadamente se anuncian lluvias próximas.

Saludo cordial

Link to comment
Share on other sites

Gerson, como te conozco un poco, por eso "me dejé caer".

Lo tomaremos con calma, sin prisas (que no las hay), pero no creas que tiré la toalla ante la solución (V).

Con paciencia y una caña...

Pues mándanos un poco de lluvia, ya que por aquí está haciendo casi verano desde hace un mes, por lo que los agricultores están alborotados ante la falta de agua, y los no agricultores también, porque a todos nos afecta. Afortunadamente se anuncian lluvias próximas.

Saludo cordial

Conozco la situacion de España tanto desempelo y para colmo el clima no ayuda mucho!... esta situacion es mundial pero hay que mantener la calma al fin al cabo hay cosas y casos que no podemos cambiar por mas que queramos jeje

Saludos

Link to comment
Share on other sites

@[uSER=1101]Fleming[/uSER]

Revisando tu archivo esta mas que completo, la respuesta a tu duda V esta en la I y III, en todo caso quedaria de modo electiva si la deseas superior o inferior dentro de una sola formula

Adjunto el archivo para que veas que obtengo los resultados solo con KESIMO MENOR Y MAYOR, tambien inclui una columna pero con las fechas ordenadas, nadas mas para comprobar tus y mis resultados, que son iguales

Espero no enredarte con este "tamalito" jeje

Saludos

FECHA_MÁS_PRÓXIMA.rar

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

Privacy Policy