Jump to content

bigpetroman

Members
  • Content Count

    2,292
  • Joined

  • Last visited

  • Days Won

    94

bigpetroman last won the day on October 30 2020

bigpetroman had the most liked content!

4 Followers

About bigpetroman

  • Rank
    Advanced Member
  • Birthday 12/17/1973

Converted

  • Campos
    ;

Recent Profile Visitors

4,280 profile views
  1. Saludos @jeaa, realmente no revise mucho, simplemente cambie la posición de una linea donde se "guarda" el archivo, ya que estaba dentro de un bucle y eso hacia que el archivo se guardara constantemente. Sistema de Entradas, Salidas y Almacén.xlsm
  2. amigo @jeaa el problema es que realmente yo no se que es esa formula, no se que es ese valor de 60,4 que tienes alli ni el porque lo divides entre 5 (me imagino que es la cantidad de items), si solo quieres dejar el valor entero sin mas. puedes usar esta formula =SI($C$45>0;REDONDEAR(BD!F4-(60,4-$B$48)/5;0);"") y aplicas lo mismo en las otras columna (colocar el redondear) puedes hacerlo? suerte
  3. amigo @jeaa de verdad no se como mas ayudarte, tu formula en la tabla es esta =SI($C$45>0;BD!F4-(60,4-$B$48)/5;"") alli claramente tienes un decimal (60,4) restandole la nota, luego eso entre 5, es muy probable que siempre tengas decimales allí, como no entiendo que eso, no se como ayudarte, creo que deberías revisar tu formula.
  4. @jeaa pero ese es el valor, 66.6, está bien lo que dice el Excel y la calculadora, o hay algún otro problema?
  5. saludos @jeaa, realmente el problema con tu suma es que los valores en las celdas son decimales si colocas dos decimales vas a ver lo que digo, por eso si sumas con la calculadora te da un valor diferente
  6. @jeaa mientras sigas ignorando los comentarios será difícil, está macro simplemente sustituye en tu hoja el nombre del alumno y la la nota, si hay algún cálculo y NO cuadra, pues es simplemente tu archivo y las formulas que tengas, NO es ningún problema de la macro. mientras NO termines de explicar que hace tu archivo o que es lo que necesitas y coloques algún ejemplo de lo que NO cuadra, pues será complicado. suerte
  7. amigo, lamentablemente NO nos estamos entendiendo, tu quieres que la macro haga algo pero no terminas de explicar, lo mas que voy a hacer por ti es dejarte esta macro que hace lo mismo que tu macro original pero mucho mas resumida Sub correspondencia() Dim NumCriterios As Variant Dim nCantDatos As Double Dim nDatos As Double Dim wHoja As Worksheet Dim nVariable As Integer Dim sVariable As String Dim sDatos As String ' ' correspondencia Macro ' ' Acceso directo: CTRL+a ' ''''''''''''''''''pedimos la cantidad de crieterios ''''''
  8. yo veo lo que hace la macro, simplemente hace una copia de la hoja Correspondencia y supuestamente sustituye los criterios o campos, pero en este caso simplemente cambia solo dos, <nombre> y <nota> y tu hablas hasta de 8 criterios, si puedes explicar lo que intentas hacer
  9. @jeaa lamentablemente NO puedo bajar videos, mi internet no es muy buenos y no tengo casi datos
  10. Saludos @jeaa , me parece que tu archivo está incompleto o no lo entiendo, según tu código se toman las variables de la hoja DB que van desde la columna A hasta la H según la cantidad de variables, pues es algo ilógico, pues tu tabla de DB solo tiene dos columnas (nombre y nota), es decir, el código en teoría sería para esas dos variables nada mas (aunque lo que vi está mal también), por favor si puedes aclarar eso y explicar un poco mejor puede ser que le dedique un tiempo y te ayude, suerte la idea es saber exactamente que es lo que quieres hacer para poder ayudarte
  11. saludos @jeaa, baje el archivo para ver si entendía algo pero nada, de verdad si no explicas mejor que problemas tienes y das un ejemplo de cuando si lo hace bien y cuando no, va a ser difícil que recibas ayuda
  12. Saludos @MCA , revisa el anexo, no conozco del tema pero vi un ejemplo y creo que no es nada complicado, realice varias pruebas y todas dan el valor correcto, puedes agregar tantas filas como columnas necesites (siempre insertando dentro de la misma tabla para que no se pierda la referencia) suerte Método de la esquina noroeste.xlsm
  13. Saludos amigo @Haplox, he llegado tarde a la fiesta pero allí va mi comentario. yo he tenido estos problemas muchas veces (el UCASE, FORMAT, etc) que fallan sin explicación aparente, pero te puedo asegurar que prácticamente el 100% de las veces es por problemas de referencias, no necesariamente que te falte una referencia a una librería, sino que tienes marcada una referencia a un objeto que NO está disponible en dicha maquina, si en el momento que te da el problema revisas las referencias del proyecto de seguro veras alguna que dice FALTA o MISSING, y por consiguiente el objeto o código
  14. Saludos @victorjavega revisa el anexo en la tabla que está entre BS y BW eliges la información a agregar y listo, en aulas solo te van a aparecer las disponibles para el día y hora elegidas Aulas.xlsm
  15. Saludos @alvaroballes, con el permiso del maestro @Antoni, te dejo un archivo que creo que hace lo que buscas, mientras al celda este en color naranja (el mismo color que la celda A1 de la hoja config) se agrega a los cuadros semanales donde NO se haya agregado antes, es decir, si ya se agrego a una semana NO se agrega nuevamente así siga en color naranja, solo se agrega a las semanas que no se ha agregado aún suerte Seguimiento campañas_BP.xlsm
×
×
  • Create New...

Important Information

Privacy Policy