Jump to content

silver_axe007

Members
  • Content Count

    37
  • Joined

  • Last visited

  • Days Won

    1

silver_axe007 last won the day on March 7

silver_axe007 had the most liked content!

About silver_axe007

  • Rank
    Member
  • Birthday 08/05/1983

Contact Methods

  • MSN
    silver_axe007@hotmail.com
  • Skype
    silver_axe007
  • Facebook
    www.facebook.com/silver_axe007
  • Twitter
    @silver_axe007

Profile information

  • Gender
    Hombre
  • Localización:
    Ecuador
  • Interests
    La playa, Estudio y trabajo en tecnologia, me gustan temas informaticos, ps4, juego Battlefield , Barcelonista.

Converted

  • Campos
    ,

Recent Profile Visitors

390 profile views
  1. Hola @merlyn333 Buenos dias, Te comento que el 2 y 3 estaba seguro si era eso .. el primero quizas no lo entendedia .. pero bueno vamos a ver que se puede hacer.... en ciertas ocasiones las respuestas mas sencillas son las soluciones mas robustos ... pero las mas "Complicadas" de encontrar jejejejej en fin veamos que se puede hacer ... de lo que tu me dices En éste caso está configurado para que la semana empiece los días "lunes" (Configuración!C4), entonces el próximo lunes 13 de Mayo, cuando yo abra el archivo de Excel, deberá escribirse automáticamente el valor $500,00 (Configuración!C5) en la celda "Principal!B3". ***aqui pongo 500.00 En caso de que yo no lo abra el lunes, pero lo abra cualquiero otro día de esa misma semana, igualmente se escribiría el valor $500,00 en la celda "Principal!B3". pewro no entiendo si siempre va a ser los 500 cual es la diferencia si es lunes o si es martes?? Que haria yo .. en la hoja configuracion pondia la fecha del dia con la funcion =hoy() luego pondia el valor a texto =TEXTO(DIASEM(C6),"ddddddddd") y aparece en F el dia ..... que es .. y valuidaria si dice "Lunes" Hago Algo o lo otro ... espero ayude.
  2. Pues si he leido y entendido bien...... El primer punto si siempre debe estr ese valor de C5 en principal en todas las B deberia ser =Configuración!$C$5 Para el segundo tema... esta es la formula (ppega esta eb A3 y correla) =SI(B2="","",A2+1) Celda J2 =SI(B2<>"","NO","") Copia de presupuesto_semanal_2019.xlsm
  3. If IsNumeric(target) and Target.Addres = "$L$9" Then ' es que aqui evaluas si es NUMERICO si le quitas esto .... If Target.Addres = "$L$9" Then lo que debas hacer....
  4. Cuando me toca hacer que sea la consideracion de DOS columnas .... lo que hago es concatenar estas y crear una CLAVE (que se supoines sera unica ) y si la encuentro buscando la concatenacion .. pues muestro.. para mayor claridad le pongo un mensaje en si.error por si no lo encuentra .. q se vea bien *En A concatene B y C ... lo mismo en G con H e I .. y mando a buscar su lo encuentra .. lo muestra en este caos solo veo que encuentra el expedinete 20 con fecha 11/06/2018 =SI.ERROR(BUSCARV(G4,$A$2:$E$14,5,0),"No Encontrado") Espero te ayude si no es lo que necesitas indicar ,. adicional en la formula puedes cambiar el mensa o hacer que aparezca vacio =SI.ERROR(BUSCARV(G4,$A$2:$E$14,5,0),"Si no lo encuentra Muestro ESTO") =SI.ERROR(BUSCARV(G4,$A$2:$E$14,5,0),"")
  5. Excelente lo que indicas Gerson es la solución correcta lo que indicas ... solo un tema ,. lo que pasa es que LUG (a quien alguna vez ayude en otro tema) pone sus libros en diferentes PC's... por ende la solución seria que el libro posea el método o función y no instalarlo el complemento en el excel. Saludos y muchas gracias por tu comentario cada día aprendo mas acá!!.
  6. Hola lo del punto 2 es por que TextBox17.Text = hop.Range("L" & fily) no es correcto TextBox16.Text = hop.Range("L" & fily) es correcto ya reviso lo otro auqneu no se por que dices que te sale cortado a mi me sale bien podrias subir una imagen¡?
  7. Haber .. quizas que podrias hacer .... usar ponderaciones y una tabla auxilia r.... haz que valga 1 Miembro = 1000 haz que valga 2 Miembro = 2000 haz que valga 4 Miembro = 4000 y sumas el valor de tu subdivision, y creas una tabla auxiliar y sacas un buscarV , verdadero y encuentras..... si tienes alguna duda podrias decirme espero poder ayyudarte....
  8. Guarda la funcion que utilizas ene l libro actual y listo la invocas sin novedades. Saludos Lug. Andres.
  9. Hola lo que me parece mal es qe estas realizadno mal la cadena sql o query... Query = "SELECT * FROM Consulta where [Descripción Casas]" & Exacto & Dato & _ " and Motivo" & Exacto & Devolu te faltan los iguales y en el motivo no puedes poner esos valores..... Mira asi .... Query = "SELECT * FROM Consulta where [Descripción Casas] ='" & Exacto & Dato & _ 'supongo que el dato a va filtrar lo contatenado... "' and Motivo=" & Exacto & Devolu 'aqui te faltaba la comilla...
  10. OTRA MANERA =SI(O(MES(J9)=MES($H$2),MES(K9)=MES($H$2)),0,1)
  11. no se si tenga que ver que quueres copiar de una subcarpeta a una carpeta puede ser por eso .. digo yo .--- cambia a direcciones como c:\origen y c:\destino .. prueba asi
  12. Do While ActiveCell.Value <> "" inicio = Range("B1") & ActiveCell fin = Range("B1") valida = Dir(inicio) msgbox inicio & " - " & fin ' estas seguro que existe esa ruta ??? presentala para ver si te vale If valida = "" Then Else FSO.CopyFolder inicio, fin End If ActiveCell.Offset(1, 0).Select Loop
  13. Solo una correccion en tu codigo te digo por que a mi me dio Muelas llegar a esto espero te ayude Origen = "c:\DirectorioOrigen\*.*" ' yo no se por que a mi me pedia que especifique el *.* destino = "c:\DirectorioDestino\" ' y en el destino tenga al final la barra invertida o antislash "\" fso.CopyFolder origen ,destino ,1 ' el uno para que sobreescriba Espero te ayude
  14. Hola Alfonso5597 Es por esto que es importante los labels en los formularios asi podriamos entender a que va ... haber lo que entiendo quieres... que al poner en el text1 un valor que represente Bueno en el codigo preguntas esto , pero la pregunta es ... en que momento le das el valor a TotalV??? Entiendo que primero deberias dar la suma..... Private Sub CommandButton1_Click(): On Error Resume Next If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 10) Then TextBox1.BackColor = vbGreen If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 20) Then TextBox2.BackColor = &H80FF80 If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 30) Then TextBox3.BackColor = vbYellow If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 40) Then TextBox4.BackColor = &H80C0FF If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 50) Then TextBox5.BackColor = &H80C0FF If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 60) Then TextBox6.BackColor = &H80FF& If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 70) Then TextBox7.BackColor = &H80FF& If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 80) Then TextBox8.BackColor = vbRed If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 90) Then TextBox9.BackColor = vbRed If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 100) Then TextBox10.BackColor = vbRed End Sub Yo te recomiendo inicializar a 0 los text box y luego revisar una auna .. las validaciones.... No entiendo lo que quieres hacer pero ... espero te ayude. Private Sub CommandButton1_Click(): On Error Resume Next TotalV.Text = CDbl(TextBox1.Text) + CDbl(TextBox2.Text) + CDbl(TextBox3.Text) + CDbl(TextBox4.Text) + CDbl(TextBox5.Text) + CDbl(TextBox6.Text) TotalV.Text = CDbl(TotalV.Text) + CDbl(TextBox7.Text) + CDbl(TextBox8.Text) + CDbl(TextBox9.Text) + CDbl(TextBox10.Text) If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 10) Then TextBox1.BackColor = vbGreen If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 20) Then TextBox2.BackColor = &H80FF80 If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 30) Then TextBox3.BackColor = vbYellow If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 40) Then TextBox4.BackColor = &H80C0FF If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 50) Then TextBox5.BackColor = &H80C0FF If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 60) Then TextBox6.BackColor = &H80FF& If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 70) Then TextBox7.BackColor = &H80FF& If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 80) Then TextBox8.BackColor = vbRed If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 90) Then TextBox9.BackColor = vbRed If CDbl(TotalV.Text) >= CDbl(Previsto.Text / 100) Then TextBox10.BackColor = vbRed End Sub
  15. Hasta donde se la hoja no la podrias blouear por sercciones.. lo que podrias es mostrar las 4 horjas y luego si no afectaria el proceso de una a otra...!! https://support.office.com/en-ie/article/view-multiple-panes-sheets-or-workbooks-fcdfb33e-5168-470d-a3d6-7ef1663599f3
×
×
  • Create New...

Important Information

Privacy Policy