Jump to content

Buscar fecha y mostrarlo


sagamoal
Go to solution Solved by Silvia,

Recommended Posts

Muy buenas.

Espero su ayuda, en poder mostrar la fecha, cuando estén en cierta condición.

En la Hoja1, se ingresan los datos, ya sea el código de la persona, la fecha de ingreso y la fecha de retiro.

Codigo Nombres F.Ingreso F.Retiro
10 X1 01/02/2020  
20 X2 01/02/2020 20/07/2021
30 X3 01/02/2020  
40 X4 01/02/2020  
100 X10 01/02/2020  
110 X11 01/02/2020  
120 X12 01/02/2020  
130 X13 01/07/2020  
140 X14 01/02/2020  
150 X15 10/07/2020  
160 X16 01/02/2020  
170 X17 01/02/2020  
180 X18 01/02/2020  
190 X19 23/07/2021  
200 X20 01/06/2021  

En la hoja2, se ingresa el código de la persona y ademas un carácter, que es la novedad, cuando es I, debe mostrar todas las fechas que están dentro del mes, eso se lo relaciona con la fecha del cierre, y la letra R, cuando es la fecha de retiro.

  Fecha Cierre 30/07/2021
     
Codigo Novedad Fecha
10 I  
20 R 20/07/2021
30 I  
40 I  
100 I  
110 I  
120 I  
130 I 01/07/2021
140 I  
150 I 10/07/2021
160 I  
170 I  
180 I  
190 I 23/07/2021
200 I  
   

 

He tratado de subir el ejemplo en la planilla excel, pero hay líos para subirlo.

gracias

 

 

Link to comment
Share on other sites

Hola sagamoal

Ser miembro de paga, te da algunas ventajas, como subir archivos.

Prueba esta formula, deberás adecuar a tus rangos

=SI(INDICE(MES(Hoja1!$D$5:$D$9)=7,COINCIDIR(B6,Hoja1!$B$5:$B$9,)),INDICE((Hoja1!$D$5:$D$9,Hoja1!$E$5:$E$9),COINCIDIR(B6,Hoja1!$B$5:$B$9,),,SI(Hoja2!C6="i",1,2)),"")

B6 es el código, y lo busca en la hoja 1 en la columna que corresponda.

te adjunto imágenes para que te guíes.

hoja1

image.png.147ad2e1409543839faffab9020b2af1.png

 

Hoja2

image.png.0e79d23416b21b74eccdae4d36258c40.png

Espero te sea de utilidad

Saludos,

Silvia

 

 

 

Link to comment
Share on other sites

  • Solution

hola

Se me ha pasado algo:

Cambia el 7 por mes(D3) 

=SI(INDICE(MES(Hoja1!D$5:D$9)=MES(D$3),COINCIDIR(B6,Hoja1!B$5:B$9,)),INDICE((Hoja1!D$5:D$9,Hoja1!E$5:E$9),COINCIDIR(B6,Hoja1!B$5:B$9,),,SI(C6="i",1,2)),"")

 

Link to comment
Share on other sites

  • Crear macros Excel

  • Posts

    • Muchas gracias! Voy a tener que revisar las macros porque no domino mucho...   Saludos!
    • Sube tu archivo siempre y pon un ejemplo de donde hay que tomar los datos y donde y como deben reflejarse  
    • Hola nuevamente muchachos. Espero estén bien todos, es mi mayor deseo. Estoy teniendo otro problema por acá con la configuración de un TextBox donde quiero expresar números. Propiamente el número que va a estar reflejado en esos TextBox son la división del Salario Mensual entre los días a trabajar y eso me da un índice o tarifa salarial diaria.  No tengo problemas en las operaciones matemáticas, sino en el formato a expresar en el TextBox.  Este dato lo toma el TextBox de la Hoja, la que tengo configurada (Celda) como Numero. Podrían ayudarme. Gracias de antemano y excelente semana para todos. Saludos Pino
    • Buenas tardes. Tengo el siguiente código en una macro:   Sub Prueba() hora = Hour(Now) If hora <= 18 & Sheets("Hoja1").Range("G7") = 1 Then     MsgBox ("haz esto")      ElseIf hora > 18 & Sheets("Hoja1").Range("G7") = 2 Then     MsgBox ("haz esto otro")      Else     MsgBox ("No se cumple") End If End Sub Sin embargo,  siempre se me ejecuta el Else aunque a priori se cumplan las condiciones del If. Adjunto el excel de prueba. ¿Alguna idea del por qué no entra en el If ni en el ElseIf? Gracias   Prueba.xlsm
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy