Jump to content

Error al crear fórmula en una tabla de Excel


Antonio

Recommended Posts

Un saludo a todos. He construidouna tabla de Excel en la que la última columna de la misma (P) se calcula un resultado commo se explica en el siguiente ejemplo:

En P6 swe tiene un valor X. En la fila siguiente, en la celda P7, se suma el valor en P7, se adiciona el valor de la celda H7 y se sustraen los valores de las celdas N7 y O7. Antes, se condiciona que si las celdas H7, Ny y O7 su valor es cero (0), que la fórmula devuelva igual valor, si no, que realice la operación indicada anteriormente. El caso es que al iniciar una nueva fila en la tabla, la fórmula que se copia automáticamente en la celda correspondiente de la columna P incluye un argumento (#¡REF!), tanto en la condición (el SI), como en el cálculo del resultado que se busca. He buscado por todos lados y no encuentro respuesta a qué se debe esto y cómo solucionarlo.

Esta la expresión correcta: '=SI(Y([@[RETIRO BANCO]]=0;[@[T DÉB-PSE]]=0;[@EFECTIVO]=0);0;SUMA(P6;[@[RETIRO BANCO]]-[@EFECTIVO]))'

Y esta la incorrecta: '=SI(Y(#¡REF!=0;H9=0;N9=0;O9=0);"";SUMA(P8;#¡REF!;H9-O9))'

Si se observa, tampoco toma los nombres de los campos de la tabla que intervienen en la fórmula.

Agradecería mucho la ayuda que me puedan prestar sobre este caso. Para el efecto, subo el archivo correspondiente.

 

TABLA GASTOS-ERROR FÓRMULA.xlsm

Link to comment
Share on other sites

Hola,

Tener constantes y fórmulas dentro de un campo de una tabla no es muy recomendable, lo ideal es que las fórmulas en los campos sean "coherentes" en cada uno de los registros.

En la celda "P6" desea un valor que depende de una condición Concepto = "SALDO INICIAL", si el concepto es diferente el excel deberia hacer el cálculo deseado.

La formula debería ser la misma para cada fila.

Solo me he limitado al cambio de la formula de la celda "P6", la nueva formula se debe repetir en forma automatica en cada registro insertado conservando la logica del calculo cuando el concepto no coincide con ser el "SALDO INICIAL".

Revise el archivo adjunto.

 

TABLA GASTOS-ERROR FÓRMULA CAMPO.xlsm

Link to comment
Share on other sites

  • Crear macros Excel

  • Posts

  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy