Jump to content

Antonio

Members
  • Posts

    341
  • Joined

  • Last visited

About Antonio

  • Birthday 12/19/1954

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Antonio's Achievements

  1. OK, no sabía eso. Disculpa esa omisión. ¿Quedan marcados con una X?
  2. JSD JSD, excelente, me sirvió tu solución. Te reitero mi agradecimiento. Poddemos dar por solucionado el tema.
  3. Muchas gracias JSD JSD por tu ayuda. En principio, parece que me servirá esta solución. Probaré y te comentaré.
  4. Enlace a Drive: https://drive.google.com/file/d/1aATF_YL8W3yBqmHZAoK3lQ-lODDHMrSi/view?usp=drivesdk
  5. Requiero que en la celda C4 de la Hoja "Datos" se copie el resultado de concatenar el dato de la celda A4 con el de la celda B4 A su vez, que el dato de la celda C4 de la Hoja "Datos" se copie como valor en la primera celda vacía que se encuentre en el rango que inicia a partir de la celda A4 de la Hoja "Facturas" cuando pulse un botón que ejecute la macro. Y, por último, que al copiar el dato de la celda C4 de la Hoja "Datos" en la Hoja "Facturas" se valide que el dato no se duplique o que ya se encuentra registrado. Ahora, si hay la posibilidad de omitir la concatenación de datos de las celdas A4 y B4 en la celda C4 de la Hoja "Datos" y realizarla directamente en la celda A4 de la Hoja "Facturas", también sería válida. La validación sí es imprescindible. No tengo forma de subir un archivo de ejemplo, ¿cómo hago? Antes podía hacerlo pero ahora no encuentro la opción. Gracias.
  6. Luis, muy amable de tu parte por responder a mi inquietud. Muchas gracias.
  7. Gabriel, muy agradecido por tu ayuda y enseñanza sobre las fórmulas en Tablas. Podemos dar por solucionado este tema. Bendiciones
  8. Un saludo a todos. He construidouna tabla de Excel en la que la última columna de la misma (P) se calcula un resultado commo se explica en el siguiente ejemplo: En P6 swe tiene un valor X. En la fila siguiente, en la celda P7, se suma el valor en P7, se adiciona el valor de la celda H7 y se sustraen los valores de las celdas N7 y O7. Antes, se condiciona que si las celdas H7, Ny y O7 su valor es cero (0), que la fórmula devuelva igual valor, si no, que realice la operación indicada anteriormente. El caso es que al iniciar una nueva fila en la tabla, la fórmula que se copia automáticamente en la celda correspondiente de la columna P incluye un argumento (#¡REF!), tanto en la condición (el SI), como en el cálculo del resultado que se busca. He buscado por todos lados y no encuentro respuesta a qué se debe esto y cómo solucionarlo. Esta la expresión correcta: '=SI(Y([@[RETIRO BANCO]]=0;[@[T DÉB-PSE]]=0;[@EFECTIVO]=0);0;SUMA(P6;[@[RETIRO BANCO]]-[@EFECTIVO]))' Y esta la incorrecta: '=SI(Y(#¡REF!=0;H9=0;N9=0;O9=0);"";SUMA(P8;#¡REF!;H9-O9))' Si se observa, tampoco toma los nombres de los campos de la tabla que intervienen en la fórmula. Agradecería mucho la ayuda que me puedan prestar sobre este caso. Para el efecto, subo el archivo correspondiente. TABLA GASTOS-ERROR FÓRMULA.xlsm
  9. Excelente, Antoni. Gran ayuda y gran descuido de parte mía. Agradecido contigo. Podemos dar por terminado el tema. Bendiciones.
  10. Saludo a todos. Solicito el favor de que me ayuden con un error que me salta al correr una macro con la cual pretendo registrar datos en una hoja de Excel. El error se produce cuando se ejecuta la línea de código "Hoja5.Range ("E9"), ClearContents". Sin embargo, cuando comento el bloque de las líneas siguientes (son 12 similares), el error que salta es el 13 en tiempo de ejecución, No coinciden los tipos. Les agradecería enormemente su ayuda. Subro el archivo para una mayor comprensión de lo que expongo. PLANTILLA CONTROL DE CAJA-2021_v2.xlsm
  11. Muchísimas gracias, Antoni, por tu valiosa ayuda. Funcionó perfecto. Podemos dar por solucionado el tema.
  12. Hola a todos. Tengo una serie de datos (4,872) que contienen cadenas de texto a los cuales hay que suprimir espacios intermedios. He intentado con las funciones Suprimir, Reemplazar y no lo he logrado. Igualmente. con la opción Buscar y reemplazar sin éxito. Las cadenas de texto tienen esta estructura: 00: 01: 04,600 --> 00: 01: 09,599 El espacio que hay que suprimir es el que se encuentra después de los dos puntos (:), es decir, que debe quedar así; 00:01:04,600 --> 00:01:09,599 Aspiro a que alguien me ayude con una macro que me permita hacer esta tarea y, para el efecto, adjunto un archivo con una muestra. Muchísimas gracias. FORMATO.xlsx
  13. Muchas gracias por tu respuesta, Gerson. Podemos dar por solucionado el tema.
  14. Gracias a Silvia y a Gabriel por sus aportes a la solución de mi problema.
  15. Yo sí creo, Gerson. Muchas gracias por tu ayuda. Sin embargo, me gustaría que me explicaras la línea If .Column > 5 And .Column < 9 Then. ¿A qué se refiere el mayor a 5 y el menor a 9?
×
×
  • Create New...

Important Information

Privacy Policy