Jump to content

Sumar.si.conjunto rango de 2 columnas usando referencias estructuradas


Recommended Posts

Buenas noches:

Tengo que sumar un rango de 4 columnas y quiero hacerlo usando referencias estructuradas. pero me da erro... me pone Valor

hago lo siguiente

                                                  Rango de suma               Rango condic 1        Cond 1      Rango cond 2         Cond 2

=Sumar.si.conjunto(Eventos[[columna1]:[Columna4]];Eventos[columna5];"="&A87;Eventos[Columna6];"Condición2")

Se que el error está en el rango de la suma. 

Gracias

Link to post
Share on other sites

¡Hola @pmorales23!

Ten en cuenta siempre subir un archivo adjunto Excel que lo que tienes y deseas obtener, para que la ayuda sea más precisa (además son normas del foro)

Las columnas en las funciones x.SI(.CONJUNTO) deben tener la misma dimensión y sentido.  Si quieres sumar 4 columnas, puedes usar la función DESREF dentro de la función, así:

=SUMA(SUMAR.SI.CONJUNTO(DESREF(Eventos[columna1];;{0\1\2\3});Eventos[columna5];A87;Eventos[Columna6];"Condición2"))

De igual forma, también puedes usar SUMAPRODUCTO, con la ventaja que aquí si puedes usar diferentes dimensiones en columnas:

=SUMAPRODUCTO((Eventos[[columna1]:[Columna4]])*(Eventos[columna5]=A87)*(Eventos[Columna6]="Condición2"))

¡Bendiciones!

Link to post
Share on other sites
×
×
  • Create New...

Important Information

Privacy Policy