Jump to content

TRAER VARIOS DATOS EN DIFERENTES COLUMNAS DE 1 REGISTRO


Recommended Posts

datos a traer.xlsx

 

Buenas tardes, en el archivo adjunto hay 2 hojas (datos y base), lo que necesito es que en la hoja datos en cada columna de fecha me traiga de la hoja base las fechas de cada uno de los clientes, ejemplo del sr anselmo en la celda E2 deberia traer la fecha 20/01/2020, en la celda F2 deberia traer la fecha 21/02/2020 y asi sucesivamente si tuviera otra fecha

 

Quedo pendiente de su ayuda

Link to post
Share on other sites

Hola @gacg1310! Adjunto 2 opciones, la primera usando la función BUSCARV y una columna auxiliar; y la segunda usando funciones matriciales (se ingresan presionando Ctrl + Shift + Enter).

La búsqueda la hice en base al número de cédula, ya que los datos de los nombres no son adecuados; para que sirvan, el nombre de cada persona debe escribirse igual en ambas tablas ("ANSELMO SALAMANCA MARTINEZ" no es lo mismo que "ANSELMO MARTINEZSALAMANCA").

Saludos!

datos a traer.xlsx

Link to post
Share on other sites
Hace 7 horas, Cristian 1985 dijo:

Hola @gacg1310! Adjunto 2 opciones, la primera usando la función BUSCARV y una columna auxiliar; y la segunda usando funciones matriciales (se ingresan presionando Ctrl + Shift + Enter).

La búsqueda la hice en base al número de cédula, ya que los datos de los nombres no son adecuados; para que sirvan, el nombre de cada persona debe escribirse igual en ambas tablas ("ANSELMO SALAMANCA MARTINEZ" no es lo mismo que "ANSELMO MARTINEZSALAMANCA").

Saludos!

datos a traer.xlsx 12.19 kB · 0 descargascritian, no me sale en mi base real, me ayudas por favor no entiendo que pasa

 

Link to post
Share on other sites

Así debería funcionar:

Cita

En AP7

=SI.ERROR(BUSCARV($D7&"-"&COLUMNA()-41;fechas!$A$3:$F$7791;6;FALSO);"-")

 

Paso a explicarla por si precisas adaptarla en el futuro.

La fórmula BUSCARV se encarga de encontrar cada uno de los valores que siguen.

En $D7 se usan referencias mixtas porque siempre se debe hacer referencia a la columna D.

Se usa COLUMNA()-41 porque la primera fórmula se inserta en la columna 42. En el primer caso el resultado es 1 (42-41), en el segundo 2 (43-41), en el tercero 3 (44-41) y así sucesivamente; de esta forma, la fórmula va buscando las sucesivas apariciones del valor.

"fechas!$A$3:$F$7791" es el rango en el que se encuentran los datos, debes ampliarlo cada vez que se agreguen nuevas filas o directamente tomar un rango mayor (por ejemplo, fechas!$A$3:$F$10000) y editarlo cuando se excedan las 10000 filas. Una tercera opción (no siempre recomendable) sería hacer referencia a las columnas completas (fechas!$A:$F).

El 6 es porque los datos que necesitamos buscar se encuentran en la 6° columna del rango anterior y FALSO porque necesitamos una coincidencia exacta en los valores.

Todo está envuelto en la función SI.ERROR para los casos que no se encuentran en la base de datos.

Saludos!

Edited by Cristian 1985
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Posts

    • ¡Hola @pmorales23! Ten en cuenta siempre subir un archivo adjunto Excel que lo que tienes y deseas obtener, para que la ayuda sea más precisa (además son normas del foro) Las columnas en las funciones x.SI(.CONJUNTO) deben tener la misma dimensión y sentido.  Si quieres sumar 4 columnas, puedes usar la función DESREF dentro de la función, así: =SUMA(SUMAR.SI.CONJUNTO(DESREF(Eventos[columna1];;{0\1\2\3});Eventos[columna5];A87;Eventos[Columna6];"Condición2")) ¡Bendiciones!
    • Mil Gracias Isidro, si es justo lo que necesito, mil Gracias, con este hermoso aporte, doy por cerrado el tema.  
    • Buenas noches: Tengo que sumar un rango de 4 columnas y quiero hacerlo usando referencias estructuradas. pero me da erro... me pone Valor hago lo siguiente                                                   Rango de suma               Rango condic 1        Cond 1      Rango cond 2         Cond 2 =Sumar.si.conjunto(Eventos[[columna1]:[Columna4]];Eventos[columna5];"="&A87;Eventos[Columna6];"Condición2") Se que el error está en el rango de la suma.  Gracias
    • Estimados, gracias por la ayuda, ya solucioné mi proyecto , Saludos,
    • Buenas tardes chic@s; Tengo una macro que pone diferentes fórmulas en varias hojas diferentes y para poder ponerlas tengo que antes seleccionar la hoja donde quiero que se ponga. Hay alguna forma de poner la fórmula en la hoja que necesite sin antes seleccionar/activar dicha hoja??. Las fórmulas las pongo de la siguiente forma: Worksheets("Hoja2").Range("A2:A30").FormulaR1C1= "aquí la fórmula" Pd: ahora mismo no tengo aquí el Excel, estoy escribiendo desde el móvil, si es necesario mañana le adjunto. Muchísimas gracias.
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy