Jump to content

combinar formula de promedio con formula si.error


Recommended Posts

Buenas tardes

Necesito de vuestra ayuda

Tengo una planilla donde debo leer el promedio de dos celdas (D7;D10), pero que si hay algún error me devuelva el valor 0, este resultado se deme mostrar en la celda G7

yo he aplicado de esta forma =PROMEDIO((D7;D10);SI.ERROR(G7;0)), pero no me arroja el resultado correcto, estoy haciendo algo mal? o debo separar las operaciones y después en otra columna hacer la combinación?

desde ya muchas gracias a todos!

Link to post
Share on other sites

Cristian si quisiera agregarle un argumento mas a esta formula, en donde si el promedio me da cero que devuelva la palabra Undetermined

Se que me vas a decir que directamente cambie el 0 x la palabra pero sucede que hay cedas q al no tener valores para realizar el porcentaje me devuelve el 0 por lo que necesitaría ese argumento para las celdas que me pasa eso

=SI.ERROR(PROMEDIO(E14;E17);"0")

 

Agradecere tu ayuda

Link to post
Share on other sites

Hola! Para agregar un texto debes ponerlo entre comillas. Algunas opciones:

Cita

=SI.ERROR(SI(PROMEDIO(E14;E17)=0;"Undetermined";PROMEDIO(E14;E17));"0")

=SI.ERROR(SI(E14=-E17;"Undetermined";PROMEDIO(E14;E17));"0")

 

Si el único error que pueden tener los datos es que las celdas se encuentren vacías:

=SI(Y(E14="";E17="");"Undetermined";PROMEDIO(E14;E17))     'ambas celdas vacías

=SI(O(E14="";E17="");"Undetermined";PROMEDIO(E14;E17))     '1 celda vacía

Creo que en tu caso te va a servir mejor la segunda opción, ya que si E14 es opuesto a E17 el promedio es 0 y también funciona si las celdas estan vacías!

Saludos!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Posts

    • Hola a todos. Estoy buscando la forma de pegar varias gráficas que están en varias pestañas de un excel en unos apartados de word, manteniendo la vinculación de datos de las gráficas con vba. Os mando un ejemplo por si me pudierais ayudar. Gracias!BuscarV (1).xlsx
    • Hola, Con esta formulación funciona siempre y cuando estén siempre todos los datos, como puedes ver si falla alguno de ellos se produce un error. prueba (1).xlsx
    • Hola! Podría valerme esta solución. Muchas gracias!!!
    • DiegoPC saludos y millones de gracias por tu valiosa ayuda amigo.
    • Hola a tod@s Nuevamente solicitando su tiempo para resolver un nuevo caso. Según el archivo "prueba" la celda A2 contiene la siguiente información: Vehículo 2018 BMW X4 2.0 XDrive20I A M Sport Precio $28.000.000 CLP Kilómetros 36.000 km Color blanco bach Body 5 doors 5 seat SUV Litros (motor) 2.0 Cilindros 4 Combustible Bencina Lo particular de esta información de la celda A2 es que está con "Ajuste de texto" o carácter (010) y por cada título o cabecera debajo de esta está la descripción. Por ejemplo: Vehículo es a 2018 BMW X4 2.0 XDrive20I A M Sport Precio es a $28.000.000 CLP Kilómetros es a 36.000 km ... Mencionado lo anterior se necesita extraer la descripción de "Vehículo" en la celda B2 que en este caso es "2018 BMW X4 2.0 XDrive20I A M Sport". En la celda C2 la descripción del "Precio" y así sucesivamente. Saludos   prueba.xlsx
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy