Jump to content

Buscar en Columna y Marcar Si


julayala

Recommended Posts

Buenas Noches Amigos,

 

Necesito de vuestra ayuda, resulta que cada dia debo revisar dos columnas y verificar si esta auditado o no y decir cual es el faltante, me podrian ayudar he subido una hoja de excel con un ejemplo, lo que requiero es que si encuentra el mismo valor en las columnas F y G   escriba SI , si no lo encuentra NO

 

A lo mejor sera facil pero he probado con varias formulas que he visto en youtube y en verdad ninguna me ayuda y este trabajo me quita mucho tiempo, 

 

Muchas Gracias, 

AUDITADO SI O NO.xlsx

Link to comment
Share on other sites

Hola @julayala

Si te he entendido bien, aquí te pongo una propuesta, lo que no encontré en la hoja2 donde buscar el Faltante, para poder relacionarlo, de todas formas he puesto una columna en la Hoja2 con unos supuestos Faltantes para darte una idea, tampoco especificas si te hace falta el Faltante para los “SI” o para los “NO”, así que te lo he puesto para ambos casos.

Ya me dirás si es lo que precisas.

Un Saludo

Lázaro.

P/D- No me deja subir el Archivo, bueno de momento te pongo las formulas.

En la celda H5 de la Hoja1 pon esta formula.

=SI(G5="";"";SI(CONTAR.SI(F$5:F$164;G5);"SI";"NO"))

En la celda I5 de la Hoja1 pon esta formula.

=SI.ERROR(BUSCARV(F5;Sheet2!$I$4:$L$266;4;0);"")

y crea una columna en la Hoja2 con los Faltantes, ponlos apartir de L4 hacia abajo.

 

Link to comment
Share on other sites

 

Pues lo otro que se me ocurre, es que tu Excel no acepte algo de los caracteres del mío, igual debes cambiar al Ingles las Formulas.

De todas formas cualquier otro compañer@ podrá ver mejor cual es el problema, yo la verdad que del Idioma Ingles estoy en cero.

Y no me deja subir el Archivo donde lo tengo resuelto sin problema.

Saludos.

Lázaro

Link to comment
Share on other sites

si lo tienes resulto en tu excel, no se si te conte, pero la idea es que encuentre similitud en la columna H  contra la F, lo que pasa que no va a estar ordenado la columna F porque voy revisando y voy colocando, la formula debe buscar en la columna H y buscar similitud en la columna F y colocar si 

me lo puedes enviar a mi email por favor : julayala@gmail.com

Link to comment
Share on other sites

Hola @julayala

Bueno aquí te mando otras interpretaciones de tus comentarios, si quieres buscar en la propia columna G si existe alguna repetición pues pon está en la Celda H5.

=SI(G5="";"";SI(CONTAR.SI(G$5:G$164;G5)>1;"SI";"NO"))

Si quieres en la propia columna F, pon en H5

Cita

 =SI(F5="";"";SI(CONTAR.SI(F$5:F$164;F5)>1;"SI";"NO"))

Saludos.

Lázaro

Link to comment
Share on other sites

 

Bueno @julayala , aquí te pongo otra opción, realmente me dedique a buscar ese error que te daba y que nunca había visto, creo que tiene que ver con la Función CONTAR.SI, no entendí el Por qué?, quizás otro compañer@ lo sepa, pero te mando otra solución para ver si te sirve, en este caso sería comparar cada celda de los AUDITADOS con relación a REPORTADOS.

=SI(G5="";"";SI.ERROR(SI(INDICE(F$5:F$1000;COINCIDIR(G5;$F$5:$F$1000;0);1);"SI");"NO"))

Si lo necesitas los REPORTADOS  con relación a los AUDITADOS, solo es cambiar los rangos, es decir sustituir la G por la F y viceversa en la formula.

No te subo archivo, pues parece ser que tengo algún problema en particular.

Saludos.

Lázaro.

Link to comment
Share on other sites

Bueno @julayala  ya puedo subir Archivos, así que ahí te dejo lo que te he explicado hasta ahora, sino no es lo que deseas o falta algo, ya nos dirás.

Recuerda que he colocado en la Hoja2 una columna con los supuestos Faltantes.

Como veraz a mí al menos no me da el error que tu comentas.

AUDITADO SI O NO(2).rar

Link to comment
Share on other sites

Estos son números Aleatorios que puse, un poco para darte una idea en caso de que te sirva, lo puedes sustituir por los que tú entiendas.

Además la formula de BUSCARV se puede condicionar por si necesitas los FALTANTES para cuando te dé “SI” o “NO”.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Current Donation Goals

    • Raised 45.01 EUR of 130.00 EUR target
  • Files

  • Download Statistics

    • Files
      143
    • Comments
      87
    • Reviews
      25

    Latest File
    By pegones1

    3    0

  • Crear macros Excel

  • Posts

    • Estoy trabajando un archivo de biblioteca para el cual ya me han ayudado anteriormente con un ListBox y con un formulario para Mantenimiento de Listas, lo que me ha servido muchísimo y de lo cual estoy muy agradecido de los miembros Antoni y JSDJSD,  en esta oportunidad he agregado al objeto "ThisWorbook" las instrucciones "Application.Visible = False" y "FRMPanel.Show" para que al usuario le muestre solo el formulario "Panel" desde donde podrá realizar la gestión de la biblioteca, ocultando la aplicación Excel a su vista. La contraseña del proyecto es "biblio" Además he agregado al formulario un botón de comando para hacer visible Excel, el que al ejecutarlo y,  previamente a hacer visible Excel, le pedirá una contraseña (en este caso "biblio"),  para evitar que trabajen directamente en la hojas, tablas y VBA si no tienen el acceso necesario, además agregué en el mismo formulario un botón de comando para ocultar Excel y volver al modo de usuario. El problema es que después de abrir una vez el archivo,  funciona correctamente lo esperado, es decir: se abre el formulario "Panel" manteniendo oculto Excel,  pero cuando cierro el formulario y lo vuelvo a abrir, en esta oportunidad me abre Excel en la hoja lista, sin abrir el formulario y ocultar Excel. Para que vuelva a funcionar el código debo obligadamente guardar el archivo y solo la vez siguiente volverá a funcionar. La idea es que cuando el usuario cierre el formulario "Panel" y vuelva a abrirlo,  nuevamente esté oculto Excel y le muestre solo el formulario "Panel". Intenté poner la instrucción "ActiveWorkbook.Save" en el evento "BeforeClose",  primero en el objeto ThisWorbook y no me resultó,  después probé agregando lo mismo en el código del botón "Cerrar" del formulario "Panel" y tampoco me resultó,  la 2da vez que lo abro (sin haber guardado el archivo) siempre me muestra Excel,  y lo que necesito es que cada vez que el usuario abra el archivo le muestre el formulario "Panel", ocultando Excel. Les agradecería muchísimo me pudiesen ayudar con este inconveniente. Listas.xlsm
    • Hi @FGV  Podemos sumar ideas, por lo que pude comprender el formato negativo le causa conflicto a @Pirtrafilla y para no entrar en opciones avanzadas podemos modificar el formato para poder tratar con todas. Saludines         Convertir a horas.xlsx
    • Antoni no puede pensar en retiros... el es MODERADOR PERPETUO.
    • Que tal a todos, considerando la versión de Excel de la consulta, me permito aportar otra posible solución con fórmula matricial. Espero les sea útil. Ordenar correos (Ayuda Excel).xlsx
    • Hola a todos, Una solución para M365 podría ser, suponiendo que el rango a evaluar sea A1:A6 : =ORDENARPOR(A1:A6;TEXTODESPUES(A1:A6;"@")) que desplegará una matriz con los resultados deseados........ pero eso sí, por orden estrictamente alfabético de dominio; es decir: aaaa@fp.com dddd@fp.com bbbb@hg.com eeee@hg.com cccc@ml.com fffff@ml.com Saludos,                                
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy