Jump to content

Recommended Posts

Estimados:

 

Solicito su ayuda por favor.

Necesito en la columna K:

Escribir una formula que permita calcular el sueldo más el bono correspondiente al término de conflicto de los empleados con la siguiente escala

Sueldos mayores o iguales a 2000000 el bono será de 50000

Mayores iguales a 1000000 y menores a 2000000 el bono será de 75000

Sueldos menores a 1000000 el bono será de 100000

 

Entonces, por ejemplo:

para el sueldo de c8 que son 1500000, el valor de k8 debería ser 1575000

 

No sé como hacerlo, por eso solicito su ayuda

 

Muchas gracias :)

 

 

PABLO BRAVO (1).xlsx

Link to post
Share on other sites

Hola!

 

adjunto solución

=SI(C8>$C$23;$D$23;SI(Y(C8>$C$25;C8<$C$23);$D$24;SI(C8<$C$25;$D$25)))

agregue una tabla para obtener el dato, tu modificas los textos como crees que es mejor.

espero te sirva.

(depende de tu excel, modifica el ; por ,)

 

PABLO BRAVO (1).xlsx

Edited by myusagi
incluí el PD, de ; y ,
Link to post
Share on other sites
Hace 41 minutos , myusagi dijo:

Hola!

 

adjunto solución


=SI(C8>$C$23;$D$23;SI(Y(C8>$C$25;C8<$C$23);$D$24;SI(C8<$C$25;$D$25)))

agregue una tabla para obtener el dato, tu modificas los textos como crees que es mejor.

espero te sirva.

(depende de tu excel, modifica el ; por ,)

 

 

 

Muchas gracias, me has salvado

 

Saludos ❤️

Hace 41 minutos , myusagi dijo:

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Posts

    • Buenos días compañeros, @JSDJSD Estoy utilizando la solución que me prestaste en la empresa y me solucionaste la vida a parte de estar super contento, y he añadido muchas cosas más. Ahora me encuentro con otro problemilla que me gustaría añadir y no sé como implementarlo en tu codigo. Necesito que en el textbox se obligue a añadir un mínimo de 8 caracteres y un maximo de 17 y si no es correcto que se termine la macro. No sé si me explico. He intentado añadir este código pero creo que no sé implementarlo correctamente ya que pongas lo que pongas me salta que tengo que poner 8 caracteres mínimo.   If Val(TextBox1) < 8 Or Val(TextBox1) > 17 Then MsgBox "Rango invalido. Mínimo 8 caracteres. Gracias." Exit Sub End If   No sé si me podrías ayudar de nuevo. Gracias
    • Te he reestructurado un poco él código. Ya comentarás si quieres los combos ordenados y que se añada de forma automática al elegir de la lista. LLAVES.xlsm
    • Hola @gacg1310! Adjunto 2 opciones, la primera usando la función BUSCARV y una columna auxiliar; y la segunda usando funciones matriciales (se ingresan presionando Ctrl + Shift + Enter). La búsqueda la hice en base al número de cédula, ya que los datos de los nombres no son adecuados; para que sirvan, el nombre de cada persona debe escribirse igual en ambas tablas ("ANSELMO SALAMANCA MARTINEZ" no es lo mismo que "ANSELMO MARTINEZSALAMANCA"). Saludos! datos a traer.xlsx
    • Private Sub Worksheet_Change(ByVal Target As Range) With Target If .Column = 3 Then ' Si la celda cambiada petenece a la coluna 3 = "C", entramos ... Application.EnableEvents = False 'Desactivo eventos porque voy hacer cambios en las celdas .Offset(, -1) = Format(Now, "hh:mm") 'Ponemos la hora en la celda, una celda a la Izq, de la celda modificada ' que si estamos en "C" ==> "B" If Len(.Text) = 0 Then .Offset(, -1) = "" ' Evaluo : Sí En la celda cambiada no hay nada, elimino ' lo que hay en la celda una a la Izq Application.EnableEvents = True 'Activamos eventos End If End With End Sub Te dejo el código comentado para que el próximo cambio te lo puedas apañar tú. Saludos
    • Hola a todos! Adjunto una opción usando forulación y una columna auxiliar. Los datos de la columna "Fecha recogida/entrega" no tenían el formato correcto, hay que convertirlos a formato fecha. Saludos! productividad por horas.xlsx
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy