Jump to content

excell no funciona al cerrar archivo excell.xlms


Recommended Posts

Buenos Días, 

Tengo un archivo excell, 16000 kb. Contiene celdas vinculadas a otro libro y dos macros que copian valores de una hoja a otra , y otra que muestra formulas y sustituye  un mes por otro cuando la ejecuto. El archivo me deja trabajar, guardar pero al cerrar el libro excell deja de funcionar.

He quitado los vinculos, no funciona, he quitado los complementos no funciona. No se que hacer, el problema es si tengo otros libros abiertos, que se cierran al dejar de funcionar excell.

Alguna idea?

Gracias

 

Link to post
Share on other sites

Buenas tardes Susana.

Con "deja de funcionar" quieres decir que te da un error y se cierra? 

Quizá el archivo tenga algún código que cierre los demás archivos.

Por favor, adjunta el archivo. Si tiene datos confidenciales quítalos.

Le echaré un vistazo a las macros y al archivo en general.

Link to post
Share on other sites

Hola Sergio, no puedo enviarte el archivo. Son todos los costes de mi empresa y tiene en todas sus pestañas datos que no puedo compartir. Lo que ocurre es que cuando le doy a la cruz de cerrar el archivo sale el mensaje excell dejo de funcionar y se cierra todo, luego se reinicia solo, es extraño porque me deja trabajar y guardar, es solo cuando lo cierro, no se que es lo que hace excel cuando cierra un archivo, las macros son muy simples, el fichero contiene numerosas tablas. Solo necesito que me des alguna idea de donde puede estar el motivo, solo me ocurre con ese fichero.

Gracias

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.



  • Crear macros Excel

  • Posts

    • Buenos días. Es mi primera intervención, y ya es para pedir ayuda.  Ver si puedo contar con vuestras experiencias.   Tengo una tabla, en una columna días, y en la otro la puntualidad de ese día en concreto en "%"   Ya he calculado en el total de año el nr de días que la puntualidad ha sido del 100%   Pero (y ahí es donde me he quedado atascado), necesitaría un contador que me dijera el número de días que llevamos con una puntualidad de los empleados del 100%   He encontrado este tema que me ha servido de algo de ayuda, pero o bien no se interpretarlo, o no es exactamente lo que busco.     Comunidad, anticipadamente, muchas gracias por vuestra ayuda. EJEMPLO 1.xlsx
    • Buenas a tod@s, Os adjunto un calendario al que quiero hacer lo siguiente: como veis tengo una celda que es la E22 en color rojo que usaré para los dias festivos. Justamente debajo incluiré los dias festivos (1 de enero, 6 de enero, etc) estos dias al incluirlo en el listado querria que cambiaran el color segun el relleno de la Celda E22. Tambien busco la forma de que si cambio el año estos dias se actualicen Luego tengo la celda I18 que tiene el color amarillo y querria que al incluir los dias del calendario me cambiaran al color de relleno de dicha celda. Es posible? 2021.xlsm
    • Después de varios años sin abrir una hoja de cálculo, me encuentro ante nuevos retos, espero poder aportar mis antiguos conociminentos y aprender de los vuestros.   Un Saludo. !!
    • ¡Hola a ambos! @YOUSAFJAMALD, para la próxima, sube un archivo Excel en vez de una imagen.  Nos ayuda mucho más a ayudarte. Ahora, en cuanto a tu problema y como bien te comenta @DiegoPC, efectivamente, con la función BUSCAR "solita", el problema no es posible realizarlo, pero con "ayuda" si que es posible. =BUSCAR(2;1/FRECUENCIA(0;1/(1+(K$37:K$43<=N37)*K$37:K$43));L$37:L$43) otra alternativa un poco más "digerible": =INDICE(L$37:L$43;COINCIDIR(MAX(INDICE(K$37:K$43*(K$37:K$43<=N37);));K$37:K$43;)) o también usar la función BUSCARX (solo disponible en Microsoft 365 / Excel 2021 / Excel Online 😞 =BUSCARX(N37:N63;K37:K43;L37:L43;"No Existe";-1) Analiza detenidamente las propuestas.  ¡Bendiciones!
    • Saludos espero me puedan ayudar, he intentado todo y no lo consigo. estoy tratando de descargar datos de una web la cual es "post" y posteriormente es "get" redirecciona a otra pagina, solo lo he logrado con el navegadro explorer pero el detalle que es muy tardado ya que son 170mil datos y con explorer es como si fuera navegando, abrir explorador, poner url, bucar las etiquetas donde se hace la cosulta y despues click en un boton, esperar a que cargue la pagina y extraer los datos de esa consulta.   me gustaria poderlo hacer mediante xmlhttp   anexo link de la pagina  https://serviciosfinanzas.villahermosa.gob.mx:8800/serviciosfinanzas/dp/busqueda-agua.html y mi codigo    Sub Web_Data()     Dim str_arg As String    Dim URL     str_arg = "xContrato=000001&Buscar=Buscar"     URL = "https://serviciosfinanzas.villahermosa.gob.mx:8800/serviciosfinanzas/dp/busqueda-agua.html" Set OBJHTTP = CreateObject("MSXML2.XMLHTTP")     With OBJHTTP              .Open "GET", URL, False         .setRequestHeader "User-Agent", "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.114 Safari/537.36"         .setRequestHeader "contenido-type", "text/html"         .setRequestHeader "contenido-type", "application/xhtml+xml"         .setRequestHeader "contenido-type", "application/x-www-form-urlencoded"                  .setRequestHeader "contenido-type", "application/javascript"         .send str_arg         TXT = .responseText         Debug.Print TXT              End With     [A1] = html.getElementsByTagName("td")(1).innerText 'valor a extraer numero de contrato, nombre y direccion End Sub
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy