Jump to content

Archived

This topic is now archived and is closed to further replies.

alc112

Una función si anidada me arroja un falso

Recommended Posts

Hola,

Nunca había usado una función SI tan larga y resulta ser que llega un punto que en vez de calcularme lo que necesito, me arroja "FALSO" para los valores del régimen intermedio y no sé como corregirlo.

La función sería esta:

=SI(B7<50;($G$4*($G$1-$G$2)*A7*A7/(18*$G$3));SI(50>=B7<10^5;(D7*$G$3/B7/$G$2);SI(B7>=10^5;(RAIZ(3*($G$1-$G$2)*A7*$G$4/$G$2)))))[/CODE]

Y respondería a las fórmulas de esta tabla (B7 es Ar):

mbJ5IUz.png

Les dejo la planilla

Dropbox - TpSedimetacion.xlsx

No me deja subirla como archivo adjunto al tema. Mil disculpas.

Share this post


Link to post
Share on other sites

Hola!

Como opción, podrías usar esta fórmula en C2:

=SI(B2<50;$G$4*($G$1-$G$2)*A2^2/(18*$G$3);SI(B2<10^5;D2*$G$3/(A2*$G$2);RAIZ(3*($G$1-$G$2)*A2*$G$4/$G$2)))[/CODE]

Y copias hacia abajo. Comentas!

Espero haberte ayudado, Dios te bendiga!

Share this post


Link to post
Share on other sites

Hola que tal estimado:

Lo que veo es que de la celda C2 hasta C8 tu segunda condicion es esta SI(50>=B4<10^5 y a partir de la celda C9 a C18 es esta SI(50<=B9<10^5 y por lo que veo no usas la misma condicion en todas las celdas. Entonces en la celda C7 y C8 te muestra falso porque las condiciones que pusiste no se cumplen, recuerda que la función si te pide estos parametros

Si(prueba_lógica,[Valor_si_verdadero],[Valor_si_falso])[/CODE]

por lo tanto te falta poner el valor falso

Cambia el texto "ValorSiFalso" por un valor

[CODE]=SI(B7<50,($G$4*($G$1-$G$2)*A7*A7/(18*$G$3)),SI(50>=B7<10^5,(D7*$G$3/B7/$G$2),SI(B7>=10^5,(RAIZ(3*($G$1-$G$2)*A7*$G$4/$G$2)),"ValorSiFalso")))[/CODE]

Share this post


Link to post
Share on other sites

Hola, primero veo que la primera condicion es "SI b7 es menor que 50" y en la siguiente condicion es que sea menor o igual que 50 y a su vez menor que 10^5, creo que estas dos condiciones son lo mismo, no se si ahí querias el intervalo de 50 a 10^5 entonces tendría que ser 50 menor o igual que b7, así quedaria: "50<=B7<10^5", otra observacion es que al final: "...G$4/$G$2))))) te falta una expresión despues del segundo parentesis de izquierda a derecha.

"...$G$2)),"aqui falta el [Valor Si Falso]")))"

Espero haber ayudado.

Share this post


Link to post
Share on other sites

Muchísimas gracias por las respuestas.

Seguí los consejos y me sirvió mucho. Al final hice como dijeron primero, agregar al valor falso la última condición y anduvo de maravilla.

La fórmula tenía que ser la misma en toda la columna, es que yo me puse a probar pensando que escribí mal el intervalo algebráicamente (la idea era b7 está entre 50 y 10 a la 5)

Share this post


Link to post
Share on other sites

Ok... es bueno que hayas resuelto el inconveniente.

Ten en cuenta que en ocasiones es redundante usar varias condiciones cuando los rangos son intervalos. Es decir, si la primera condición es B2<50, al ser falsa necesariamente es B2>=50, lo que nos dice que no es necesario volver a preguntar si B2 >=50, puesto que ya se supone desde la primera condición (tal y como lo planteé en la fórmula que puse primero).

Como acotación, sería bueno que regalaras un clic en "me gusta" en las respuestas que ayudaron a resolver tu duda. Otra acotación: Cuando un tema esté solucionado, debes escribir tu mismo algo como TEMA SOLUCIONADO, para que los moderadores del foro cierren el tema. Dios te bendiga!

Share this post


Link to post
Share on other sites



×
×
  • Create New...

Important Information

Privacy Policy