Jump to content

Ama

Members
  • Content Count

    902
  • Joined

  • Last visited

  • Days Won

    3

Ama last won the day on July 12 2014

Ama had the most liked content!

About Ama

  • Rank
    Advanced Member
  • Birthday 09/10/1985
  1. Hola La diferencia es que la columna "C" tiene un formato especial que muestra 001 pero el valor es 1. La columna "I" no tiene valores numéricos ,si en la celda se ve 01 y no es el efecto de un formato en la celda ,el dato no deja de ser un texto y por eso la función K.Esimo no opera sobre estos datos.
  2. Hola hotel A ver si esta formula te puede servir ,la copias en la celda H6 y arrastras al resto de celdas. =SUMAPRODUCTO((G6>=$C$6:$C$301)*(G6<=$D$6:$D$301))[/CODE] Saludos
  3. Hola jcjones Seguramente que al abrir el libro la hoja que se muestra no está afectada por el procedimiento ,es decir que hay que seleccionar otra hoja y volver a seleccionar esta. Igual puedes correr el código al abrir el libro. Bueno con lo que sea comentas.
  4. Hola celim Cambia la línea que selecciona el rango: Esta- rn1.Select[/CODE] por [CODE]rn1.Resize(UlF - 3, 1).Select[/CODE] saludos
  5. Hola jcjones La restricción se realiza sobre la hoja donde está puesto el procedimiento "Activate": Private Sub Worksheet_Activate() Run "interface" Me.ScrollArea = "A1:AA79" End Sub[/CODE] Si quieres que funcione en otra hoja solo tienes que ponerlo en el módulo de la hoja que quieras. Saludos
  6. Hola Rafael A ver si la formula que te vale puede ser esta: =INDICE(FACTURAS!$K$5:$K$459;COINCIDIR(1;INDICE(($B6=FACTURAS!$C$5:$C$459)*($C6=FACTURAS!$D$5:$D$459)*($L6=FACTURAS!$E$5:$E$459);))[/CODE] Lo que tienes que tener en cuenta es el valor que hay en la columna factura de la hoja "Facturas" (D:D) tiene que ser del mismo tipo que el de la columna "Cartera" (C:C) .No puede ser que en una parte el dato sea un valor númerico y en otra un número como texto. Te lo comento porque ahora lo tienes así ,y no se encuentra la coincidencia. Saludos
  7. Hola gustavo Mira a ver si te sirve esta formula: =EXTRAE(F4;1;HALLAR(".";F4)-1)+1&".2"[/CODE] Adapta la formula a la separación de argumentos de tu excel : punto y coma ( o coma(,) Saludos Entro mi respuesta y no vi tu respuesta bigpetroman
  8. Hola olguita9222 Aquí tienes el archivo corregido. Para aplicarlo a tu ejemplo tienes que copiar el código que está en el módulo de la hoja1 y pegarlo en la hoja que quieres que actúe de tu libro. Inserta un módulo en tu libro y copia el código que está en el módulo de mi ejemplo. Saludos Concatena y mantiene los colores(1).xls
  9. Hola olguita9222 Por medio de una función no se puede mostrar mas que el resultado de la misma ,el color depende del color que tenga asignada la celda ,pero solo puede ser uno. Una idea es hacer una macro que se activa con el procedimiento Change de la hoja ,en la celda se puede poner el rango que se quiere concatenar guardar en una variable el rango a concatenar y activar una macro que concatena al rango y color. La pega es que no se actualiza como una formula ya que el resultado son los valores. Bueno si el uso va a ser ocasional igual te puede servir. Te dejo un ejemplo ,a ver que tal. Concatena y mantiene los colores.xls
  10. Hola 5luis Cambia la línea Selection.PasteSpecial xlPasteFormats[/CODE] por esta [CODE]ActiveSheet.Paste[/CODE] Al utilizar esta línea se pega todo ,hasta los nombres definidos que afectan al rango copiado. Para evitar al pegar futuras facturas el error del nombre existente hay que quitarlo del libro destino. Entonces añade esta línea después de pegar los datos: [CODE]ActiveWorkbook.Names("tblArticulos").Delete[/CODE] saludos
  11. Hola aczazueta En el formulario buscar y reemplazar (ctr+ está el botón Formato... Este botón abre el formulario buscar formato ,el botón abajo a la izquierda (Elegir formato de celda) es para que pulses sobre la celda que quieres copiar el formato. A ver si te sirve
  12. Hola henryericsson El utilizar la opción filtro de una forma manual hay que hacerlo hoja por hoja ,copiar e ir pegando los datos en la hoja Documentos pendientes ,el problema está en que cada vez que se modifica un registro hay que borrar los datos de la hoja Documentos Pendientes y volver a realizar el proceso. Una opción es hacer una macro que filtre todas las hojas y muestre el resultado en la hoja Documentos Pendientes ,claro que cada vez que se actualiza un registro hay que filtrar de nuevo para tener la hoja actualizada. Otra opción es que la macro se active al modificar el valor de la columna "K" que parece ser la que verifica el estado de la factura. tu diras.
  13. Hola Pablolin Para evitar el desbordamiento: Tienes declaradas las variables mD,f y r como rango En la variable mD no se le asigna bien el rango ,tienes que modificar la línea:. mD = Range("A1").CurrentRegion por Set mD = Range("A1").CurrentRegion Edito:. Entro la respuesta de Macro Antonio mientras respondía ,no vi la respuesta:. Lo dejo para que qpuedas corregir en futuras macros el problema.
  14. Hola Pablolin El desbordamiento puede ser posible no por la cantidad de celdas que se recorren si no por el modo en que se hace. Hay una linea para evitar la actualización de pantalla ,es decir anular todos los movimientos que realiza la macro ,como seleccionar,ocultar,copiar etc... Si no se aplpica en códigos que producen mucho movimiento se consumen muchos recursos y el código no es admisible. En el archivo adjunto tienes el código modificado. Dentro del código está explicada cada linea ,ya verás que tampoco hace falta un bucle para encontrar la ultima celda vacía. Registro Contratación Vida 1.rar
  15. Hola henryericsson Puedes usar un filtro y mostrar solo "pendientes" en la columna -Falta regularizar- ,copias y pegas en la hoja documentos pendientes. Te puede valer si es una tarea que se realiza de cuando en cuando. Otra opción es utilizar una macro que automatiza la tarea. Con lo que sea comenta.
×
×
  • Create New...

Important Information

Privacy Policy