Jump to content

ioyama

Members
  • Content Count

    4,745
  • Joined

  • Last visited

  • Days Won

    30

ioyama last won the day on July 23 2014

ioyama had the most liked content!

3 Followers

About ioyama

  • Rank
    Advanced Member
  • Birthday 06/20/1963

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hola Con =SI.ERROR(BUSCARV(VALOR(EXTRAE(A2;3;7));cruce!A:B;2;0);"") en B2 y copiando hacia abajo podría valerte. Siempre y cuando mantengas la codificación en cuanto a número de dígitos y dígitos que usas en el cruce Un saludo desde Vitoria
  2. Hola Entiendo que te contará de más y es que Electromecanico I* incluye a los Electromecánico II* En este caso el comodín (*) te está seleccionado de más. Prueba a usar =CONTAR.SI.CONJUNTO(SUC;B2;CARGOS;"Electromecánico I *") - CONTAR.SI.CONJUNTO(SUC;A2;CARGOS;"Electromecánico II *") Si no me equivoco debería darte el resultado esperado Un saludo desde Vitoria
  3. Hola Prueba a seleccionar las dos hojas a imprimir, tal que algo como Sheets(Array("Hoja2", "Hoja3")).Select ActiveSheet.ExportAsFixedFormat Type:=xlTypePDF, Filename:= ........ Un saludo desde Vitoria
  4. Hola Te adjunto una opción usando una función matricial (y nombrando el rango de la lista ya que lo pongo en la segunda hoja) No te avisa, simplemente no te muestras las opciones ya seleccionadas con lo que no puedes repetirte Un saludo desde Vitoria ListaValidacionSinRepetidos_io_180830.zip
  5. Hola Revisa el adjunto. He procurado mantener tu tabla, pero se trabaja mejor si simplificad líneas en blanco, combinadas, etc. Me he limitado a usar las funciones INDICE y COINCIDIR Un saludo desde Vitoria Precios_io_180830.zip
  6. Hola Prueba con ="DESAYUNO "&(DIA(HOY()))&" de "&NOMPROPIO(TEXTO((HOY());"MMMM")) Un saludo desde Vitoria
  7. Hola Prueba con la siguiente macro (debes ponerla en la hoja sumario) Private Sub Worksheet_Activate() If Range("D37") >= 0.99 Then r1 = 153 g1 = 255 b1 = 204 Else r1 = 255 g1 = 204 b1 = 255 End If If Range("E37") >= 0.99 Then r2 = 153 g2 = 255 b2 = 204 Else r2 = 255 g2 = 204 b2 = 255 End If ActiveSheet.ChartObjects("Gráfico 8").Activate ActiveChart.SeriesCollection(1).Points(1).Format.Fill.ForeColor.RGB = RGB(r1, g1, b1) ActiveChart.SeriesCollection(1).Points(2).Format.Fill.ForeColor.RGB = RGB(r2, g2, b2) Range("L35").Select End Sub El evento que la activa es Worksheet_Activate es decir que cada vez que entras en la hoja sumario la macro se activará y coloreará las barras Otra opción es usar el evento Worksheet_Calculate de forma que cada vez que haya un cálculo la macro se ejecute (habría que limitarla para que no se esté ejecutando continuamente) Un saludo desde VItoria
  8. Hola Revisa el adjunto =SI.ERROR(INDICE(BDDatos[Codigo],COINCIDIR(0,INDICE(CONTAR.SI(B$2:B2,BDDatos[Codigo]),),0)),"") =DESREF(Lista_Codigo!$B$3;;;CONTAR(Lista_Codigo!$B$3:$B$20)) En apariencia funciona Un saludo desde Vitoria Lista codigos rev1_gp_io_180612.xlsm
  9. Hola Rigor Desmarca las celdas modificables en Formato de celda, pestaña Proteger >>> Bloqueada Protege la hoja Listo, las imágenes no se podrán seleccionar y sólo podrán variarse las celdas que tu quieras Un saludo desde Vitoria
  10. Hola Revisa el siguiente enlace Creo que es lo que estás solicitando Un saludo desde Vitoria
  11. Hola parca Si te he entendido bien con usar la función BUSCARV te sería suficiente, en tu archivo en C2 de la Hoja2 copia =BUSCARV(B2;Hoja1!$B$2:$C$16;2;0) Y arrastras hasta el final. Un saludo desde Vitoria
  12. Hola Jorge La función SUMAPRODUCTO podría valerte. Revisa el adjunto Un saludo desde Vitoria Sumaproducto_io_171222.zip
  13. ioyama

    fórmulas

    Hola Yo me decantaría por un filtro avanzado tal y como te adjunto. Al variar la celda V2 de la hoja Filtro obtienes los datos correspondientes de la cartera completa. Dado que los filtros avanzados son manuales he puesto una pequeña macro de evento para que al modificar V2 se active el filtro. Un saludo desde Vitoria FiltroAvanzado_io_171213.zip
  14. ioyama

    duda

    Hola (haz caso al compañero johnmpl) Revisa el adjunto Un saludo desde Vitoria PuntosDentroFuera_io_171010.zip
  15. Hola Sergio Prueba a usar al opción de: Obtene Datos Externos (pestaña Datos) desde Excel Un saludo desde Vitoria
×
×
  • Create New...

Important Information

Privacy Policy