Jump to content

johnmpl

Moderators
  • Content Count

    3,501
  • Joined

  • Last visited

  • Days Won

    197

Everything posted by johnmpl

  1. ¡Hola, @Haplox! No das muchos detalles, pero puedes intentar, entre varias opciones, con: =CONTAR.SI.CONJUNTO(M$5:M$34;">="&FECHA(2020;FILAS(A$1:A1);1);M$5:M$34;"<"&FECHA(2020;1+FILAS(A$1:A1);1)) o, también: =SUMAPRODUCTO(CONTAR.SI(M$5:M$34;">="&FECHA(2020;FILAS(A$1:A1)+{0;1};1));{1;-1}) =SUMAPRODUCTO(--(TEXTO(M$5:M$34;"yyymm")="2020"&TEXTO(FILAS(A$1:A1);"00")) y copiar la fórmula hacia abajo tanto como lo necesites. ¡Bendiciones!
  2. ¡Hola, @EduA! ¡Bienvenido al foro! Revisa el adjunto, donde dejo una propuesta. ¡Bendiciones! BUSCAR HORAS.xlsx
  3. ¡Hola, a ambos! Si el Excel que te mando es correcto, entonces revisa el modelo de datos, donde con una columna calculada en DAX muestro el resultado. ¡Bendiciones! EJEMPLO PROMEDIOS.xlsx
  4. ¡Hola, a todos! Otra opción más económica, puede ser: Sub SoloFecha() Range("M2", Range("M" & Rows.Count).End(xlUp)).TextToColumns _ Range("M2"), 1, 1, 1, 0, 0, 0, 1, 0, , Array(Array(1, 5), Array(2, 9)) End Sub ¡Bendiciones!
  5. ¡Hola, a ambos! (SIL... RPC de vuelta pa' ti) Ya estaba redactando una posible respuesta, cuando Sil compartió una fórmula muy similar a la que yo iba a compartir. De todas formas la pongo (igual, de entrada matricial). =SUMA(EXTRAE(0&A1;1+K.ESIMO.MAYOR(FILA($1:$99)*(1-ESERR(-EXTRAE(A1;FILA($1:$99);1)));FILA($1:$99));1)*10^(FILA($1:$99)-1)) Tal y como lo comenta Sil, ese 99 (en mi fórmula) corresponde a la cantidad de caracteres posible que tenga la cadena alfanumérica. Con esto, lo que quiero decir es que siempre debes colocar un número igual o mayor a la cantidad de caracteres de la cadena alfanumérica. Si tienes Excel 2019, o Office 365, puedes usar (también de introducción matricial): =UNIRCADENAS("";;SI.ERROR(--EXTRAE(A1;FILA($1:$99);1);"")) ¡Bendiciones!
  6. ¡Hola, @ROVER1965! Puedes usar la siguiente fórmula: =EXTRAE(A1;4;10) ' Si quieres el resultado como texto =--EXTRAE(A1;4;10) ' Si quieres el resultado como número Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  7. ¡Saludos @MAURO_1512! ( y a todos los integrantes de este post ). Creo debes tener en cuenta que aquí en el foro estamos para ayudar en cosas puntuales, siempre y cuando se tenga claro qué es lo que se quiere hacer. Ten en cuenta que el foro es gratuito, y cada quien ayuda según su disposición, y en algunas ocasiones, su paciencia, como bien la ha tenido el amigo @bigpetroman. Te recomiendo para una nueva oportunidad de pregunta, y un nuevo tema, ordenes tus ideas y tengas súper claro lo que quieres hacer, para que la ayuda sea precisa y concreta. Es muy incómodo (al menos para mi y lo que he percibido, para la mayoría), hacer algo y luego se cambie, y se den vueltas sin sentido alrededor de un tema que parece no "llega a su fin". Para mi, este tema ya ha sido resuelto (según tus mismos comentarios anteriores) con creces. Espero lo tomes con la mejor actitud posible, y puedas reflexionar al respecto. ¡Bendiciones!
  8. Hola, @Heiner Guillén Alvarado. Sube un archivo ejemplo con lo que tienes y deseas obtener, para que la ayuda pueda venir de forma adecuada. ¡Bendiciones!
  9. ¡Hola, a todos! @GIOVANNYVANEGAS: según entiendo, la cantidad de notas por cada asignatura es variable. Entonces, bastaría con que coloques, en una columna auxiliar, la cantidad de notas que tendrá cada asignatura (que en el ejemplo la definí como CN). Esto hará que la fórmula propuesta pueda hacer el cálculo de la Nota para Aprobar (NPA). Revisa el adjunto. ¡Bendiciones! CALIFICACIONES.xlsx
  10. ¡Hola, a ambos! Esta podría ser una forma con fórmulas para lo que necesitas. Si necesitas más repeticiones de las 20 que te dejo en el ejemplo adjunto, solamente arrastra la fórmula hasta donde la necesites (o un poco más). ¡Bendiciones! ejemplo (9).xlsx
  11. ¡Hola, @carlosrg! Disculpa por no haberte respondido antes. He estado un poco ocupado. Revisa el adjunto, donde te hago una propuesta. ¡Bendiciones! ValidaciónCondicionada.xlsm
  12. ¡Hola de nuevo, @afkael! La pregunta del porcentaje la hiciste en el "otro foro". ¿Estás turnándote por pasos en un foro y en el otro? 😂 Revisa el adjunto, con una propuesta. ¡Bendiciones! ejemplo (8).xlsx
  13. ¡Hola, a todos! La fórmula, puede reducirse a: =BUSCARV(I2;SI(E6="Inspector";Datos!B5:J22;Datos!B4:I11);2;)/(1+(E6="Media Jornada")) ¡Bendiciones!
  14. ¡Hola, @carlosrg! La verdad, al menos para mi, es confusa tu pregunta. 1. ¿En qué parte quieres la validación? 2. ¿En la primera columna siempre va Nombre 1, en la Segunda Nombre 2, En la tercera Nombre 3, y así sucesivamente? 3. ¿Siempre es una sola condición que se debe cumplir, y la colocas en el rango C22:D22? Ayúdanos a ayudarte. Si hay más detalles que creas debes contar, no ahorres en ello. ¡Bendiciones!
  15. ¡Hola, @fsabater! Revisa el archivo adjunto, con una propuesta. ¡Bendiciones! Ejemplo (7).xlsx
  16. ¡Hola de nuevo, @ROVER1965! Te doy dos opciones para que coloques el caracter "º" 1. En la fórmula que te dí, puedes concatenarle al final el caracter "º", así: =1+SUMAPRODUCTO((C4<$C4:$L4)/CONTAR.SI($C4:$L4;$C4:$L4))&"º" El resultado, por la concatenación, es un texto. 2. Puedes dejar la fórmula que te dejé anteriormente (sin la concatenación), dándole un formato personalizado, así (Formato de Celdas, Pestaña Número, Opción Personalizado, debajo de tipo, escribes) : General"º" El resultado seguirá siendo numérico, solo que se verá el caracter "º" a la derecha de los números. ¡Bendiciones!
  17. ¡Hola, a ambos! Si es tal cual como muestras en tu imagen, entonces, prueba con la siguiente fórmula (en C2) y arrastras hacia la derecha: =1+SUMAPRODUCTO((C4<$C4:$L4)/CONTAR.SI($C4:$L4;$C4:$L4)) Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
  18. ¡Hola, a ambos! Cuando abres un archivo en una carpeta, Windows genera un "pseudoarchivo" que comienza por vigulilla (~). Esto lo detecta Power Query, e intenta abrir el archivo, sin que este lo sea realmente. Lo que debes hacer es, en el filtro de los archivos que él selecciona dentro de la carpeta, omitir los que comienzan por la vigulilla. Así podrás trabajar con archivos cerrados o abiertos, sin problema. ¡Bendiciones!
  19. ¡Hola, @Pedro Martos Sanchez! En ese orden de ideas, si estás aprendiendo, no deberías encasillarte a algunas funciones para resolver un cometido. Conoce varias funciones para lograr resolver un problema en particular. Hazlo de varias formas, y así ampliarás el conocimiento que tienes sobre Excel. ¡Saludos y Bendiciones!
  20. ¡Hola, @Matías86! Puedes probar cualquiera de las siguientes fórmulas: =--EXTRAE(A766;16;SUMA(HALLAR(" ";A766;{8;17})*{-1;1})-1) =--ESPACIOS(EXTRAE(SUSTITUIR(A766;" ";REPETIR(" ";99));3*99;99)) ¡Bendiciones!
  21. ¡Hola, @Pedro Martos Sanchez! Tu pregunta suena a "tarea de escuela"... Es una función matricial (debes introducirla con Ctrl + Shift + Enter, en vez de solo Enter): =INDICE(D6:D13;COINCIDIR(MIN(SI(AÑO(C6:C13)=G6;C6:C13));C6:C13;)) O esta, de introducción normal: =INDICE(D6:D13;COINCIDIR(AGREGAR(15;6;C6:C13/(AÑO(C6:C13)=G6);1);C6:C13;)) ¡Bendiciones!
  22. Al introducir la fórmula, debes hacerlo con Ctrl + Shift + Enter. ¡Bendiciones!
  23. ¡Hola, @julayala! (y @GabrielRaigosa) Ten en cuenta los nombres de los respectivos programas que funcionan como hojas de cálculo. Una cosa es "Excel" y otra cosa es "Hojas de Cálculo de Google". Aunque hay varias cosas en común entre las dos, ciertamente difieren en la forma en que se trabajan ciertas cosas. Ten en cuenta que este es un foro de Excel, no de Hojas de Cálculo de Google. Ahora bien, puedes usar lo que te muestro en el adjunto, duplicando la hoja por cada Oficina que aparezca, y referenciándola en la celda B1. https://docs.google.com/spreadsheets/d/1Fw4eUWLjyl3U34JEHmrGf7GVPWEZYFZQ2LPPFV1CTro/edit?usp=sharing ¡Bendiciones!
  24. ¡Hola, @JSDJSD! El problema, puntualmente, está en el uso de la función Y. Puedes usar su forma booleana, la cual corresponde a la multiplicación, o hacer un doble SI, preguntando por cada condición. Entonces, la fórmula podría quedar así (no olvides el CSE : Ctrl + Shift + Enter) : =INDICE(D3:D11;MODA(SI((B3:B11=I3)*(C3:C11=J3);COINCIDIR(D3:D11;D3:D11;)))) =INDICE(D3:D11;MODA(SI(B3:B11=I3;SI(C3:C11=J3;COINCIDIR(D3:D11;D3:D11;))))) ¡Bendiciones!
  25. ¡Hola, @Carusha! Puedes usar la siguiente fórmula, en C2 y arrastrar hacia abajo según tu necesidad: =SI(B2;BUSCAR(2;1/(Programación!B$4:B$13=A2);Programación!D$4:D$13);"") Nota: Mi separador de argumentos es ";". Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema. ¡Bendiciones!
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png