Jump to content

Gerson Pineda

Administrators
  • Posts

    12,510
  • Joined

  • Last visited

  • Days Won

    446

Everything posted by Gerson Pineda

  1. En realidad es lo mismo que buscabas hacer, pero no tan directo Saludos!
  2. El resultado no es errático, solo que depende del resultado que buscas Las tablas, hacen referencias al rango completo de la misma, aquí ya no existe referencias relativas nativamente, por lo tanto la función lo toma como tal Pero afortunadamente siempre encontraremos métodos y formas de resolver problemas en Excel Algo mas, el formato tabla tiene mas ventajas respecto a rangos normales, comenzando pe: con el rango dinámico de sus filas Saludos
  3. Te adjunto un método que te permitirá redimensionar a unas coordenadas prestablecidas de la ventana de Excel y a partir de estas se va redimensionar el formulario También podrás trabajar en otras ventanas de Excel Saludos! Redimensiona formulario de acuerdo ventana Excel_GP.xlsm
  4. Hola 2 horas de proceso ufff me parece mucho tiempo... Si ese proceso te congela momentáneamente Excel, no te queda mas que usar una virtual Saludos
  5. Hola El comportamiento de las funciones utilizando formato de tabla estructurada, cambia respecto a las referencias Una forma sencilla de superarlo es usar referencias relativas de esas celdas Mira =SUMAR.SI.CONJUNTO(J$7:J7,C$7:C7,$C7) Saludos
  6. Mi versión para eliminar filas Saludos Eliminar filas eficientemente_GP.xlsm
  7. Hola Roxana Pero sin ver un archivo con tus "intentos" por tratar de resolverlo, no podremos hacer algún "intento" en darte una mejor orientación o ayuda Saludos
  8. Onkey, tiene un argumento opcional, que es llamar a un procedimiento, bueno ahi agregas el mensaje y listo Sub MostrarMensaje() If Application.OnKey Key:="{c}" Then "MiSub" End Sub Sub MiSub() VBA.MsgBox "Hola mundo" End Sub Saludos
  9. En el otro formulario, debe existir una hoja y tabla con el mismo nombre Corrígelo y te va funcionar Saludos
  10. Hola Por favor sube los archivos al foro, a menos que sean excesivamente grandes, aunque si es asi, puedes enviar solo una muestra y listo Nota: elimine tu enlace y subí el archivo Saludos
  11. Hola El fallo se da, porque estas encerrando la variable entre comillas, y esta variable es de tipo numero entero, por lo que debes dejarla tal cual, es decir elimina las comillas Saludos
  12. Te adjunto un ejemplo La celda A1 de la hoja2 tiene color de fondo, mismo que va tomar el textbox de la hoja1, cuando la hoja sea la activa Y si seleccionas el textbox, también va tener el mismo efecto, y si seleccionas una celda, se va quitar dicho color Saludos Textbox en hoja_GP.xlsm
  13. Siendo así, es complicado, pero también puedes unificar esas 2 tablas transaccionales, y poder hacer una medida mucho mas sencilla Como dato adicional, si el modelado de datos, no es adecuado, tendrás muchos problemas con las métricas Saludos
  14. Hola Debes tener relacionadas esas 3 tablas, de lo contrario, no va ser posible Eso es lo que te puedo mencionar, pues sin ver tu modelo y las medidas es difícil darte orientación certera Saludos!
  15. Es posible que tu libro contiene formulas volátiles y además incluyes columnas completas como referencia, formato condicional en exceso etc... Revisa eso, y trata de mejorarlo Saludos
  16. @paikerr como te va! Si porque es manual, pero lo resuelves de una manera simple, utilizando un evento como Open y listo Tal que: Hoja1.ScrollArea = "A1:H10" Saludos
  17. Hola Puedes utilizar la función ABS Saludos
  18. Si es una solución simple, pero que a mi llevo un tiempo detectarla [hace unos par de años], especialmente porque no había tenido la necesidad que tu, ahora tienes Y no es necesario que pongas el símbolo dólar, con solo digitar A1:A10 y dar intro, Excel lo deja fijo y pone los signos Saludos a todos!
  19. Y para ampliar, dado que a veces utilizamos mas de una vez esa linea, te recomiendo siempre, pero siempre declarar y activar el objeto Asi Dim cel As Range Set cel = ActiveCell y al final del procedimiento, siempre descargar ese objeto Set cel = Nothing De esta forma, "cel" será un objeto mas como Range Saludos
  20. Para obtener la fila activa, observa como trabaja el objeto Cells Cells(ActiveCell.Row, ActiveCell.Column) Cells(ActiveCell.Row, 14) Cells(ActiveCell.Row, "N") Saludos
  21. Como tu duda es general, ahora debes ser explicito y con archivo adjunto, para que detalles que es exactamente lo que deseas hacer Saludos
  22. Hola Adjunto otro método [utilizando en "memoria" la carga de datos] Saludos arraysW.xlsm
  23. También puedes configurar la hoja desde las propiedades en el proyecto VBA Mira la imagen Saludos
  24. Holas! Solo por acompañar a Silvia Una variante mas [te funcionara sea que el numero este o no, como texto] =INDICE(CNAE!$B$2:$B$617,COINCIDIR(--B6,--CNAE!$A$2:$A$617,),) Evitar en la medida de lo posible INDIRECTO, es parte de las funciones volátiles 😟 Saludos!
  25. A lo mejor es porque, debes cambiar la ruta actual donde esta tu CSV Para poder modificar esa ruta, debes irte al editor de PQ, y en el paso "origen" poder cambiar a tu ruta de la PC Lee un poco sobre power query en la red y luego regresas si tienes mas dudas o cualquier cosa me avisas Saludos
×
×
  • Create New...

Important Information

Privacy Policy