Jump to content

Formula convertir cadena a horas


Pirtrafilla

Recommended Posts

Buenos días. Tengo un fichero que descargo cada día de un aplicativo de la empresa que me vienen las horas y minutos en formato texto. La única manera que he conseguido de convertirlo a horas y minutos es con esta formula. Pero el problema me viene cuando las horas están en negativo, que me da error. Esto es de un archivo que me informa de las horas informadas por cada empleado en un registro de jornada, hay quien hace menos de su jornada o simplemente no ha venido y ahí es cuando viene en negativo. Lo tengo que convertir al formato adecuado para poder tratar el fichero. Adjunto un ejemplo.

Agradezco la ayuda.

 

Convertir a horas.xlsx

Link to comment
Share on other sites

Te puede servir en G2 y copiar hacia abajo:

=SI(E2="";D2;SI(D2="";"-"&TEXTO(E2;"hh:mm")))

PERO esas horas negativas son texto y no puedes operar matemáticamente con ellas... No puedes poner una hora en negativo y operar con ella, excepto si en Opciones de Excel -> Avanzadas, cambias en ese Libro al sistema de fechas 1904, lo cual tiene algunas consecuencias: https://learn.microsoft.com/es-es/office/troubleshoot/excel/1900-and-1904-date-system

Con ese sistema ya puedes utilizar horas negativas sin problema. Adjunto ambas posibilidades.

image.png.a5ba6ed1c473485863387a7531c18b44.png

Convertir a horas-FGV2.xlsx Convertir a horas-FGV3-1904.xlsx

Link to comment
Share on other sites

  • 2 weeks later...

Hola @Pirtrafilla,  no se aún haya tiempo de colaborar y si mi aporte te ayude en algo.

Por lo que entendí necesitas convertir la hora negativa en un formato de hora que pueda ser operable.

Te anexe un ejemplo esperando sea de ayuda.

 

Captura.JPG

Convertir a horas.xlsx

Link to comment
Share on other sites

Hola @Israel Cassales,

Ya dirá @Pirtrafilla pero lo que yo entendí es obtener el resultado de horas teniendo en cuenta el signo, que en el ejemplo  son -14.31, resultado de  09:29 positivas menos 24:00 negativas. En tu adjunto, la suma del rango D2:D23 es 33:29 horas, pero muestra 09:23 a causa del formato de la celda F26 (h:mm;@). Si le asignas el formato [h]:mm muestra 33:29. Un saludo, Fernando

Link to comment
Share on other sites

Hi @FGV 

Podemos sumar ideas, por lo que pude comprender el formato negativo le causa conflicto a @Pirtrafilla y para no entrar en opciones avanzadas podemos modificar el formato para poder tratar con todas.

Captura.jpg

Saludines

 

 

 

 

 

Edited by Israel Cassales
Eliminar Adjunto
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Privacy Policy